手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个通达信公式

[通达信]
设置
1545 9 肖锦阳 Lv.2 发表于 · 2020-10-26 21:01 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
条件:
1、红柱②的最高度小于①的最高度
2、红柱②的宽度(时间周期)小于①的宽度
3、上面两个条件满足后当macd再次金叉0轴即为买点

附件

2020-10-26_191745.png

举报

扔鸡蛋(0) 回复

肖锦阳
Lv.2
发表于 2020-10-29 17:50 复制 查看全部楼层
macd红柱的最高峰值小于前一波红柱的最高峰值的公式怎么表达呀

举报

点亮(0) 扔鸡蛋(0) 回复

肖锦阳
Lv.2
发表于 2020-10-28 15:03 复制 查看全部楼层
什么情况,没人能编出来吗,很难吗

举报

扔鸡蛋(0) 回复

肖锦阳
Lv.2
发表于 2020-10-27 12:13 复制 查看全部楼层
有没有高手能编写一下这个公式呀,万分感谢!!!

举报

点亮(0) 扔鸡蛋(0) 回复

一天行情
Lv.3
发表于 2020-10-27 06:56 复制 查看全部楼层
牛牛1888 发表于 2020-10-27 01:42
还是不理想

你说的对,我只是觉得用面积比较好,底背驰有时4次或以上。

举报

点亮(0) 扔鸡蛋(0) 回复

肖锦阳
Lv.2
发表于 2020-10-27 02:26 复制 查看全部楼层

公式共享一下呀,谢谢

举报

扔鸡蛋(0) 回复

肖锦阳
Lv.2
发表于 2020-10-27 02:22 复制 查看全部楼层
图片。。。。。。。。。。。。

附件

2020-10-27_021841.png

举报

扔鸡蛋(0) 回复

肖锦阳
Lv.2
发表于 2020-10-27 02:16 复制 查看全部楼层
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
MACD,COLOR777777;

VA1:=HHVBARS(MACD,BARSLAST(MACD<0)+1);
VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5);
QG:=CROSS(BACKSET(CROSS(0,MACD) OR (ISLASTBAR AND MACD>0),REF(VA1,1)+2),0.5);
前高:DRAWLINE(VA2,MACD,REF(VA2,1),REF(MACD,1),1),COLORGREEN;

红柱面积:IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),COLORRED;
绿柱面积:=ABS(IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0)),COLORBLUE;
MACD面积:=IF(MACD>0,红柱面积,绿柱面积),COLORFFFF00,NODRAW;

举报

点亮(0) 扔鸡蛋(0) 回复

牛牛1888
Lv.0
发表于 2020-10-27 01:42 复制 查看全部楼层
提示: 作者被禁止或删除 内容自动屏蔽

举报

扔鸡蛋(0) 回复

一天行情
Lv.3
发表于 2020-10-27 00:33 复制 查看全部楼层
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  : EMA(DIFF,9);
MACD : 2*(DIFF-DEA), COLORSTICK;
JC := DEA-DIFF;
绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIFF,DEA)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积)
AND 本次最低价<前次最低价 ),1,0);
RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
底背驰:= IF (CROSS(DIFF,DEA),REF(Y1,1),0);
DRAWTEXT(底背驰,-0.01,底背驰),COLOR00FFFF;
STICKLINE(底背驰,0,-0.01,4,0),COLOR0000FF;
DRAWICON(底背驰,0,23),COLORYELLOW;
DRAWBAND(DIFF,RGB(200,50,55),DEA,RGB(50,100,10));
遵:IF(DIFF>=DEA,DIFF,DRAWNULL),COLORRED;
守:IF(DEA>=DIFF,DEA,DRAWNULL),COLORFF9900;
纪:IF(DIFF>=DEA,DEA,DRAWNULL),COLOR00FFFF;
律:IF(DEA>=DIFF,DIFF,DRAWNULL),COLOR00FF00;
X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIFF)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
顶背驰:= IF (CROSS(DEA,DIFF),REF(Y2,1),0);
DRAWICON(顶背驰,0,19),COLOR00FF00;
STICKLINE(顶背驰,0,0.01,4,0),COLOR00FF00;
DRAWTEXT(顶背驰,0.01,顶背驰),COLORFF0000;
买:IFF(底背驰,0.1,0),COLOR0000FF;
卖:IFF(顶背驰,0.1,0),COLOR00FF00;
以上的源码公式讲解的是红柱线与绿柱线之间的面积形成的底背离,也就是底背驰的基本形态,是面积与股票价格之间的背离形态;
2020-10-27_003217.png

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表