最牛MACD(指标、副图,通达信,贴图)无加密

[通达信] 精华 1 315个推荐315
设置
69953 89 牛必红红 Lv.3 发表于 · 2020-10-27 15:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 石一峰 于 2020-10-28 08:29 编辑

前辈高人整理优化的MACD王牌指标,自认为还可以,MACD的钝化,高低位背离等都很简洁美观,如果有优化的高人也可以在此基础上优化,公式感觉不错,大家互相讨论学习,共进步,希望大家多留言,多点赞,多推荐,下载,多改进公式,使公式更完美

附件

1.png
2.png
3.png
最牛MACD.tn6 在线检测未来函数

10.34 KB, 下载次数: 432, 下载积分: 共享币 -20 个

查看全部打赏
  • 泫暻+2共享币 : 很给力,投资愉快,理想因你而精彩;
本主题由 任务系统 于 2020-12-4 05:30 解除限时高亮

举报

扔鸡蛋(0) 回复

大山9
Lv.2
发表于 2020-12-13 00:46 复制 查看全部楼层
不太会看,是什么意思

举报

扔鸡蛋(0) 回复

伍胥缘
Lv.2
发表于 2020-12-4 13:11 复制 查看全部楼层
谢谢楼主 现在就试试

举报

扔鸡蛋(0) 回复

乡下股民
Lv.6
发表于 2020-12-4 10:13 复制 查看全部楼层
确实非常直观,不错!

举报

扔鸡蛋(0) 回复

年年有魚
Lv.4
发表于 2020-12-4 10:05 复制 查看全部楼层
谢谢楼主分享!

参数这样设置,就通过了,铁达尼奥,你再试试看!


{【最牛MACD】(副图),2020-11-18-(3)}

{【MACD2】(副图), 指数平滑异同移动平均线,
     参数名      最小值   最大值    缺省值   

     SS            0       100        12               
     LL            0       100        26      
     MM         0       100        9      }

举报

扔鸡蛋(0) 回复

股迷233
Lv.1
发表于 2020-12-2 12:10 复制 查看全部楼层
楼主辛苦,谢谢分享!!!

举报

扔鸡蛋(0) 回复

铁达尼奥
Lv.2
发表于 2020-12-2 12:03 复制 查看全部楼层
年年有魚 发表于 2020-12-1 14:41
{【最牛MACD】(副图),2020-11-18-(3)}

{【MACD2】(副图), 指数平滑异同移动平均线,

我的一直不行

举报

扔鸡蛋(0) 回复

清竹2005
Lv.2
发表于 2020-12-1 15:08 复制 查看全部楼层
看上去很不错

举报

扔鸡蛋(0) 回复

年年有魚
Lv.4
发表于 2020-12-1 14:41 复制 查看全部楼层
{【最牛MACD】(副图),2020-11-18-(3)}

{【MACD2】(副图), 指数平滑异同移动平均线,
     参数名      最小值   最大值    缺省值   

     SS            0       100        12               
     LL            0       100        26      
     MM            0       100         9      }


DIF1:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL));
DEA1:=EMA(DIF1,MM);
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));

DIF:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL)),COLORWHITE;
DEA:=EMA(DIF,MM),COLORYELLOW;
DRAWBAND(DIF,RGB(155,50,50),DEA,RGB(0,100,50));
{DRAWBAND(DIF,RGB(255,0,0),DEA,RGB(0,100,50));}
MACD:(DIF-DEA)*2,COLORSTICK;

MACD120:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,120))),COLORRED,LINETHICK1;
MACD250:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,250))),COLORGREEN,LINETHICK1;
XG:=NOT(REF(MACD120,1)=MACD120);
STICKLINE(XG,0,MACD,1,0),COLORYELLOW;
STICKLINE(MACD>=MACD250,MACD250,MACD,1,0),COLORMAGENTA;
大行情:=NOT(REF(MACD120,1)=REF(MACD250,1)) AND MACD120=MACD250;
{DRAWTEXT(XG,0,'↖金柱'),COLORYELLOW;}
DRAWTEXT(大行情,0,'↖大牛启动'),COLORYELLOW;

{_抄底:ABS((CROSS("MACD.DIF","MACD.DEA") &&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;
_DIF:"MACD.DIF",COLORWHITE;
_DEA:"MACD.DEA",COLORYELLOW;
__强度:IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:IF(DEA<DIF,DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ABS(_抄底)>0,_抄底*1.20,' 抄底'),COLORYELLOW;
DRAWICON(ABS(_抄底)>0,_抄底*1.10,4);
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);}

死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);

STICKLINE(B OR BG,DIF,DEA,1,0),COLORRED;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.1),'钝化'),COLORYELLOW;
DRAWTEXT(FILTER(BG,10),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(底背离消失,10),DIF*1.1,'消失'),COLORGREEN;
STICKLINE(BG,0,DIF,1,0), COLORRED;


金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,DIF,1,0), COLORGREEN;
STICKLINE(T OR TG,DIF,DEA,1,0),COLORGREEN;
DRAWTEXT(FILTER(TG,20),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(顶背离消失,20),DIF*1.1,'消失'),COLORGREEN;

MACDDIF:=IF(ABS(MACD)>ABS(DIF),MACD,DIF);
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,MACDDIF*1.1,39),COLORGREEN;
DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,MACDDIF*1.1,38),COLORRED;

{精选金叉}
X_1:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
DDD:100*(X_1-X_2)*2,COLORFF00FF,LINETHICK2;
DDD2:EMA(DDD,9),COLORGREEN,LINETHICK2;
X_3:=CROSS(DDD,DDD2) AND DDD2>=0 AND DDD2<1.5 AND CLOSE/REF(CLOSE,1)>1 AND CLOSE>MA(CLOSE,5) AND CROSS(CLOSE,REF(HHV(HIGH,15),1));
DRAWICON(X_3,0,38);
STICKLINE(X_3,0,10,1,0),COLORBLUE;




举报

扔鸡蛋(0) 回复

年年有魚
Lv.4
发表于 2020-12-1 14:39 复制 查看全部楼层
设置简称参数通过了!

{【最牛MACD】(副图),2020-11-18-(3)}

{【MACD2】(副图), 指数平滑异同移动平均线,
     参数名      最小值   最大值    缺省值   

     SS            0       100        12               
     LL            0       100        26      
     MM         0       100        9      }


DIF1:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL));
DEA1:=EMA(DIF1,MM);
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));

…………

举报

点亮(0) 扔鸡蛋(0) 回复

铁达尼奥
Lv.2
发表于 2020-11-30 15:25 复制 查看全部楼层
垚鑫鑫 发表于 2020-11-30 12:13
兄弟,参数你设了吗?
SS(SHORT)     0       100        12               
     LL(LONG)      0     ...

设置了,
{【最牛MACD】(副图)
{DIF1:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL));}
DEA1:=EMA(DIF1,MM)
详细信息 : 在变量 DEA1 前又错误的定义一次变量!
错误起始位置 : 318 ; 长度: 4

举报

点亮(0) 扔鸡蛋(0) 回复

垚鑫鑫
Lv.2
发表于 2020-11-30 12:13 复制 查看全部楼层
铁达尼奥 发表于 2020-11-29 22:30
一样的老哥,错误字符SS

兄弟,参数你设了吗?
SS(SHORT)     0       100        12               
     LL(LONG)      0       100        26      
     MM(M)         0       100         9

举报

点亮(1) 扔鸡蛋(0) 回复

铁达尼奥
Lv.2
发表于 2020-11-29 22:30 复制 查看全部楼层
垚鑫鑫 发表于 2020-11-29 12:52
DIF1:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL));
DEA1:=EMA(DIF1,MM);
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB ...

一样的老哥,错误字符SS

举报

扔鸡蛋(0) 回复

铁达尼奥
Lv.2
发表于 2020-11-29 22:11 复制 查看全部楼层
通不过SS未知字符

举报

扔鸡蛋(0) 回复

单伟林
Lv.2
发表于 2020-11-29 15:23 复制 查看全部楼层
看这很清爽直观

举报

扔鸡蛋(0) 回复

垚鑫鑫
Lv.2
发表于 2020-11-29 12:53 复制 查看全部楼层
这个可以通过

举报

扔鸡蛋(0) 回复

垚鑫鑫
Lv.2
发表于 2020-11-29 12:52 复制 查看全部楼层
DIF1:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL));
DEA1:=EMA(DIF1,MM);
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));

DIF:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL)),COLORWHITE;
DEA:=EMA(DIF,MM),COLORYELLOW;
DRAWBAND(DIF,RGB(155,50,50),DEA,RGB(0,100,50));
{DRAWBAND(DIF,RGB(255,0,0),DEA,RGB(0,100,50));}
MACD:(DIF-DEA)*2,COLORSTICK;

MACD120:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,120))),COLORRED,LINETHICK1;
MACD250:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,250))),COLORGREEN,LINETHICK1;
XG:=NOT(REF(MACD120,1)=MACD120);
STICKLINE(XG,0,MACD,1,0),COLORYELLOW;
STICKLINE(MACD>=MACD250,MACD250,MACD,1,0),COLORMAGENTA;
大行情:=NOT(REF(MACD120,1)=REF(MACD250,1)) AND MACD120=MACD250;
{DRAWTEXT(XG,0,'↖金柱'),COLORYELLOW;}
DRAWTEXT(大行情,0,'↖大牛启动'),COLORYELLOW;

{_抄底:ABS((CROSS("MACD.DIF","MACD.DEA") &&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;
_DIF:"MACD.DIF",COLORWHITE;
_DEA:"MACD.DEA",COLORYELLOW;
__强度:IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:IF(DEA<DIF,DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ABS(_抄底)>0,_抄底*1.20,' 抄底'),COLORYELLOW;
DRAWICON(ABS(_抄底)>0,_抄底*1.10,4);
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);}

死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);

STICKLINE(B OR BG,DIF,DEA,1,0),COLORRED;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.1),'钝化'),COLORYELLOW;
DRAWTEXT(FILTER(BG,10),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(底背离消失,10),DIF*1.1,'消失'),COLORGREEN;
STICKLINE(BG,0,DIF,1,0), COLORRED;


金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,DIF,1,0), COLORGREEN;
STICKLINE(T OR TG,DIF,DEA,1,0),COLORGREEN;
DRAWTEXT(FILTER(TG,20),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(顶背离消失,20),DIF*1.1,'消失'),COLORGREEN;

MACDDIF:=IF(ABS(MACD)>ABS(DIF),MACD,DIF);
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,MACDDIF*1.1,39),COLORGREEN;
DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,MACDDIF*1.1,38),COLORRED;

{精选金叉}
X_1:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
DDD:100*(X_1-X_2)*2,COLORFF00FF,LINETHICK2;
DDD2:EMA(DDD,9),COLORGREEN,LINETHICK2;
X_3:=CROSS(DDD,DDD2) AND DDD2>=0 AND DDD2<1.5 AND CLOSE/REF(CLOSE,1)>1 AND CLOSE>MA(CLOSE,5) AND CROSS(CLOSE,REF(HHV(HIGH,15),1));
DRAWICON(X_3,0,38);
STICKLINE(X_3,0,10,1,0),COLORBLUE;

举报

扔鸡蛋(0) 回复

年年有魚
Lv.4
发表于 2020-11-29 11:07 复制 查看全部楼层
请楼主看看,为什么不能通过?

当前公式 : 最牛MACD (画线指标公式)  
错误句 :
DIF:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL)),COLORWHITE
详细信息 : 未知字符串 SS
错误起始位置 : 22 ; 长度: 2

为什么公式原码不全?

{【最牛MACD】(副图),2020-11-18-(3)}

{【MACD2】(副图), 指数平滑异同移动平均线,
     参数名      最小值   最大值    缺省值   

     SS(SHORT)     0       100        12               
     LL(LONG)      0       100        26      
     MM(M)         0       100         9      }


{【最牛MACD】(副图)
{DIF1:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL));
DEA1:=EMA(DIF1,MM);
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));}

DIF:=100*(EMA(CLOSE,SS)-EMA(CLOSE,LL)),COLORWHITE;
DEA:=EMA(DIF,MM),COLORYELLOW;
DRAWBAND(DIF,RGB(155,50,50),DEA,RGB(0,100,50));
{DRAWBAND(DIF,RGB(255,0,0),DEA,RGB(0,100,50));}
MACD:(DIF-DEA)*2,COLORSTICK;

MACD120:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,120))),COLORRED,LINETHICK1;
MACD250:=REF(MACD/2,BARSLAST(MACD=HHV(MACD,250))),COLORGREEN,LINETHICK1;
XG:=NOT(REF(MACD120,1)=MACD120);
STICKLINE(XG,0,MACD,1,0),COLORYELLOW;
STICKLINE(MACD>=MACD250,MACD250,MACD,1,0),COLORMAGENTA;
大行情:=NOT(REF(MACD120,1)=REF(MACD250,1)) AND MACD120=MACD250;
{DRAWTEXT(XG,0,'↖金柱'),COLORYELLOW;}
DRAWTEXT(大行情,0,'↖大牛启动'),COLORYELLOW;

{_抄底:ABS((CROSS("MACD.DIF","MACD.DEA") &&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;
_DIF:"MACD.DIF",COLORWHITE;
_DEA:"MACD.DEA",COLORYELLOW;
__强度:IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:IF(DEA<DIF,DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ABS(_抄底)>0,_抄底*1.20,' 抄底'),COLORYELLOW;
DRAWICON(ABS(_抄底)>0,_抄底*1.10,4);
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);}

死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);

STICKLINE(B OR BG,DIF,DEA,1,0),COLORRED;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.1),'钝化'),COLORYELLOW;
DRAWTEXT(FILTER(BG,10),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(底背离消失,10),DIF*1.1,'消失'),COLORGREEN;
STICKLINE(BG,0,DIF,1,0), COLORRED;


金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,DIF,1,0), COLORGREEN;
STICKLINE(T OR TG,DIF,DEA,1,0),COLORGREEN;
DRAWTEXT(FILTER(TG,20),(DIF*1.1),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(顶背离消失,20),DIF*1.1,'消失'),COLORGREEN;

MACDDIF:=IF(ABS(MACD)>ABS(DIF),MACD,DIF);
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,MACDDIF*1.1,39),COLORGREEN;
DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,MACDDIF*1.1,38),COLORRED;

{精选金叉}
X_1:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
DDD:100*(X_1-X_2)*2,COLORFF00FF,LINETHICK2;
DDD2:EMA(DDD,N),COLORGREEN,LINETHICK2;
X_3:=CROSS(DDD,DDD2) AND DDD2>=0 AND DDD2<1.5 AND CLOSE/REF(CLOSE,1)>1 AND CLOSE>MA(CLOSE,5) AND CROSS(CLOSE,REF(HHV(HIGH,15),1));
DRAWICON(X_3,0,38);
STICKLINE(X_3,0,10,1,0),COLORBLUE;




举报

扔鸡蛋(0) 回复

牛必红红
Lv.3
发表于 2020-11-28 19:19 复制 查看全部楼层

举报

扔鸡蛋(0) 回复

再望江南
Lv.2
发表于 2020-11-25 22:39 复制 查看全部楼层
一个人分享一次副图并不难,
难的是每次都把主图一起分享出来,
这才是最牛必最牛必
的啊!

举报

点亮(0) 扔鸡蛋(0) 回复

年年有魚
Lv.4
发表于 2020-11-22 16:02 复制 查看全部楼层
下载了,不能用?

举报

扔鸡蛋(0) 回复

肖锦阳
Lv.2
发表于 2020-11-21 18:15 复制 查看全部楼层
真不知道牛逼在哪里

举报

扔鸡蛋(0) 回复

估值技术
Lv.2
发表于 2020-11-21 17:55 复制 查看全部楼层
牛必红红 发表于 2020-11-21 09:40
就一个MACD指标而已,MACD指标可以配合任何主图使用,高手甚至可以不配合主图而单独使用,这个帖子只是分 ...

你说的也有道理,毕竟现在伸手党多,有共享精神的人少。我不应该打压共享精神,我做错了。

举报

点亮(0) 扔鸡蛋(0) 回复

有道同花
Lv.2
发表于 2020-11-21 11:14 复制 查看全部楼层
源码有吗?求共享

举报

扔鸡蛋(0) 回复

有道同花
Lv.2
发表于 2020-11-21 11:13 复制 查看全部楼层
最经典的指标才是王道,比那很多骗人的金钻指标更好用

举报

扔鸡蛋(0) 回复

杨羽新手
Lv.3
发表于 2020-11-21 10:12 复制 查看全部楼层
非常不错的指标,就是你这个分享币要20个,我下载不了

举报

点亮(0) 扔鸡蛋(0) 回复

牛必红红
Lv.3
发表于 2020-11-21 09:40 复制 查看全部楼层
估值技术 发表于 2020-11-20 18:21
不,你误会了。散户要赚两个钱,不容易。你截图有主图指标,也许是配合着用的,也许不是。有人问到了你的 ...

就一个MACD指标而已,MACD指标可以配合任何主图使用,高手甚至可以不配合主图而单独使用,这个帖子只是分享这个MACD指标而已,其他的我愿意分享自然会分享,但没有一定要分享的义务,一切分享都是遵从自愿的原则,也并没有吊人的胃口

举报

点亮(1) 扔鸡蛋(0) 回复

无敌就是
Lv.3
发表于 2020-11-20 20:41 复制 查看全部楼层
散户要赚两个钱,不容易,也没用法,直接说就是看图。真考验一个人悟性了,每个图含义都不一样,天天看累死了

举报

点亮(0) 扔鸡蛋(0) 回复

估值技术
Lv.2
发表于 2020-11-20 18:21 复制 查看全部楼层
牛必红红 发表于 2020-11-20 15:10
其实吧,这个论坛的基本上都是垃圾,懂的自然懂,不懂的自然不懂!大神些哪看这些指标,直接就只看裸K线 ...

不,你误会了。散户要赚两个钱,不容易。你截图有主图指标,也许是配合着用的,也许不是。有人问到了你的主图指标,按照论坛的共享精神,你应该同时送给人家。我认为你吊着人家的胃口这做法不妥,所以才恶评。如果你自己平时就是配合着用的话,我认为应该同时送出。人人都献出一点爱,社会才会更美好,对吧。

举报

点亮(0) 扔鸡蛋(0) 回复

关才人
Lv.2
发表于 2020-11-20 15:53 复制 查看全部楼层
有没有TXt格式的

举报

扔鸡蛋(0) 回复

牛必红红
Lv.3
发表于 2020-11-20 15:10 复制 查看全部楼层
估值技术 发表于 2020-11-18 08:42
连MACD都要改成这么垃圾,那个主图能好到哪去。

其实吧,这个论坛的基本上都是垃圾,懂的自然懂,不懂的自然不懂!大神些哪看这些指标,直接就只看裸K线就OK了,你一定是大师级别,肯定不用看这些垃圾指标的

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表