手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改成选股公式

[通达信]
设置
1306 2 四季3313 Lv.3 发表于 · 2020-10-27 15:58 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
有一组公式,想改成选股用  通达信用

DRAWKLINE(H,O,L,C);

BOLL:IF(N=0,MA(CLOSE,N2),DRAWNULL),LINETHICK2,COLOR400080;

UB:IF(N=0,MA(C,N2)+1.2*STD(CLOSE,N2),DRAWNULL),COLOR339900;

LB:IF(N=0,MA(C,N2)-1.2*STD(CLOSE,N2),DRAWNULL),COLOR2693FF;

UB1:=IF(N=0,MA(C,N2)+2*STD(CLOSE,N2),DRAWNULL),DOTLINE,COLORBLUE;

LB1:=IF(N=0,MA(C,N2)-2*STD(CLOSE,N2),DRAWNULL),DOTLINE,COLORBLUE;

MA5:=IF(N=0,MA(C,5),DRAWNULL),COLORLIMAGENTA;

MA60:IF(N=0,MA(C,60),DRAWNULL),LINETHICK2,COLORRED;

MA250:=IF(N=0,MA(C,250),DRAWNULL),LINETHICK2,COLORLIRED;

均线1:IF(N,MA(C,N1),DRAWNULL),COLORWHITE;

均线2:IF(N,MA(C,N2),DRAWNULL),COLORWHITE;

均线3:IF(N,MA(C,N3),DRAWNULL),COLORWHITE;

IF(均线1>REF(均线1,1) AND N,均线1,DRAWNULL),LINETHICK3,COLORWHITE;

IF(均线2>REF(均线2,1) AND N,均线2,DRAWNULL),LINETHICK3,COLORWHITE;

IF(均线3>REF(均线3,1) AND N,均线3,DRAWNULL),LINETHICK3,COLORWHITE;

{扣底手指形图标}

HD1:=1.003;

DRAWICON(CURRBARSCOUNT=20,H*HD1,13);

DRAWICON(CURRBARSCOUNT=60,H*HD1,13);

{

DRAWTEXT_FIX(ISLASTBAR AND A3<=A4 AND DF4*100<20,0.650,HG2,0,TEXT_2),COLORRED;

DRAWTEXT_FIX(ISLASTBAR AND (A3>A4 OR (A3<A4 AND DF4*100>20)),0.65,HG2,0,TEXT_2),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR,0.79,HG2,0,'%'),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.74,HG2,0,CON2STR(BF*100,2));

};

DS1:=IF(KDJ.K#DAY>KDJ.D#DAY,1,0);

DS2:=IF(KDJ.K#DAY<KDJ.D#DAY,-1,0);

ZS1:=IF(KDJ.K#WEEK>KDJ.D#WEEK,2,0);

ZS2:=IF(KDJ.K#WEEK<KDJ.D#WEEK,-2,0);

MS1:=IF(KDJ.K#MONTH>KDJ.D#MONTH,3,0);

MS2:=IF(KDJ.K#MONTH<KDJ.D#MONTH,-3,0);

SS1:=IF(KDJ.K#SEASON>KDJ.D#SEASON,4,0);

SS2:=IF(KDJ.K#SEASON<KDJ.D#SEASON,-4,0);

KDSUM:=DS1+ZS1+MS1+SS1;

KDSAM:=DS2+ZS2+MS2+SS2;

DRAWTEXT_FIX(ISLASTBAR,0.15,0.06,0,'KD多空比'),COLORBLUE;

DRAWTEXT_FIX(ISLASTBAR,0.17,0.12,0,':'),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.15,0.12,0,CON2STR(KDSUM,0)),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0.18,0.12,0,CON2STR(KDSAM,0)),COLORBLUE;

DRAWTEXT_FIX(ISLASTBAR,0.01,0.06,0,'20扣抵'),COLORMAGENTA;

DRAWTEXT_FIX(CURRBARSCOUNT=20,0.01,0.12,0,VAR2STR(CLOSE,2)),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0.06,0.06,0,'60扣抵'),COLORBLUE;

DRAWTEXT_FIX(CURRBARSCOUNT=60,0.06,0.12,0,VAR2STR(CLOSE,2)),COLORBLUE;

1 股价在UB以外,且UB向上,且角度30度到60度

1.jpg

2 股价在UB以内,且UB向上,且角度30度到60度
2.jpg

3 股价在UB以外,且UB向上,且角度30度到60度,成交量相比昨天(或者上个周期)放大
3.jpg

4 股价回到中轴,且中轴以30到60度角度向上
4.jpg


多谢各位

举报

扔鸡蛋(0) 回复

四季3313
Lv.3
发表于 2020-10-27 19:39 复制 查看全部楼层
周游25 发表于 2020-10-27 17:14
公式没有N 、N2等,不便于修改,

QQ截图20201027193928.png

感谢

举报

扔鸡蛋(0) 回复

周游25
Lv.2
发表于 2020-10-27 17:14 复制 查看全部楼层
本帖最后由 周游25 于 2020-10-27 17:16 编辑

公式没有N 、N2等,不便于修改,

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表