手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把金财神主图出现红柱时改成选股公式

[通达信]
设置
1621 2 丹东千千结 Lv.3 发表于 · 2020-10-28 23:03 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
拜托了。

M5:MA(CLOSE,5);
M10:MA(CLOSE,10);
M30:MA(CLOSE,30);
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
BUY1:=ZIG(3,10);
SELL1:=MA(BUY1,2);
DRAWICON(CROSS(BUY1,SELL1),L-0.1,7);
DRAWICON(CROSS(SELL1,BUY1),H+0.1,8);
STICKLINE(BUY1>SELL1 AND O>=C,C,O,-1,0),COLORRED;
STICKLINE(BUY1>SELL1 AND O>=C,L,H,0,0),COLORRED;
STICKLINE(BUY1<SELL1 AND O<=C,O,C,-1,1),COLORCYAN;
STICKLINE(BUY1<SELL1 AND O<=C,O,L,0,1),COLORCYAN;
STICKLINE(BUY1<SELL1 AND O<=C,C,H,0,1),COLORCYAN;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
LJB:=1/WINNER(CLOSE);

举报

扔鸡蛋(0) 回复

丹东千千结
Lv.3
发表于 2020-10-29 00:16 复制 查看全部楼层
苏连城 发表于 2020-10-28 23:24
BUY1:=ZIG(3,10);
SELL1:=MA(BUY1,2);
XG:BUY1>SELL1 AND O>=C;

谢谢老师!辛苦了 更要谢谢老师的提醒。祝老师一生好运

举报

点亮(2) 扔鸡蛋(0) 回复

苏连城
Lv.3
发表于 2020-10-28 23:24 复制 查看全部楼层
BUY1:=ZIG(3,10);
SELL1:=MA(BUY1,2);
XG:BUY1>SELL1 AND O>=C;
{注意未来函数,参考意义不大}

举报

点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表