请老师帮助编写个选股公式

[通达信]
设置
2103 11 刘写乐乐 Lv.3 发表于 · 2020-11-1 13:06 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
条件是粉红色K线和“买”字同时出现的时候选股公式;谢谢
以下是主图源码:
E40:EXPMA(CLOSE,40);
工作线:=MA(CLOSE,1);
M3:MA(CLOSE,3)COLORRED;
M13:MA(CLOSE,13)COLORGREEN;
收:C,COLORRED,NODRAW;
高:H,NODRAW;
三:C*1.0348,NODRAW;
五:C*1.055,NODRAW;
八:C*1.0848,NODRAW;
十:C*1.1048,NODRAW;
十五:C*1.1548,NODRAW;
廿:C*1.2048,NODRAW;
止:C*(1-0.025),NODRAW;

TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
稻壳1:EMA(CLOSE,144),POINTDOT,COLORWHITE;
稻壳2:EMA(C,318);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
DRAWICON(CROSS(ZX,C),H*1.01,2);
{DRAWTEXT(CROSS(工作线,M13)AND J<55,LOW,'入')COLORWHITE;}
DRAWTEXT(CROSS(CLOSE,TT1)AND J<55,LOW,'买'),COLORRED;
DRAWTEXT(CROSS(88,RSI),HIGH * 1.02,'顶'),COLOR00FFFF;
{DRAWTEXT(FF1,L*0.99,'超短'),COLOR00FF00;}
STICKLINE(TT3,OPEN,CLOSE,3,0),COLORFF00FF;
{STICKLINE(TT4,OPEN,CLOSE,3,0),COLORGREEN;};
日跌: L*0.99,NODRAW,COLORFF00FF;
周跌: L*0.94,NODRAW,COLORFF00FF;

举报

扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-11-5 00:40 复制 查看全部楼层
本帖最后由 刘写乐乐 于 2020-11-5 00:42 编辑

不太严密,顺钠股份000533没有选出来,智慧农业选出来,但是滞后好多天了

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-4 08:51 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-11-4 08:53 编辑
刘写乐乐 发表于 2020-11-3 23:47
谢谢,那个数字是天数啊,我对这个一窍不通,谢谢你了。
再麻烦老师帮个忙,写个选股预警公式。上面的 ...


试试指标行不行

DW:=V=HHV(V,40) AND C<O;
T:=BARSLAST(DW);
TJ:=REF(HHV(C,T)<REF(O,T),1) AND  CROSS(C>REF(O,T),0.5);
T2:=BARSLAST(TJ);
XG:COUNT(CROSS(C>REF(O,T),0.5),T2)>0  AND T2>0 AND C/REF(C,1)>1.06;

附件

tdxjietu2.JPG
tdxjietu3.JPG

举报

点亮(1) 扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-11-3 23:47 复制 查看全部楼层
本帖最后由 刘写乐乐 于 2020-11-4 08:23 编辑
许昌舍得 发表于 2020-11-3 11:06
条件由30天 改为40天的大阴


谢谢,那个数字是天数啊,我对这个一窍不通,谢谢你了。
再麻烦老师帮个忙,写个选股预警公式。上面的公式选出40天以来过前大阴实顶以后,回调的很多,现在想回调后再次站上突破前大阴实顶的选股预警公式,麻烦你了

附件

22.png
111.png
33.png

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-3 11:06 复制 查看全部楼层
刘写乐乐 发表于 2020-11-3 10:39
说的不太严密,指的是选股时候的价格高于大阴线实顶的价格,期间的K线实顶都低于大阴线的实顶价格,这样 ...


条件由30天 改为40天的大阴


DW:=V=HHV(V,40) AND C<O;
T:=BARSLAST(DW);


TJ:REF(HHV(C,T)<REF(O,T),1) AND  CROSS(C>REF(O,T),0.5);

附件

tdxjietu1.JPG
tdxjietu2.JPG
查看全部打赏
  • 刘写乐乐+20理想币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-11-3 10:39 复制 查看全部楼层

说的不太严密,指的是选股时候的价格高于大阴线实顶的价格,期间的K线实顶都低于大阴线的实顶价格,这样,大庆华科就符合条件了,老师再看看怎么改一下

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-3 08:37 复制 查看全部楼层
刘写乐乐 发表于 2020-11-2 23:56
麻烦老师帮改这个指标,改成高阴量柱到选股的时候之间的K线实体最高价都低于高阴量柱和选股时候的价格, ...


DW:=V=HHV(V,30) AND C<O;
T:=BARSLAST(DW);


TJ:REF(HHV(H,T)<REF(O,T),1) AND  CROSS(C,REF(O,T));


大庆华科不符合你的条件

附件

tdxjietu1.JPG
tdxjietu2.JPG
tdxjietu3.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

刘写乐乐
Lv.3
发表于 2020-11-2 23:56 复制 查看全部楼层
许昌舍得 发表于 2020-11-1 13:15
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LO ...

麻烦老师帮改这个指标,改成高阴量柱到选股的时候之间的K线实体最高价都低于高阴量柱和选股时候的价格,今日股价过高阴量柱顶预警,谢谢
源码:

DW:=V=HHV(V,30) AND C<O;
CROSS(C,REF(O,BARSLAST(DW)));

附件

22.png
111.png

举报

点亮(0) 扔鸡蛋(0) 回复

风含笑204
Lv.2
发表于 2020-11-2 13:27 复制 查看全部楼层
许昌舍得 发表于 2020-11-2 09:10
爆发点:=(DCLOSE-REF(C,1))/REF(C,1)*100;
XG:CROSS(爆发点,20) OR CROSS(爆发点,18);

好的   谢谢老师提醒      我是用下面的公式吗

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-2 09:10 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-11-2 14:16 编辑
风含笑204 发表于 2020-11-1 22:19
{起爆点}
H1:=EMA(DCLOSE,5);
A1:=LLV(DCLOSE,5);






未来性质,谨慎使用
查看全部打赏
  • 风含笑204+10理想币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(0) 扔鸡蛋(0) 回复

风含笑204
Lv.2
发表于 2020-11-1 22:19 复制 查看全部楼层
许昌舍得 发表于 2020-11-1 13:15
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LO ...


{起爆点}
H1:=EMA(DCLOSE,5);
A1:=LLV(DCLOSE,5);
A2:=A1+1/CURRBARSCOUNT*N;
A3:=IF(CURRBARSCOUNT<20 AND A1>REF(A1,1),CONST(REF(A2,10)),A1);
A4:=MA(A3,10);
A5:=H1+1/CURRBARSCOUNT*M;
A6:=IF(CURRBARSCOUNT<20 AND A1>REF(A1,1),CONST(REF(A5,10)),A3);
A7:MA(A6,10);
L1:=LLV(L,10);
DRAWBAND(A4,90,L1,RGB(35,135,35));
DRAWBAND(A7,90,A4,90);
敢死队操作线:MA(C,24),LINETHICK2,COLORLIMAGENTA;
操作线2:MA(C,26),LINETHICK1,COLORLICYAN;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
爆发点:=(DCLOSE-REF(C,1))/REF(C,1)*100;
XG:=CROSS(爆发点,20) OR CROSS(爆发点,18);
L3:IF(XG,O,L1*0.999),COLORYELLOW;
STICKLINE(XG,L3,L3,100,0);
DRAWTEXT(XG,L3,'起爆点'),COLORMAGENTA;
DRAWTEXT_FIX(C>O,0.01,0.01,0,' W'),COLORYELLOW;


麻烦许老师   在出现起爆点   三个字的  第二天   做个预警公式    另外在恳请把   理想论坛的  网站都去掉   万分感谢

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-1 13:15 复制 查看全部楼层
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;

买:CROSS(CLOSE,TT1)AND J<55;
查看全部打赏
  • 刘写乐乐+20理想币 : 很给力,投资愉快,理想因你而精彩;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表