手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改编个可用于通达信的分时公式

[通达信]
设置
1235 2 南国峰 Lv.2 发表于 · 2020-11-1 14:59 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MA20: =EMA(CLOSE, 20);
多空:EMA( CLOSE,800);
STICKLINE((MA20>多空),MA20,多空,1,0), COLORRED;
STICKLINE((MA20<多空),MA20,多空,1,0), COLORGREEN;
H1: =MAX (DYNAINFO(3. 19), DYNAINFO(5. 17));
L1: =MIN(DYNAINFO(3. 16), DYNAINFO(6. 18));
P1:=H1-L1;
压力:L1+P1*9/10, COLORGREEN;
支撑:L1+P1*0.5/10, COLORRED;
现价:CLOSE, COLORBLUE, LINETHICK3;
STICKLINE(CROSS(支撑,现价),支撑,压力,1.5,0),COLORRED;
STICKLINE(CROSS(现价,压力),现价,支撑,1.5,0),COLOGREEN;
DRAVTEXT (LONGCROSS((支撑,现价,2),支撑*1.0001,'*分时买
'), COLORRED;{吸}
DRAVTEXT(LONGCROSS(现价,压力,2),现价,'*分时卖'), COLORGREEN;{抛};


安装时出现的问题

错误句 : MA20: =EMA(CLOSE, 20);
多空:EMA( CLOSE,800);
STICKLINE((MA20>多空),MA20,多空,1,0), COLORRED;
STICKLINE((MA20<多空),MA20,多空,1,0), COLORGREEN;
H1: =MAX (DYNAINFO(3. 19), DYNAINFO(5. 17));
L1: =MIN(DYNAINFO(3. 16), DYNAINFO(6. 18));
P1:=H1-L1
详细信息 : 在变量 多空 前又错误的定义一次变量!
错误起始位置 : 26 ; 长度: 4

举报

扔鸡蛋(0) 回复

南国峰
Lv.2
发表于 2020-11-1 16:12 复制 查看全部楼层
勤学务实 发表于 2020-11-1 15:35
MA20:= EMA(CLOSE, 20),NODRAW;
多空:= MEMA(CLOSE,800),NODRAW;
STICKLINE((MA20>多空),MA20,多空,1,0), ...

谢谢你

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-11-1 15:35 复制 查看全部楼层
MA20:= EMA(CLOSE, 20),NODRAW;
多空:= MEMA(CLOSE,800),NODRAW;
STICKLINE((MA20>多空),MA20,多空,1,0),COLORRED;
STICKLINE((MA20<多空),MA20,多空,1,0),COLORGREEN;
H1:= MAX(DYNAINFO(3.19),DYNAINFO(5.17)),NODRAW;
L1:= MIN(DYNAINFO(3.16),DYNAINFO(6.18)),NODRAW;
P1:= H1-L1,NODRAW;
压力:= L1+P1*9/10,COLORGREEN;
支撑:= L1+P1*0.5/10,COLORRED;
现价:= CLOSE,COLORBLUE,LINETHICK3;
STICKLINE(CROSS(支撑,现价),支撑,压力,1.5,0),COLORRED;
STICKLINE(CROSS(现价,压力),现价,支撑,1.5,0),COLORGREEN;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.0001,'*分时买'),COLORRED;{吸}
DRAWTEXT(LONGCROSS(现价,压力,2),现价,'*分时卖'), COLORGREEN;{抛};
查看全部打赏
  • 南国峰+1共享币 : 很给力,投资愉快,理想因你而精彩;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表