请老师帮忙改写个选股公式

[通达信]
设置
2034 15 月生112 Lv.3 发表于 · 2020-11-1 15:47 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙改写个选股公式:当黄线变成红线第一天时做选股指标。谢谢

源码如下:
HZ:=HHV((H+L)/2,120);
AA:=(2*C+H+L)/4;
VAR1:=IF(DATE=10301201,0,1);
VAR2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
VAR3:=EMA(CLOSE,3);
VAR4:=(2*CLOSE+LOW+HIGH)/4*VAR1;
VAR5:=VAR2-VAR3;
VAR6:=CLOSE*VOL;
VAR7:=EMA((EMA(VAR6,3)/EMA(VOL,3)+EMA(VAR6,6)/EMA(VOL,6)+EMA(VAR6,12)/EMA(VOL,12)+EMA(VAR6,24)/EMA(VOL,24))/4,13);
VAR8:=EMA(CLOSE,9);
VAR9:=(CLOSE+OPEN)/2;
上轨1:=EMA(VAR8*1.14,15),COLORGREEN,LINETHICK1;
黄线:=(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,LINETHICK1;
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
黄牛线:EMA(HH,90),COLORYELLOW,LINETHICK2;
离合3:黄牛线-((C-黄牛线)*C-黄牛线)/黄牛线,LINETHICK2,COLORLIRED;
TP1:=CROSS(黄牛线,离合3);
DRAWICON(TP1,LOW,34);
道2:6*HHV(黄牛线,3)-5*黄牛线;
IF(黄线>=道2,黄牛线,DRAWNULL),LINETHICK3,COLORRED;
IF(C<=上轨1,黄牛线,DRAWNULL),LINETHICK3,COLORYELLOW;

附件

20201101154203.png

举报

扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-2 12:44 复制 查看全部楼层
注册111 发表于 2020-11-2 12:19
前面看错了,这次对了。
APX:=(H+L+C+O)/4;
TR0:=MAX(H-L,MAX(ABS(H-REF(C,1)),ABS(L-REF(C,1))));

谢谢老师耐心的帮助~~~

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-2 12:19 复制 查看全部楼层
月生112 发表于 2020-11-2 10:24
老师你好  不是  

条件是:1、 股价突破所有线(股价在所有线线值上面)      2、C15线在其它线的最下 ...

前面看错了,这次对了。
APX:=(H+L+C+O)/4;
TR0:=MAX(H-L,MAX(ABS(H-REF(C,1)),ABS(L-REF(C,1))));
MF0:=C-REF(C,2);
MF1:=REF(MF0,1);
MF2:=REF(MF0,2);
DIRECT1:=BARSLAST(MF0>MF1 AND MF0>MF2);
DIRECT2:=BARSLAST(MF0<MF1 AND MF0<MF2);
DIRECT0:=IF(DIRECT1<DIRECT2,100,-100);
TBP:=REF(REF(C,1)+IF(DIRECT0>50,MIN(MF0,MF1),MAX(MF0,MF1)),1)COLORYELLOW;
C1:=REF(TBP,1) ;
C2:=REF(TBP,2) ;
C3:=REF(TBP,3) ;
C4:=REF(TBP,4) ;
C5:=REF(TBP,5) ;
C15:=REF(TBP,15);
RL3:=REF(L,1)*(1+1.4*0.01);
CROSS(C>MAX6(C1,C3,C4,C5,C15,RL3)&&C15<MIN6(C1,C2,C3,C4,C5,RL3),0.5);
查看全部打赏
  • 月生112+18理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-2 10:24 复制 查看全部楼层
注册111 发表于 2020-11-2 07:19
是这个意思吗。
APX:=(H+L+C+O)/4;
TR0:=MAX(H-L,MAX(ABS(H-REF(C,1)),ABS(L-REF(C,1))));

老师你好  不是  

条件是:1、 股价突破所有线(股价在所有线线值上面)      2、C15线在其它线的最下面。  

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-2 07:19 复制 查看全部楼层
月生112 发表于 2020-11-1 20:35
再麻烦老师给改写个选股指标  谢谢

条件:K线在线内不操作, C15线在最下面股价突破所有线

是这个意思吗。
APX:=(H+L+C+O)/4;
TR0:=MAX(H-L,MAX(ABS(H-REF(C,1)),ABS(L-REF(C,1))));
MF0:=C-REF(C,2);
MF1:=REF(MF0,1);
MF2:=REF(MF0,2);
DIRECT1:=BARSLAST(MF0>MF1 AND MF0>MF2);
DIRECT2:=BARSLAST(MF0<MF1 AND MF0<MF2);
DIRECT0:=IF(DIRECT1<DIRECT2,100,-100);
TBP:=REF(REF(C,1)+IF(DIRECT0>50,MIN(MF0,MF1),MAX(MF0,MF1)),1)COLORYELLOW;
C1:=REF(TBP,1);
C2:=REF(TBP,2);
C3:=REF(TBP,3);
C4:=REF(TBP,4);
C5:=REF(TBP,5);
C15:=REF(TBP,15);
RL3:=REF(L,1)*(1+1.4*0.01);
CROSS(BARSLAST(C15<MIN6(C1,C2,C3,C4,C5,RL3))&&
C15>MAX6(C1,C2,C3,C4,C5,RL3),0.5);

举报

点亮(2) 扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-1 20:35 复制 查看全部楼层
注册111 发表于 2020-11-1 19:52
变色线它们的条件不一样造成的。用了过滤10天。但10天内又出现黄变红就被过滤了。过了10天还会出现你说 ...

再麻烦老师给改写个选股指标  谢谢

条件:K线在线内不操作, C15线在最下面股价突破所有线

源码:
APX:=(H+L+C+O)/4;
TR0:=MAX(H-L,MAX(ABS(H-REF(C,1)),ABS(L-REF(C,1))));
MF0:=C-REF(C,2);
MF1:=REF(MF0,1);
MF2:=REF(MF0,2);
DIRECT1:=BARSLAST(MF0>MF1 AND MF0>MF2);
DIRECT2:=BARSLAST(MF0<MF1 AND MF0<MF2);
DIRECT0:=IF(DIRECT1<DIRECT2,100,-100);
TBP:=REF(REF(C,1)+IF(DIRECT0>50,MIN(MF0,MF1),MAX(MF0,MF1)),1)COLORYELLOW;
C1:REF(TBP,1),COLORBLUE;
C2:REF(TBP,2),COLORGREEN;
C3:REF(TBP,3),COLORCYAN;
C4:REF(TBP,4),COLORRED;
C5:REF(TBP,5),COLORMAGENTA;
C15:REF(TBP,15),COLORWHITE,LINETHICK3;
RL3:REF(L,1)*(1+1.4*0.01),COLORYELLOW,LINETHICK2;

举报

点亮(0) 扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-1 19:58 复制 查看全部楼层
注册111 发表于 2020-11-1 19:52
变色线它们的条件不一样造成的。用了过滤10天。但10天内又出现黄变红就被过滤了。过了10天还会出现你说 ...

谢谢老师的指点 明白了

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-1 19:52 复制 查看全部楼层
本帖最后由 注册111 于 2020-11-1 19:54 编辑
月生112 发表于 2020-11-1 17:20
比如设定10月22日选股 里面有002304 但它10月20日就由黄变红了  300304   10月13日由黄变红了  300312  ...


变色线它们的条件不一样造成的。用了过滤10天。但10天内又出现黄变红就被过滤了。过了10天还会出现你说现象。如果觉得时间短的话把最后一项的10放大至15或20;
HZ:=HHV((H+L)/2,120);
AA:=(2*C+H+L)/4;
VAR1:=IF(DATE=10301201,0,1);
VAR2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
VAR3:=EMA(CLOSE,3);
VAR4:=(2*CLOSE+LOW+HIGH)/4*VAR1;
VAR5:=VAR2-VAR3;
VAR6:=CLOSE*VOL;
VAR7:=EMA((EMA(VAR6,3)/EMA(VOL,3)+EMA(VAR6,6)/EMA(VOL,6)+EMA(VAR6,12)/EMA(VOL,12)+EMA(VAR6,24)/EMA(VOL,24))/4,13);
VAR8:=EMA(CLOSE,9);
VAR9:=(CLOSE+OPEN)/2;
上轨1:=EMA(VAR8*1.14,15),COLORGREEN,LINETHICK1;
黄线:=(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,LINETHICK1;
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210 ;
黄牛线:=EMA(HH,90);
道2:=6*HHV(黄牛线,3)-5*黄牛线;
A1:=IF(黄线>=道2,黄牛线,DRAWNULL);
A2:=IF(C<=上轨1,黄牛线,DRAWNULL);
FILTER(A2=DRAWNULL&&A1<>DRAWNULL,10);
查看全部打赏
  • 月生112+18理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(3) 扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-11-1 17:20 复制 查看全部楼层
月生112 发表于 2020-11-1 16:44
谢谢老师帮忙 但不准的。

再试试看应该没问题了

举报

扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-1 17:20 复制 查看全部楼层
本帖最后由 月生112 于 2020-11-1 17:26 编辑
注册111 发表于 2020-11-1 17:14
请说个股票代码与日期。


比如设定10月22日选股 里面有002304 但它10月20日就由黄变红了  300304   10月13日由黄变红了  300312  10月13日由黄变红了   300632  10月20日由黄变红了

举报

点亮(2) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-1 17:14 复制 查看全部楼层
月生112 发表于 2020-11-1 16:49
老师你好 学生按你的指标来选股 在设定A天来选出的股有些票前一天或前两天就已经由黄线变成红线了。看老 ...

请说个股票代码与日期。

举报

扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-1 16:49 复制 查看全部楼层
注册111 发表于 2020-11-1 16:26
HZ:=HHV((H+L)/2,120);
AA:=(2*C+H+L)/4;
VAR1:=IF(DATE=10301201,0,1);

老师你好 学生按你的指标来选股 在设定A天来选出的股有些票前一天或前两天就已经由黄线变成红线了。看老师还能否细化一下吗? 谢谢

举报

点亮(1) 扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-1 16:44 复制 查看全部楼层
竹隐风雷 发表于 2020-11-1 16:14
VAR9:=(CLOSE+OPEN)/2;
黄线:=(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,LINET ...

谢谢老师帮忙 但不准的。

举报

扔鸡蛋(0) 回复

月生112
Lv.3
发表于 2020-11-1 16:43 复制 查看全部楼层
注册111 发表于 2020-11-1 16:26
HZ:=HHV((H+L)/2,120);
AA:=(2*C+H+L)/4;
VAR1:=IF(DATE=10301201,0,1);

谢谢老师的及时解答!!!

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-1 16:26 复制 查看全部楼层
HZ:=HHV((H+L)/2,120);
AA:=(2*C+H+L)/4;
VAR1:=IF(DATE=10301201,0,1);
VAR2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
VAR3:=EMA(CLOSE,3);
VAR4:=(2*CLOSE+LOW+HIGH)/4*VAR1;
VAR5:=VAR2-VAR3;
VAR6:=CLOSE*VOL;
VAR7:=EMA((EMA(VAR6,3)/EMA(VOL,3)+EMA(VAR6,6)/EMA(VOL,6)+EMA(VAR6,12)/EMA(VOL,12)+EMA(VAR6,24)/EMA(VOL,24))/4,13);
VAR8:=EMA(CLOSE,9);
VAR9:=(CLOSE+OPEN)/2;
上轨1:=EMA(VAR8*1.14,15),COLORGREEN,LINETHICK1;
黄线:=(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,LINETHICK1;
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210 ;
黄牛线:=EMA(HH,90);
道2:=6*HHV(黄牛线,3)-5*黄牛线;
A2:=IF(C<=上轨1,黄牛线,DRAWNULL);
A2=DRAWNULL&&REF(A2=黄牛线,1);
查看全部打赏
  • 月生112+18理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(3) 扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-11-1 16:14 复制 查看全部楼层
本帖最后由 竹隐风雷 于 2020-11-1 17:20 编辑

VAR9:=(CLOSE+OPEN)/2;
黄线:=(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,LINETHICK1;
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+REF(H,20))/210,COLORBLUE,LINETHICK1;
黄牛线:=EMA(HH,90),COLORYELLOW,LINETHICK2;
道2:=6*HHV(黄牛线,3)-5*黄牛线;
cross(黄线>=道2,0.5);
查看全部打赏
  • 北沙+20理想币 +2共享币 : 选股公式把颜色函数及线型粗细函数删掉。

举报

点亮(3) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表