请老师帮助把这个主图指标改成通达信可用的

[通达信]
设置
2075 2 花雨香 Lv.4 发表于 · 2020-11-1 20:36 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
kx:="chanlun@kxian";
kxg:="chanlun@kxg";
kxd:="chanlun@kxd";
kxfx:="chanlun@kxfx";
笔:="chanlun@bi";
笔周期:"chanlun@bilast",linethick0, colorff00ff;
bilast:="chanlun@bilast";{笔周期};
段:="chanlun@duan";
段周期:"chanlun@duanlast", linethick0, colorFFffFF;
duanlast:="chanlun@duanlast"; {段周期};
中枢:="chanlun@zs";
zszg:="chanlun@zszg";
zszd:="chanlun@zszd";
zsgg:="chanlun@zsgg";
zsdd:="chanlun@zsdd";
zszz:="chanlun@zszz";
zsks:="chanlun@zskslast";
zsjs:="chanlun@zsjslast";
bifx:=-REF(笔,bilast);
duanfx:=-REF(段,duanlast);
kxqj:="chanlun@kxqj";
{画中枢Begin} {以背景方式画}
STICKLINE(zszg>zszd AND duanfx=1, zszg, zszd, 10, 1),Color8E236B;
STICKLINE(zszg>zszd AND duanfx=-1, zszg, zszd, 10, 1), Color007700;
{中枢震荡监视器}
DRAWLINE(zsks=1, zszz, zsjs=1, zszz, 0), colorFFFFFF;
{画中枢END}
{顶底分型}
STICKLINE(kx>0, kxg, kxd, 5, 1),Color007700,linethick2;
STICKLINE(kx<0, kxg, kxd, 5, 1),Color00ffff,linethick2;
{笔段}
STICKLINE(笔=1, kxg, kxd, 5, 1), colorgreen, linethick2;
STICKLINE(笔=-1, kxg, kxd, 5, 1), colorred, linethick2;
STICKLINE(段=1, kxg, kxd, 5, 0), color007700, linethick2;
STICKLINE(段=-1, kxg, kxd, 5, 0), color0000cc, linethick2;
{画K线END}
{画笔段}
drawline(笔=1,h,笔=-1,l,0),colorBLUE,linethick2;
drawline(笔=-1,l,笔=1,h,0),ColorFF00FF ,linethick2;
drawline(段=1,h,段=-1,l,0),color007700, linethick2;
drawline(段=-1,l,段=1,h,0),colorRED, linethick2;

{笔高低点 周期 力度 提示}
DRAWTEXT(笔= 1, h*1.038, ''+h+''), colorffffff, align1, valign1;
DRAWTEXT(笔=-1, L*0.96, ''+l+''), colorFFffFF, align1, valign1;
VAR3:=LLV(H,240);
VAR4:=100*(C-VAR3)/VAR3;
VAR5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
VAR6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND H>L+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(C,2)-EMA(C,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
DRAWTEXT(买1>0 OR 买2>0,L*0.985,'买'),COLOR00ffff;
DRAWTEXT(卖1>0,H*1.01,'卖'),COLOR00ffff;
APP:=(VOL)/((H-L)*(2)-ABS(C-O));
ZL:=IF((H>O),(APP)*(H-L),IF((L<O),(APP)*(H-O+C-L),(VOL)/(2)));
SF:=IF((H>O),0-(APP)*(H-C+O-L),IF((L<O),0-(APP)*(H-L),0-(VOL)/(2)));
库存能量:=MA(ZL+SF,2);
库存平均:=MA(ZL+SF,5);
GET:ZIG(3,5),COLORYELLOW,LINETHICK3;
PL5:=ZIG(3,5);
EN1:=PL5>REF(PL5,1) AND REF(PL5,1)<=REF(PL5,2) AND REF(PL5,2)<=REF(PL5,3);
EX1:=PL5<REF(PL5,1) AND REF(PL5,1)>=REF(PL5,2) AND REF(PL5,2)>=REF(PL5,3);
PL10:=ZIG(3,10);
EN2:=PL10>REF(PL10,1) AND REF(PL10,1)<=REF(PL10,2) AND REF(PL10,2)<=REF(PL10,3);
EX2:=PL10<REF(PL10,1) AND REF(PL10,1)>=REF(PL10,2) AND REF(PL10,2)>=REF(PL10,3);
PL20:=ZIG(3,20);
EN3:=PL20>REF(PL20,1) AND REF(PL20,1)<=REF(PL20,2) AND REF(PL20,2)<=REF(PL20,3);
EX3:=PL20<REF(PL20,1) AND REF(PL20,1)>=REF(PL20,2) AND REF(PL20,2)>=REF(PL20,3);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'[类二买]'),COLORFFffFF;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'[一买]'),COLORFF00ff;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.04,'[二卖]'),LINETHICK2,COLORFFff00;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'[二买]'),LINETHICK2,COLORFFFF00;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.03,'[一卖]'),LINETHICK3,COLOR00FF00;
DRAWTEXTABS(620,-55,'历史最高价:'+HHV(HIGH,0)),Colorff00ff,LAYER0;
DRAWTEXTABS(620,-37,'历史最低价:'+LLV(LOW,0)),ColorAFFF00,LAYER0;
DRAWTEXTABS(750,-55,'20日最高价:'+HHV(HIGH,20)),Colorred,LAYER0;

附件

day_141120_1676687_11a3114a_QQ20141120185303.jpg

举报

扔鸡蛋(0) 回复

花雨香
Lv.4
发表于 2020-11-7 21:41 复制 查看全部楼层
感谢老师!!!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-2 08:44 复制 查看全部楼层
{公式发现未来函数ZIG等,慎用!}
KX:='CHANLUN@KXIAN';
KXG:='CHANLUN@KXG';
KXD:='CHANLUN@KXD';
KXFX:='CHANLUN@KXFX';
笔:='CHANLUN@BI';
笔周期:'CHANLUN@BILAST',LINETHICK1, COLORFF00FF;
BILAST:='CHANLUN@BILAST';{笔周期};
段:='CHANLUN@DUAN';
段周期:'CHANLUN@DUANLAST', LINETHICK1, COLORFFFFFF;
DUANLAST:='CHANLUN@DUANLAST'; {段周期};
中枢:='CHANLUN@ZS';
ZSZG:='CHANLUN@ZSZG';
ZSZD:='CHANLUN@ZSZD';
ZSGG:='CHANLUN@ZSGG';
ZSDD:='CHANLUN@ZSDD';
ZSZZ:='CHANLUN@ZSZZ';
ZSKS:='CHANLUN@ZSKSLAST';
ZSJS:='CHANLUN@ZSJSLAST';
BIFX:=-REF(笔,BILAST);
DUANFX:=-REF(段,DUANLAST);
KXQJ:='CHANLUN@KXQJ';
{画中枢BEGIN} {以背景方式画}
STICKLINE(ZSZG>ZSZD AND DUANFX=1, ZSZG, ZSZD, 10, 1),COLOR8E236B;
STICKLINE(ZSZG>ZSZD AND DUANFX=-1, ZSZG, ZSZD, 10, 1), COLOR007700;
{中枢震荡监视器}
DRAWLINE(ZSKS=1, ZSZZ, ZSJS=1, ZSZZ, 0), COLORFFFFFF;
{画中枢END}
{顶底分型}
STICKLINE(KX>0, KXG, KXD, 5, 1),COLOR007700,LINETHICK2;
STICKLINE(KX<0, KXG, KXD, 5, 1),COLOR00FFFF,LINETHICK2;
{笔段}
STICKLINE(笔=1, KXG, KXD, 5, 1), COLORGREEN, LINETHICK2;
STICKLINE(笔=-1, KXG, KXD, 5, 1), COLORRED, LINETHICK2;
STICKLINE(段=1, KXG, KXD, 5, 0), COLOR007700, LINETHICK2;
STICKLINE(段=-1, KXG, KXD, 5, 0), COLOR0000CC, LINETHICK2;
{画K线END}
{画笔段}
DRAWLINE(笔=1,H,笔=-1,L,0),COLORBLUE,LINETHICK2;
DRAWLINE(笔=-1,L,笔=1,H,0),COLORFF00FF ,LINETHICK2;
DRAWLINE(段=1,H,段=-1,L,0),COLOR007700, LINETHICK2;
DRAWLINE(段=-1,L,段=1,H,0),COLORRED, LINETHICK2;
{笔高低点 周期 力度 提示}
DRAWTEXT(笔=1, H*1.038,H),COLORRED;
DRAWTEXT(笔=-1, L*0.96, L),COLORFFFFFF;
VAR3:=LLV(H,240);
VAR4:=100*(C-VAR3)/VAR3;
VAR5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
VAR6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND H>L+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(C,2)-EMA(C,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
DRAWTEXT(买1>0 OR 买2>0,L*0.985,'买'),COLOR00FFFF;
DRAWTEXT(卖1>0,H*1.01,'卖'),COLOR00FFFF;
APP:=(VOL)/((H-L)*(2)-ABS(C-O));
ZL:=IF((H>O),(APP)*(H-L),IF((L<O),(APP)*(H-O+C-L),(VOL)/(2)));
SF:=IF((H>O),0-(APP)*(H-C+O-L),IF((L<O),0-(APP)*(H-L),0-(VOL)/(2)));
库存能量:=MA(ZL+SF,2);
库存平均:=MA(ZL+SF,5);
GET:ZIG(3,5),COLORYELLOW,LINETHICK3;
PL5:=ZIG(3,5);
EN1:=PL5>REF(PL5,1) AND REF(PL5,1)<=REF(PL5,2) AND REF(PL5,2)<=REF(PL5,3);
EX1:=PL5<REF(PL5,1) AND REF(PL5,1)>=REF(PL5,2) AND REF(PL5,2)>=REF(PL5,3);
PL10:=ZIG(3,10);
EN2:=PL10>REF(PL10,1) AND REF(PL10,1)<=REF(PL10,2) AND REF(PL10,2)<=REF(PL10,3);
EX2:=PL10<REF(PL10,1) AND REF(PL10,1)>=REF(PL10,2) AND REF(PL10,2)>=REF(PL10,3);
PL20:=ZIG(3,20);
EN3:=PL20>REF(PL20,1) AND REF(PL20,1)<=REF(PL20,2) AND REF(PL20,2)<=REF(PL20,3);
EX3:=PL20<REF(PL20,1) AND REF(PL20,1)>=REF(PL20,2) AND REF(PL20,2)>=REF(PL20,3);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'[类二买]'),COLORFFFFFF;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'[一买]'),COLORFF00FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.04,'[二卖]'),COLORFFFF00,LINETHICK2;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'[二买]'),COLORFFFF00,LINETHICK2;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.03,'[一卖]'),COLOR00FF00,LINETHICK3;
DRAWTEXT_FIX(ISLASTBAR,0.15,0.029,0,'历史最高价='),COLORFF00FF;
DRAWTEXT_FIX(ISLASTBAR,0.15,0.058,0,'历史最低价='),COLORAFFF00;
DRAWTEXT_FIX(ISLASTBAR,0.15,0.087,0,'20日最高价='),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.15,0.116,0,'20日最低价='),COLORAFFF00;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.029,0,HHV(HIGH,0)),COLORFF00FF;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.058,0,LLV(LOW,0)),COLORAFFF00;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.087,0,HHV(HIGH,20)),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.116,0,LLV(LOW,20)),COLORAFFF00;

举报

点亮(4) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表