请老师帮忙把通达信指标改为东方财富的

[通达信]
设置
1211 2 周佳萍 Lv.2 发表于 · 2020-11-2 09:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师帮忙把下面通达信主图指标改为东方财富的,感觉这个主图指标比较好用,简单直观,一眼就能看明白,只是东方财富用不了,麻烦帮改下,辛苦老师了,谢谢!


Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
大盘涨家数:INDEXADV,NODRAW,COLORRED;
大盘跌家数:INDEXDEC,NODRAW,COLORGREEN;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
AAA:=(3*C+H+L+O)/6;
VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED;
VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/0;
VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
VAR4:(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/0;
VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORRED;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
IF((VAR1 <= REF(VAR1,1)),VAR1,DRAWNULL),COLORGREEN,LINETHICK3;
IF((VAR1 >= REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3;
STICKLINE(VAR4>VAR1,VAR4,VAR1,0,0),COLORBLUE;
DRAWKLINE(H,O,L,C);
DRAWTEXT(REF(VAR5,1)=REF(VAR1,1) AND VAR5<VAR1,L*0.99,'买入'),COLORYELLOW;
V5:=EMA(CLOSE,1);
主线:=EMA(V5,5) ;
本:=EMA(HHV(主线,5),1);
急进:=EMA(HHV(本,17),1);
稳健:=EMA(HHV(急进,17),2);
主升:EMA(HHV(稳健,17),3),LINETHICK1,COLORMAGENTA,DOTLINE;


附件

微信截图_20201102092153.png

举报

扔鸡蛋(0) 回复

周佳萍
Lv.2
发表于 2020-11-2 11:59 复制 查看全部楼层
红茶2014 发表于 2020-11-2 11:30
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT(' 行业   ',HYBLOCK),STRCAT('      地域    ',DQBL ...

谢谢老师的修改,辛苦老师了!

举报

扔鸡蛋(0) 回复

红茶2014
Lv.4
发表于 2020-11-2 11:30 复制 查看全部楼层
本帖最后由 红茶2014 于 2020-11-2 11:42 编辑

所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT(' 行业   ',HYBLOCK),STRCAT('      地域    ',DQBLOCK)),STRCAT('      概念  ',GNBLOCK)));
总股本:=STRCAT(STRCAT('  总股本: ',CON2STR(FINANCE(1)/10000,2)),'亿');
流通盘:=STRCAT(STRCAT('      流通盘:   ',CON2STR(CAPITAL/1000000,2)),'亿');
市值:=STRCAT(STRCAT('      流通市值:   ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(总股本,流通盘),市值));

DRAWTEXT_FIX(ISLASTBAR,0.005,0.025,0,所属板块),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,股本市值),COLORGREEN,LINETHICK2;

大盘涨家数:INDEXADV,NODRAW,COLORRED;
大盘跌家数:INDEXDEC,NODRAW,COLORGREEN;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
AAA:=(3*C+H+L+O)/6;
VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED;
VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORRED;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
IF((VAR1 <= REF(VAR1,1)),VAR1,DRAWNULL),COLORGREEN,LINETHICK3;
IF((VAR1 >= REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3;
DRAWKLINE(H,O,L,C);
DRAWTEXT(REF(VAR5,1)=REF(VAR1,1) AND VAR5<VAR1,L*0.99,'买入'),COLORYELLOW;
V5:=EMA(CLOSE,1);
主线:=EMA(V5,5) ;
本:=EMA(HHV(主线,5),1);
急进:=EMA(HHV(本,17),1);
稳健:=EMA(HHV(急进,17),2);
主升:EMA(HHV(稳健,17),3),LINETHICK1,COLORMAGENTA,DOTLINE;
查看全部打赏
  • 周佳萍+2理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表