请老师帮助编写个N日内最高价当天的成交量向右划线的副图指标

[通达信]
设置
1186 3 疯牛病11 Lv.2 发表于 · 2020-11-2 10:03 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙,N日内最高价当天的成交量向右划线的副图指标,N值可以自己设定,只要成交量向右划线就可以,谢谢老师

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-2 11:01 复制 查看全部楼层
本帖最后由 北沙 于 2020-11-2 11:14 编辑
疯牛病11 发表于 2020-11-2 10:07
我遗漏了一个要求,就是请保留最近的10条线

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*(TOTAL+3)/(CTIME+3),DRAWNULL),NODRAW;
STICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
N:=10;
条件:=H=HHV(H,N);
天数:=IF(条件 AND REFX(BARSNEXT(条件),1)+1=DRAWNULL,BARSNEXT(ISLASTBAR),REFX(BARSNEXT(条件),1)+1);
DRAWSL(SUM(条件,0)>CONST(SUM(条件,0))-10 AND 条件,V,0,天数,0);

举报

点亮(2) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-2 10:52 复制 查看全部楼层
疯牛病11 发表于 2020-11-2 10:07
我遗漏了一个要求,就是请保留最近的10条线

供参考



VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,5);
MAVOL2:MA(VOLUME,10);

N:=21;
TJ:=H=HHV(H,N);
K1:=SUMBARS(TJ,1);
K2:=CONST(SUMBARS(TJ,10))>=CURRBARSCOUNT;
STICKLINE(K1 AND K2>0,REF(V,K1-1),REF(V,K1-1),4,0),COLORYELLOW;

附件

tdxjietu1.JPG

举报

点亮(1) 扔鸡蛋(0) 回复

疯牛病11
Lv.2
发表于 2020-11-2 10:07 复制 查看全部楼层
我遗漏了一个要求,就是请保留最近的10条线

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表