请老师帮助改一个公式,当出现大胆搏或加仓的时候,改成预警公式

[通达信]
设置
1387 4 楚留香1971 Lv.2 发表于 · 2020-11-2 12:46 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
A:=(3*C+L+O+H)/6; X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
短期底部:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
IF(MA(C,3),MA(C,3),DRAWNULL),COLORYELLOW,LINETHICK2;
IF(MA(C,9),MA(C,9),DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(MA(C,23.5),MA(C,23.5),DRAWNULL),COLORWHITE;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);
DRAWTEXT(FB,L-0.58,'★红牛'),COLORRED;
VAR1:=LLV(LOW,21); VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK); DRAWTEXT((AB = 1),(LOW * 0.99),'○起爆'),COLORYELLOW;
AA1:=AMOUNT/V;
BB1:=L;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L;
EE1:=V;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
A1AA:=9;
A2AA:=REF(CLOSE,A1AA+1);
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;

附件

123.png

举报

扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-2 14:43 复制 查看全部楼层
可以用了,希望有用

举报

扔鸡蛋(0) 回复

抓板的神
Lv.3
发表于 2020-11-2 14:11 复制 查看全部楼层
加仓:=FILTER(C/REF(C,1) > 1.05  AND (H/C)<1.01 AND C>REF(C,1),35);
大胆搏:=FILTER(C/REF(C,1) > 1.05  AND (H/C)<1.01 AND C>REF(C,1),45);
XG:加仓 OR  大胆搏;

举报

扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-2 13:50 复制 查看全部楼层
抓板的神 发表于 2020-11-2 13:30
加仓:FILTER(C/REF(C,1) > 1.05  AND (H/C)REF(C,1),35);
大胆搏:FILTER(C/REF(C,1) > 1.05  AND (H/C)REF ...

有错,指标通不过。

举报

扔鸡蛋(0) 回复

抓板的神
Lv.3
发表于 2020-11-2 13:30 复制 查看全部楼层
加仓:FILTER(C/REF(C,1) > 1.05  AND (H/C)<1.01 AND C>REF(C,1),35);
大胆搏:FILTER(C/REF(C,1) > 1.05  AND (H/C)<1.01 AND C>REF(C,1),45);
其实这二个条件是一样的,一个是过滤了后面的35天,一个是过滤了后面的45天。

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表