请老师帮忙改成选股公式

[通达信]
设置
1291 5 感谢好人 Lv.3 发表于 · 2020-11-2 20:31 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
A1:=HIGH;
B1:=LOW;
C1:=CLOSE;
A2:=REF(HIGH,1);
A5:=REF(HIGH,2);
A6:=REF(HIGH,3);
B2:=REF(LOW,1);
B5:=REF(LOW,2);
B6:=REF(LOW,3);
C7:=REF(CLOSE,1);
C8:=REF(CLOSE,5);
NUM1:=IF(A2<C7 AND A2<C8 AND A1<B5 AND A1<B6,0,1);
NUM2:=IF(B2>C7 AND B2>C8 AND B1>A5 AND B1>A6,0,1);
DIF1:=A1-A2;
DIF2:=B1-B2;
REII:=(DIF1+DIF2)*NUM1*NUM2;
REIA:=SQRT(DIF1*DIF1)+SQRT(DIF2*DIF2);
REI:SUM(REII,0)/SUM(REIA,0)*100,COLORWHITE,LINETHICK2,NODRAW;

STICKLINE(C>0,REI,REF(REI,1),-1,0),COLORGRAY;
STICKLINE(REI>REF(REI,1) AND REI>MA(REI,5),REI,REF(REI,1),-1,0),COLORRED;
STICKLINE(REI<REF(REI,1) AND REI<MA(REI,5),REI,REF(REI,1),-1,0),COLORGREEN;
MA(REI,5),COLORGRAY;

请老师帮忙改成2个选股公式:
1.至少3根绿柱后首次变成灰色柱子的选股
2.灰色柱子的票都选出来

举报

扔鸡蛋(0) 回复

感谢好人
Lv.3
发表于 2020-11-2 21:55 复制 查看全部楼层
许昌舍得 发表于 2020-11-2 21:38
三连绿+灰指标

A1:=HIGH;

感谢舍得老师  您辛苦了!祝您身体健康~财源广进!

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-2 21:38 复制 查看全部楼层
三连绿+灰指标

A1:=HIGH;
B1:=LOW;
C1:=CLOSE;
A2:=REF(HIGH,1);
A5:=REF(HIGH,2);
A6:=REF(HIGH,3);
B2:=REF(LOW,1);
B5:=REF(LOW,2);
B6:=REF(LOW,3);
C7:=REF(CLOSE,1);
C8:=REF(CLOSE,5);
NUM1:=IF(A2<C7 AND A2<C8 AND A1<B5 AND A1<B6,0,1);
NUM2:=IF(B2>C7 AND B2>C8 AND B1>A5 AND B1>A6,0,1);
DIF1:=A1-A2;
DIF2:=B1-B2;
REII:=(DIF1+DIF2)*NUM1*NUM2;
REIA:=SQRT(DIF1*DIF1)+SQRT(DIF2*DIF2);
REI:=SUM(REII,0)/SUM(REIA,0)*100;

XG1:=C>0 AND REI,REF(REI,1) AND NOT(REI>REF(REI,1) AND REI>MA(REI,5))
                           AND  NOT(REI<REF(REI,1) AND REI<MA(REI,5));

XG2:=REI<REF(REI,1) AND REI<MA(REI,5);


XGZ:REF(EVERY(XG2,3),1) AND XG1;


附件

tdxjietu3.JPG
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-2 21:33 复制 查看全部楼层
感谢好人 发表于 2020-11-2 21:15
老师帮忙在看看 2个公式选出来的都不对,我之前让别的老师改也是这种问题 是不是公式有问题啊!

A1:=HIGH;
B1:=LOW;
C1:=CLOSE;
A2:=REF(HIGH,1);
A5:=REF(HIGH,2);
A6:=REF(HIGH,3);
B2:=REF(LOW,1);
B5:=REF(LOW,2);
B6:=REF(LOW,3);
C7:=REF(CLOSE,1);
C8:=REF(CLOSE,5);
NUM1:=IF(A2<C7 AND A2<C8 AND A1<B5 AND A1<B6,0,1);
NUM2:=IF(B2>C7 AND B2>C8 AND B1>A5 AND B1>A6,0,1);
DIF1:=A1-A2;
DIF2:=B1-B2;
REII:=(DIF1+DIF2)*NUM1*NUM2;
REIA:=SQRT(DIF1*DIF1)+SQRT(DIF2*DIF2);
REI:=SUM(REII,0)/SUM(REIA,0)*100;

XG1:C>0 AND REI,REF(REI,1) AND NOT(REI>REF(REI,1) AND REI>MA(REI,5))
                           AND  NOT(REI<REF(REI,1) AND REI<MA(REI,5));




附件

tdxjietu2.JPG

举报

点亮(1) 扔鸡蛋(0) 回复

感谢好人
Lv.3
发表于 2020-11-2 21:15 复制 查看全部楼层
许昌舍得 发表于 2020-11-2 21:09
A1:=HIGH;
B1:=LOW;
C1:=CLOSE;

老师帮忙在看看 2个公式选出来的都不对,我之前让别的老师改也是这种问题 是不是公式有问题啊!

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-2 21:09 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-11-2 21:11 编辑


A1:=HIGH;
B1:=LOW;
C1:=CLOSE;
A2:=REF(HIGH,1);
A5:=REF(HIGH,2);
A6:=REF(HIGH,3);
B2:=REF(LOW,1);
B5:=REF(LOW,2);
B6:=REF(LOW,3);
C7:=REF(CLOSE,1);
C8:=REF(CLOSE,5);
NUM1:=IF(A2<C7 AND A2<C8 AND A1<B5 AND A1<B6,0,1);
NUM2:=IF(B2>C7 AND B2>C8 AND B1>A5 AND B1>A6,0,1);
DIF1:=A1-A2;
DIF2:=B1-B2;
REII:=(DIF1+DIF2)*NUM1*NUM2;
REIA:=SQRT(DIF1*DIF1)+SQRT(DIF2*DIF2);
REI:=SUM(REII,0)/SUM(REIA,0)*100;

XG1:C>0;















A1:=HIGH;
B1:=LOW;
C1:=CLOSE;
A2:=REF(HIGH,1);
A5:=REF(HIGH,2);
A6:=REF(HIGH,3);
B2:=REF(LOW,1);
B5:=REF(LOW,2);
B6:=REF(LOW,3);
C7:=REF(CLOSE,1);
C8:=REF(CLOSE,5);
NUM1:=IF(A2<C7 AND A2<C8 AND A1<B5 AND A1<B6,0,1);
NUM2:=IF(B2>C7 AND B2>C8 AND B1>A5 AND B1>A6,0,1);
DIF1:=A1-A2;
DIF2:=B1-B2;
REII:=(DIF1+DIF2)*NUM1*NUM2;
REIA:=SQRT(DIF1*DIF1)+SQRT(DIF2*DIF2);
REI:=SUM(REII,0)/SUM(REIA,0)*100;
TJ:=REI<REF(REI,1) AND REI<MA(REI,5);
XG2:REF(EVERY(TJ,3),1) AND C>0;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表