请老师帮助编写个成交量预警指标

[大智慧]
设置
2596 21 你好9368 Lv.2 发表于 · 2020-11-3 15:05 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
大智慧  今天1分钟量能大于前面720分钟里 或者前3天里所有1分钟量能最高量的2倍以上  符合1分钟条件出现预警股票  不要有未来函数的    谢谢老师了  

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-12-15 13:05 复制 查看全部楼层
你好9368 发表于 2020-12-15 12:20
老师不好意思我发错公式了    这个公式。。。。      第一个  PDI大于MDI的时候  ADX上穿ADXR 出现预警, ...

1
N:=14;
MM:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
ADXR:=EXPMEMA(ADX,MM);
PDI>MDI&&CROSS(ADX,ADXR);

2
N:=14;
MM:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
ADXR:=EXPMEMA(ADX,MM);
CROSS(ADX,ADXR);
查看全部打赏
  • 你好9368+10理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-12-15 12:20 复制 查看全部楼层
注册111 发表于 2020-12-15 11:59
参数自填
1
MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

老师不好意思我发错公式了    这个公式。。。。      第一个  PDI大于MDI的时候  ADX上穿ADXR 出现预警, 第二个 ADX上穿ADXR出现预警  谢谢老师

DRAWBAND(30,RGB(60,60,58),10,RGB(60,60,58));


DRAWTEXT_FIX(1,0,0,0,'同心结为红箭头,上兄弟结为黄宝石,下兄弟结为蓝宝石,娇集为红三角,顺向结为绿宝石,
周顺向结为黄园盘。'),COLORWHITE;
N:=14;
MM:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
ADXR:EXPMEMA(ADX,MM);

20,COLORWHITE;
40,COLORWHITE;
60,COLORMAGENTA;

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-12-15 11:59 复制 查看全部楼层
本帖最后由 注册111 于 2020-12-15 13:06 编辑
你好9368 发表于 2020-12-15 10:55
麻烦老师帮忙编写2个选股预警公式。。谢谢了   


参数自填
1
MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);
DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=(ADX+REF(ADX,M))/2;
PDI>MDI&&CRoSS(ADX,ADXR);

2
MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);
DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=(ADX+REF(ADX,M))/2;
CRoSS(ADX,ADXR);
查看全部打赏
  • 你好9368+10理想币 +2共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-12-15 10:55 复制 查看全部楼层
注册111 发表于 2020-12-2 18:37
COUNT(COUNT(C/REF(C,1)>1.095 AND C=H,8)=5,500);

麻烦老师帮忙编写2个选股预警公式。。谢谢了   


第一个  PDI大于MDI的时候 ADX上穿ADXR出现预警,  第二个  ADX上穿ADXR出现预警


MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);
DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-12-15 10:46 复制 查看全部楼层
注册111 发表于 2020-12-2 18:37
COUNT(COUNT(C/REF(C,1)>1.095 AND C=H,8)=5,500);

麻烦老师帮忙编写2个选股预警公式。。谢谢了    第一个公式  PDI大于MDI的时候 ADX上穿ADXR出现预警,  第二个公式  ADX上穿ADXR出现预警




MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);
DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-12-2 18:37 复制 查看全部楼层
你好9368 发表于 2020-12-2 18:08
AA:=CLOSE>=ZTPRICE(REF(CLOSE,1),0.1);
COUNT(AA,N天)>=涨停M次;

COUNT(COUNT(C/REF(C,1)>1.095 AND C=H,8)=5,500);
查看全部打赏
  • 你好9368+1理想币 +2共享币 : 感谢交流,感恩分享,收获正能量。

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-12-2 18:08 复制 查看全部楼层
注册111 发表于 2020-11-3 15:29
DATATYPE=3 and v>ref(v,HHVBARS(v,720)+1)*2;试试


AA:=CLOSE>=ZTPRICE(REF(CLOSE,1),0.1);
COUNT(AA,N天)>=涨停M次;

老师能帮忙写一个 500天内   有   8天5涨停 的选股公式吗 谢谢了

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-5 12:05 复制 查看全部楼层
你好9368 发表于 2020-11-5 11:17
老师能也一个通达信公式吗    近3天的平均成交量大于前3天的平均成交量一倍以上   选股公式   或者近3天 ...

试试,dzh
ma(v,3)>ref(ma(v,3),3)*2 or all(v>ref(v,1)*2,3);

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-11-5 11:17 复制 查看全部楼层
注册111 发表于 2020-11-3 18:38
m1自填。
MA(VOL,M1)>REF(MA(VOL,M1),HHVBARS(MA(VOL,M1),3)+1);

老师能也一个通达信公式吗    近3天的平均成交量大于前3天的平均成交量一倍以上   选股公式   或者近3天成交量每天的成交量都大于前3天的每天的成交量1倍以上  谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-11-3 19:18 复制 查看全部楼层
冷妞妞 发表于 2020-11-3 19:06
大智慧我不熟悉  您还是取消这个任务。重新发一个任务  写清楚需要能够实现分时预警的  
实盘预警 要求 ...

哦,,, 好的  谢谢老师

举报

扔鸡蛋(0) 回复

冷妞妞
Lv.8
发表于 2020-11-3 19:06 复制 查看全部楼层
你好9368 发表于 2020-11-3 18:58
老师 大智慧的可以吗?  我办理了一个大智慧付费账号 有全推数据

大智慧我不熟悉  您还是取消这个任务。重新发一个任务  写清楚需要能够实现分时预警的  
实盘预警 要求盘中跳出及时量大于N天前的最高量

看看其他老师有没有其他软件实现  通达信肯定实现不了
期待下次的任务能够帮您 (我只熟悉通达信  抱歉)

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-11-3 18:58 复制 查看全部楼层
冷妞妞 发表于 2020-11-3 18:55
短消息审核时间太久,在这里回复您

老师 大智慧的可以吗?  我办理了一个大智慧付费账号 有全推数据

举报

点亮(0) 扔鸡蛋(0) 回复

冷妞妞
Lv.8
发表于 2020-11-3 18:55 复制 查看全部楼层
你好9368 发表于 2020-11-3 17:57
恩恩 好的     老师上面那个公式还能在写一下吗   任何时候1分钟量能大于前面720分钟里 或者前3天里所有1 ...

短消息审核时间太久,在这里回复您


您的要求我看到了,但通达信日线级别以下不能预警(因为没有全推数据),看了您的任务要求
只能在一分钟周期进行选股而且只能是盘后选股  还要下载一分钟完整数据。很是麻烦。
根据您的任务  只能在下载完整一分钟数据后  收盘后   进行一分钟选股
选出符合您的要求的股票  第二天介入
比如 收盘后 选出9:35(这个时间可以自行设定)分之前突破四天前最高量N倍的票。
再次谢谢您的信任!!

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-3 18:38 复制 查看全部楼层
你好9368 发表于 2020-11-3 17:57
恩恩 好的     老师上面那个公式还能在写一下吗   任何时候1分钟量能大于前面720分钟里 或者前3天里所有1 ...

m1自填。
MA(VOL,M1)>REF(MA(VOL,M1),HHVBARS(MA(VOL,M1),3)+1);

举报

点亮(0) 扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-11-3 17:57 复制 查看全部楼层
注册111 发表于 2020-11-3 16:43
去软件板块去请教。

恩恩 好的     老师上面那个公式还能在写一下吗   任何时候1分钟量能大于前面720分钟里 或者前3天里所有1分钟量能最高量的2倍以上  符合1分钟条件出现预警股票    或者1分钟成交金额大于前3天所有1分钟成交金额的2倍以上 预警 这样可以吗      

VOL,VOLSTICK;

MA1:MA(VOL,M1);   或者MA1参数全是1    实时M1数大于前3天所有M1最高数的2倍以上 预警

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-3 16:43 复制 查看全部楼层
你好9368 发表于 2020-11-3 16:06
老师我的设置是这样的 1分钟52天  。。 K线图 只有6天的 ...

去软件板块去请教。

举报

扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-11-3 16:06 复制 查看全部楼层
注册111 发表于 2020-11-3 16:01
在系统选项中设置。

老师我的设置是这样的 1分钟52天  。。 K线图 只有6天的 ...

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-3 16:01 复制 查看全部楼层
你好9368 发表于 2020-11-3 15:43
老师 我的 大智慧怎么只能看6天的1分钟周期K线   在哪里设置看50天的?

在系统选项中设置。

附件

捕获.JPG

举报

扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-11-3 16:00 复制 查看全部楼层
注册111 发表于 2020-11-3 15:29
DATATYPE=3 and v>ref(v,HHVBARS(v,720)+1)*2;试试

老师这个公式不行。。。

举报

扔鸡蛋(0) 回复

你好9368
Lv.2
发表于 2020-11-3 15:43 复制 查看全部楼层
注册111 发表于 2020-11-3 15:29
DATATYPE=3 and v>ref(v,HHVBARS(v,720)+1)*2;试试

老师 我的 大智慧怎么只能看6天的1分钟周期K线   在哪里设置看50天的?

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-3 15:29 复制 查看全部楼层
DATATYPE=3 and v>ref(v,HHVBARS(v,720)+1)*2;试试

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表