手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改一下指标

[通达信]
设置
1623 5 小占占 Lv.3 发表于 · 2020-11-3 22:18 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;
双背离:=REF(XG1,1)=1 AND MACD>REF(MACD,1);


M60:MA(C,60),LINETHICK1,COLORLIMAGENTA;



                                当条件满足  双背离  时,这根线变为黄色,谢谢老师。
本主题由 任务系统 于 2020-11-3 22:30 审核通过

举报

扔鸡蛋(0) 回复

小占占
Lv.3
发表于 2020-11-4 12:01 复制 查看全部楼层
好的,谢谢帮忙

举报

扔鸡蛋(0) 回复

一天行情
Lv.4
发表于 2020-11-4 10:23 复制 查看全部楼层
一天行情 发表于 2020-11-4 04:16
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);

IF(双背离,M60,DRAWNULL),LINETHICK9,COLORYELLOW;
把细线LINETHICK1改为粗线LINETHICK9,看的明显
2020-11-04_101732.png
2020-11-04_101940.png

举报

点亮(0) 扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-11-4 07:53 复制 查看全部楼层
{当条件满足  双背离  时,这根线变为黄色}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 && MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 && MACD>MQDZ && DIFF<0 && DIFF>DQDZ
&& CLOSE=LLV(CLOSE,QZQ+20) && MQDZ<0 && DQDZ<0;
双背离: REF(XG1,1)=1 && MACD>REF(MACD,1);
M60:MA(C,60),LINETHICK1,COLORLIMAGENTA;
IF(REF(XG1,1)=1 && MACD>REF(MACD,1),M60,DRAWNULL),LINETHICK3,COLORYELLOW;
查看全部打赏
  • 小占占+40理想币 +4共享币 : 点赞,知识的价值在于分享,谢谢!

举报

扔鸡蛋(0) 回复

勤学务实
Lv.3
发表于 2020-11-4 07:51 复制 查看全部楼层
{当条件满足  双背离  时,这根线变为黄色}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 && MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 && MACD>MQDZ && DIFF<0 && DIFF>DQDZ
&& CLOSE=LLV(CLOSE,QZQ+20) && MQDZ<0 && DQDZ<0;
双背离: REF(XG1,1)=1 && MACD>REF(MACD,1);
M60:MA(C,60),LINETHICK1,COLORLIMAGENTA;
IF(REF(XG1,1)=1 && MACD>REF(MACD,1),M60,DRAWNULL),LINETHICK3,COLORYELLOW;

举报

扔鸡蛋(0) 回复

一天行情
Lv.4
发表于 2020-11-4 04:16 复制 查看全部楼层
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;
双背离:=REF(XG1,1)=1 AND MACD>REF(MACD,1);


M60:MA(C,60),LINETHICK1,COLORLIMAGENTA;
IF(双背离,M60,DRAWNULL),LINETHICK1,COLORYELLOW;

查看全部打赏
  • 小占占+40理想币 +4共享币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表