手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改成选股指标

[通达信]
设置
1092 2 想好再说 Lv.3 发表于 · 2020-11-4 09:05 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师将此副图指标改成选股指标,要求选出当日出现红线上穿白线(金叉)的股票,谢谢!

M:=55;
N:=34;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
VAR71:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR72:=REF(LOW,1)*VAR71;
VAR73:=SMA(ABS(LOW-VAR72),3,1)/SMA(MAX(LOW-VAR72,0),3,1)*100*VAR71;
VAR74:=EMA(IF(CLOSE*1.3,VAR73*10,VAR73/10),3)*VAR71;
VAR75:=LLV(LOW,30)*VAR71;
VAR76:=HHV(VAR74,30)*VAR71;
VAR77:=IF(MA(CLOSE,58),1,0)*VAR71;
VAR78:=EMA(IF(LOW<=VAR75,(VAR74+VAR76*2)/2,0),3)/618*VAR77*VAR71;


白线: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORWHITE,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
红线:EMA(J,6),COLORRED,LINETHICK1;

举报

扔鸡蛋(0) 回复

想好再说
Lv.3
发表于 2020-11-4 10:31 复制 查看全部楼层
谢谢休闲68老师了!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-4 09:14 复制 查看全部楼层
M:=55;
N:=34;
白线:=100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M));
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
红线:=EMA(J,6);
XG:CROSS(红线,白线);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表