手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个MACD公式

[通达信]
设置
1530 9 市场小人物 Lv.2 发表于 · 2020-11-4 09:28 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
  老师   您好

               求助  MACD 的最高价的  表达公式,,要求 :


                                  MACD 的 金叉 到 死叉 之间  最高价 K 线  的  最低价格。。



                                                                                  谢谢

附件

坐标.JPG

举报

扔鸡蛋(0) 回复

市场小人物
Lv.2
发表于 2020-11-9 10:24 复制 查看全部楼层
市场小人物 发表于 2020-11-8 11:14
得到老师的肯定   太开心了

老师 您好

   可以帮忙改MACD 指标吗?,这个不是选股公式是附图的指标。

条件1,所有小于MACD5根的绿柱 改成 粉红色显示

            相反所有小于MACD5根的红柱 改成 绿色色显示。


                                                      谢谢

  

附件

MACD1.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

市场小人物
Lv.2
发表于 2020-11-8 11:14 复制 查看全部楼层

得到老师的肯定   太开心了

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-8 10:57 复制 查看全部楼层
市场小人物 发表于 2020-11-8 10:09
老师  您好,,上个指标非常得棒   昨天我根据这个指标 做了个  KDJ 金叉的指标  请老师帮忙看看, ...

举报

扔鸡蛋(0) 回复

市场小人物
Lv.2
发表于 2020-11-8 10:09 复制 查看全部楼层
许昌舍得 发表于 2020-11-7 12:39
修改过了再试试

T1:=SUMBARS(CROSS(MACD.DIF,MACD.DEA),2);

老师  您好,,上个指标非常得棒   昨天我根据这个指标 做了个  KDJ 金叉的指标  请老师帮忙看看,是否正确


条件1,MACD 金叉到死叉间的最高值的最低价。
条件2,KDJ 死叉到金叉  且 包含 J 值20以下 至少3天。

  要求:条件2 的KDJ金叉  大于 条件1.


T1:=SUMBARS(CROSS(MACD.DIF,MACD.DEA),1);
T2:=SUMBARS(CROSS(MACD.DEA,MACD.DIF),1);
T3:=SUMBARS(CROSS(KDJ.D,KDJ.K),1);
T4:=SUMBARS(CROSS(KDJ.K,KDJ.D),1);
SS:=IF(T1>T2 ,FINDHIGHBARS(H,T2,T1,1),DRAWNULL);
LL:=REF(L,SS);
KK:=T3>T4 AND REF(COUNT(KDJ.J<20,(T3-T4))>=3,T3);
JC:=CROSS(KDJ.K,KDJ.D);
XG:(JC AND C>LL AND KK)*5;

值选出一直  002692

请老师帮忙修改优化

                                                                                           非常感谢

附件

最终.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-7 12:39 复制 查看全部楼层
修改过了再试试

T1:=SUMBARS(CROSS(MACD.DIF,MACD.DEA),2);
T2:=SUMBARS(CROSS(MACD.DEA,MACD.DIF),1);
T3:=SUMBARS(CROSS(MACD.DIF,MACD.DEA),1);
SS:=IF(T1>T2 ,FINDHIGHBARS(H,T2,T1,1),DRAWNULL);
LL:=REF(L,SS);
KK:=T2>T3 AND REF(COUNT(KDJ.J<20,(T2-T3))>2,T3);
JC:=CROSS(MACD.DIF,MACD.DEA);
XG:(JC AND C>LL AND KK)*5;
查看全部打赏

举报

点亮(0) 扔鸡蛋(0) 回复

市场小人物
Lv.2
发表于 2020-11-7 11:56 复制 查看全部楼层
许昌舍得 发表于 2020-11-7 11:28
T1:=SUMBARS(CROSS(MACD.DIF,MACD.DEA),2);
T2:=SUMBARS(CROSS(MACD.DEA,MACD.DIF),1);
T3:=SUMBARS(CR ...

您好  老师   

      测试没有通过,,,显示   最后一句的   JC 为 未知字符串    不知道 是什么意思,,,

                                             能修改吗?

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-7 11:28 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-11-7 12:38 编辑
市场小人物 发表于 2020-11-7 00:56
老师  您好   

           又要麻烦您了,,上面的公式 再加个 条件:


T1:=SUMBARS(CROSS(MACD.DIF,MACD.DEA),2);
T2:=SUMBARS(CROSS(MACD.DEA,MACD.DIF),1);
T3:=SUMBARS(CROSS(MACD.DIF,MACD.DEA),1);
SS:=IF(T1>T2 ,FINDHIGHBARS(H,T2,T1,1),DRAWNULL);
LL:=REF(L,SS);
KK:=T2>T3 AND REF(COUNT(KDJ.J<20,(T2-T3))>2,T3);
JC:=CROSS(MACD.DIF,MACD.DEA);
XG:(JC AND C>LL AND KK)*5;

附件

tdxjietu2.JPG
查看全部打赏

举报

点亮(0) 扔鸡蛋(0) 回复

市场小人物
Lv.2
发表于 2020-11-7 00:56 复制 查看全部楼层
许昌舍得 发表于 2020-11-4 09:46
T1:=BARSLAST(CROSS(MACD.DIF,MACD.DEA));
T2:=BARSLAST(CROSS(MACD.DEA,MACD.DIF));

老师  您好   

           又要麻烦您了,,上面的公式 再加个 条件:

                  条件1   MACD金叉到死叉中  最高价 的  最低价

                 条件2   MACD 死叉到金叉   其中包含 KDJ 的 J 值  至少有3日在 20值 以下

                        要求, 当下条件2的 金叉   大于 条件1 的 最低价 (必须是相邻的)    有附图300644


                                                                               感谢

附件

结束.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-4 09:46 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-11-4 09:48 编辑

T1:=BARSLAST(CROSS(MACD.DIF,MACD.DEA));
T2:=BARSLAST(CROSS(MACD.DEA,MACD.DIF));

SS:=IF(T1>T2,FINDHIGHBARS(H,T2,T1,1),DRAWNULL);
LL:REF(L,SS);

附件

tdxjietu11.JPG
查看全部打赏
  • 市场小人物+10理想币 : 很给力,投资愉快,理想因你而精彩;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表