请老师帮忙合并一个选股公式

[通达信]
设置
1404 3 海心之翔 Lv.2 发表于 · 2020-11-4 13:47 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙合并一个选股公式,非常感谢

选股公式一:

RSV:=(((CLOSE - LLV(LOW,9)) /(HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
绝佳底:(MA(C,5)-C)/C>0.04 AND(MA(C,10)-MA(C,5))/MA(C,5)>0.04;


选股公式二:

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
DD:=VAR8>5;
买入:=IF((COUNT(DD,2)=2),-20,0);
VAR1S:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2S:=SMA(ABS(LOW-VAR1S),13,1)/SMA(MAX(LOW-VAR1S,0),10,1);
VAR3S:=EMA(VAR2S,10);
VAR4S:=LLV(LOW,33);
VAR5S:=EMA(IF(LOW<=VAR4S,VAR3S,0),3);
主力进场:=IF(VAR5S>REF(VAR5S,1),VAR5S,0)*1.1,LINETHICK1,COLOR00FFFF;
洗盘:=IF(VAR5S<REF(VAR5S,1),VAR5S,0),COLORGREEN;
低买:IF((CROSS(洗盘,主力进场) AND 买入=-20),100,0);

举报

扔鸡蛋(0) 回复

海心之翔
Lv.2
发表于 2020-11-4 15:31 复制 查看全部楼层
休闲者68 发表于 2020-11-4 14:23
绝佳底:=(MA(C,5)-C)/C>0.04 AND(MA(C,10)-MA(C,5))/MA(C,5)>0.04;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW ...

非常感谢老师

举报

扔鸡蛋(0) 回复

追牛服
Lv.3
发表于 2020-11-4 15:00 复制 查看全部楼层
{选股公式一:}

RSV:=(((CLOSE - LLV(LOW,9)) /(HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
绝佳底:=(MA(C,5)-C)/C>0.04 AND(MA(C,10)-MA(C,5))/MA(C,5)>0.04;


{选股公式二:}

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
DD:=VAR8>5;
买入:=IF((COUNT(DD,2)=2),-20,0);
VAR1S:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2S:=SMA(ABS(LOW-VAR1S),13,1)/SMA(MAX(LOW-VAR1S,0),10,1);
VAR3S:=EMA(VAR2S,10);
VAR4S:=LLV(LOW,33);
VAR5S:=EMA(IF(LOW<=VAR4S,VAR3S,0),3);
主力进场:=IF(VAR5S>REF(VAR5S,1),VAR5S,0)*1.1,LINETHICK1,COLOR00FFFF;
洗盘:=IF(VAR5S<REF(VAR5S,1),VAR5S,0),COLORGREEN;
低买:IF((CROSS(洗盘,主力进场) AND 买入=-20),100,0) AND 绝佳底;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-4 14:23 复制 查看全部楼层
绝佳底:=(MA(C,5)-C)/C>0.04 AND(MA(C,10)-MA(C,5))/MA(C,5)>0.04;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
DD:=VAR8>5;
买入:=IF((COUNT(DD,2)=2),-20,0);
VAR1S:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2S:=SMA(ABS(LOW-VAR1S),13,1)/SMA(MAX(LOW-VAR1S,0),10,1);
VAR3S:=EMA(VAR2S,10);
VAR4S:=LLV(LOW,33);
VAR5S:=EMA(IF(LOW<=VAR4S,VAR3S,0),3);
主力进场:=IF(VAR5S>REF(VAR5S,1),VAR5S,0)*1.1;
洗盘:=IF(VAR5S<REF(VAR5S,1),VAR5S,0);
低买:=IF((CROSS(洗盘,主力进场) AND 买入=-20),100,0);
HBXG:绝佳底 AND 低买;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表