手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股公式

[通达信]
设置
1331 2 蛟龙888 Lv.2 发表于 · 2020-11-4 19:59 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
VAR1:=IF(YEAR>=2993 AND MONTH>=1,0,1);
VAR2:=REF(L,1)*VAR1;
VAR3:=SMA(ABS(L-VAR2),3,1)/SMA(MAX(L-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(C*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(L,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(C,58),1,0)*VAR1;
VAR8:=EMA(IF(L<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
关注:C<REF(O,1) AND CROSS(100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),10) AND (IF(VAR8>100,100,VAR8)*VAR1)<3 AND WINNER(C)>REF(WINNER(C),1);


要求:能够搜索到在10日内出现过“关注=1”的股票。万分感谢!!!

举报

扔鸡蛋(0) 回复

蛟龙888
Lv.2
发表于 2020-11-4 21:29 复制 查看全部楼层
十分感谢老师的帮助!

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-4 20:04 复制 查看全部楼层

VAR1:=IF(YEAR>=2993 AND MONTH>=1,0,1);
VAR2:=REF(L,1)*VAR1;
VAR3:=SMA(ABS(L-VAR2),3,1)/SMA(MAX(L-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(C*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(L,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(C,58),1,0)*VAR1;
VAR8:=EMA(IF(L<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
关注:=C<REF(O,1) AND CROSS(100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),10) AND (IF(VAR8>100,100,VAR8)*VAR1)<3 AND WINNER(C)>REF(WINNER(C),1);
TJ:EXIST(关注,10);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表