请老师帮助根据明日空间主图指标做个选股公式

[通达信]
设置
1168 1 土鳖boss Lv.3 发表于 · 2020-11-4 23:58 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
源码:
明日空间买卖点:EMA(CLOSE,6),NODRAW;
N:=5;
MA250:=MA(CLOSE,250),COLORMAGENTA,LINETHICK3;
{N(3,30,5);}
【箱顶】:PEAK(3,N,1)*0.999;
【箱底】:TROUGH(3,N,1)*0.999;
【箱高】:=1*(【箱顶】-【箱底】)/【箱底】;
K线运行的升幅:=(MA(H,3)-REF(MA(H,3),1))*100/REF(MA(H,3),1);{NODRAW;}
{ML:=EMA(L,7),COLORMAGENTA;
MH:=MA(H,7),COLORGRAY;
趋势线:MA((MH+ML)/2,3),LINETHICK1,COLORGREEN;
趋势线1:IF(趋势线>REF(趋势线,1),趋势线,DRAWNULL),LINETHICK2,COLORMAGENTA;}
{八周均线}
VAR1:MA(C,7),COLORGREEN;
VAR1A:IF(VAR1>REF(VAR1,1),VAR1,DRAWNULL),COLORRED;
DRAWICON(CROSS(C,VAR1),L*0.99,1);
DRAWICON(CROSS(VAR1,C),H*1.00,2);
XDU:=IF(EMA(EMA(EMA(C,2),2),2)>REF(EMA(EMA(EMA(C,2),2),2),1),【箱底】,【箱顶】);
XTB:=【箱底】!=REF(【箱底】,2) &&【箱底】=REF(【箱底】,1);
XTS:=【箱顶】!=REF(【箱顶】,2) &&【箱顶】=REF(【箱顶】,1);
买点:=(【箱底】!=REF(【箱底】,2) && 【箱底】=REF(【箱底】,1));
卖点:=(【箱顶】!=REF(【箱顶】,2) && 【箱顶】=REF(【箱顶】,1));
DRAWICON(XTB,MIN(【箱底】,L)*0.979,1);
DRAWTEXT(XTB,MIN(【箱底】,L)*0.977,'[到底了!]'),COLOR0000DD;
DRAWICON(XTS,MAX(【箱顶】,H)*1.018,2);
DRAWTEXT(XTS,MIN(【箱顶】,H)*1.028,'[到顶了]')COLOR00DD00;
上升段:DRAWLINE(XTB,MIN(LLV(L,1),【箱底】),XTS,MAX(HHV(H,1),【箱顶】),0)
COLOR000099,LINETHICK2;{XTBL}
下跌段:DRAWLINE(XTS,MAX(HHV(H,1),【箱顶】),XTB,MIN(LLV(L,1),【箱底】),0)
COLOR009900,LINETHICK2;{XTSL}
{主图中涨停板,跌停板颜色。}
C6:=REF(C,1);
涨停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(涨停,H,L,0,0),COLORLIRED;
跌停:=(REF(C,1)-C)*100/REF(C,1)>=(10-1/REF(C,1)) AND
(REF(C,1)-C)*100/REF(C,1)<=(10+1/REF(C,1)) AND L=C;
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORYELLOW;
BOLL:MA(CLOSE,15);
UB:BOLL+2*STD(CLOSE,15);
LB:BOLL-2*STD(CLOSE,15);

明日空间.JPG

麻烦高手根据图中【前方出现到底了红箭头之后,当天又出现了红色尖头追涨信号,没有出现到顶信号】当天又出现了红色尖头追涨信号做一选股公式谢谢 【未来函数无关】
这是到底信号的尖头选股:
N:=5;
BOLL:=MA(CLOSE,N);
UB:=BOLL+2*STD(CLOSE,N);
LB:=BOLL-2*STD(CLOSE,N);
MA250:=MA(CLOSE,250),COLORMAGENTA,LINETHICK3;
{N(3,30,5);}
【箱顶】:=PEAK(3,N,1)*0.999;
【箱底】:=TROUGH(3,N,1)*0.999;
【箱高】:=1*(【箱顶】-【箱底】)/【箱底】;
XDU:=IF(EMA(EMA(EMA(C,2),2),2)>REF(EMA(EMA(EMA(C,2),2),2),1),【箱底】,【箱顶】);
XTB:=【箱底】!=REF(【箱底】,2) &&【箱底】=REF(【箱底】,1);
XTS:=【箱顶】!=REF(【箱顶】,2) &&【箱顶】=REF(【箱顶】,1);
上升段:=DRAWLINE(XTB,MIN(LLV(L,1),【箱底】),XTS,MAX(HHV(H,1),【箱顶】),0)
COLOR000099,LINETHICK2;
下跌段:=DRAWLINE(XTS,MAX(HHV(H,1),【箱顶】),XTB,MIN(LLV(L,1),【箱底】),0)
COLOR009900,LINETHICK2;
买点:=(【箱底】!=REF(【箱底】,2) && 【箱底】=REF(【箱底】,1));
买点;


我要的是【没有到底了字样的红色尖头】买点信号的选股,麻烦大神帮忙

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-5 09:05 复制 查看全部楼层
试试



{到底了箭头}
明日空间买卖点:=EMA(CLOSE,6);
MA250:=MA(CLOSE,250);
N:=(3,30,5);
【箱顶】:=PEAK(3,N,1)*0.999;
【箱底】:=TROUGH(3,N,1)*0.999;
【箱高】:=1*(【箱顶】-【箱底】)/【箱底】;
K线运行的升幅:=(MA(H,3)-REF(MA(H,3),1))*100/REF(MA(H,3),1);
VAR1:=MA(C,7),COLORGREEN;
VAR1A:=IF(VAR1>REF(VAR1,1),VAR1,DRAWNULL),COLORRED;
TJ1:=CROSS(C,VAR1),;
XDU:=IF(EMA(EMA(EMA(C,2),2),2)>REF(EMA(EMA(EMA(C,2),2),2),1),【箱底】,【箱顶】);
XTB:=【箱底】!=REF(【箱底】,2) &&【箱底】=REF(【箱底】,1);
XTS:=【箱顶】!=REF(【箱顶】,2) &&【箱顶】=REF(【箱顶】,1);
买点:=(【箱底】!=REF(【箱底】,2) && 【箱底】=REF(【箱底】,1));
卖点:=(【箱顶】!=REF(【箱顶】,2) && 【箱顶】=REF(【箱顶】,1));
TJ2:=XTB;
XG:EXIST(TJ2,5) AND TJ1;

附件

tdxjietu1.JPG
查看全部打赏
  • 土鳖boss+5理想币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表