请老师帮助在擒龙做个选股

[通达信]
设置
1728 1 曼天雨 Lv.4 发表于 · 2020-11-5 07:06 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{公式名称: 龙飞九天主图}
VAR1:=EMA(CLOSE,7);
VAR2:=EMA(CLOSE,18);
VAR3:=(VAR1-VAR2)/VAR2*100;
VAR4:=EMA(VAR3,1);
VAR5:=EMA(CLOSE,3);
VAR6:=EMA(CLOSE,26);
VAR7:=VAR5-VAR6;
NOTEXT多空:EMA(EMA(EMA(CLOSE,3),3),3)+VAR7,COLORGREEN;
NOTEXT1:IF(VAR4>=REF(VAR4,1),NOTEXT多空,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(VAR4<=REF(VAR4,1),NOTEXT多空,DRAWNULL),COLORGREEN;
VAR8:=HHV(VOL,5);
VAR9:=OPEN>CLOSE;
VAR10:=CLOSE>OPEN;
VAR11:=CLOSE=OPEN;
VAR12:=SUM(VOL,5)/VAR8;
VAR13:=IF(VAR12>0.3,1,0);
VAR14:=IF(VAR9 AND VAR13,VOL,0);
VAR15:=IF(VAR10 AND VAR13,VOL,0);
VAR16:=IF(VAR11 AND VAR13,VOL,0);
VAR17:=SUM(VAR15,3);
VAR18:=SUM(VAR14,3);
VAR19:=VAR17-VAR18;
STICKLINE(VAR19=VAR17,CLOSE,OPEN,3.05,0),COLOR000099;
STICKLINE(VAR19=VAR17,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(VAR19=VAR17,CLOSE,OPEN,1.5,0),COLORRED;
STICKLINE(VAR19=VAR17,CLOSE,OPEN,0.5,0),COLORYELLOW;
DRAWTEXT(VAR19=VAR17 AND REF(VAR19=VAR17,1)=0,LOW*0.98,'K'),COLORMAGENTA;
VAR20:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VAR21:=(REF(VAR20,1)+REF(VAR20,2)+REF(VAR20,3))/3;
VAR22:=(REF(VAR20,1)+REF(VAR20,2)+REF(VAR20,3)+REF(VAR20,4)+REF(VAR20,5)+REF(VAR20,6)+REF(VAR20,7)+REF(VAR20,8)+REF(VAR20,9)+REF(VAR20,10))/10;
VAR23:=VAR20<80 AND VAR21<80 AND VAR22<80;
VAR24:=VAR20>80 AND VAR21>80 AND VAR22>80;
VAR25:=VAR22<VAR20;
VAR26:=REF(CLOSE,1);
VAR27:=SMA(MAX(CLOSE-VAR26,0),2,1)/SMA(ABS(CLOSE-VAR26),2,1)*100;
VAR28:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
VAR29:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
VAR30:=CROSS(VAR27,VAR29) AND VAR25;
VAR31:=VAR27>75 AND VAR29<5;
DRAWTEXT(VAR31 AND VAR17>VAR19,LOW*0.99,'Q'),COLORYELLOW;
DRAWTEXT(VAR30,LOW*0.98,'K'),COLORYELLOW;
VAR32:=EMA(CLOSE,2);
VAR33:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
VAR34:=IF(CROSS(VAR32,VAR33),LOW-0.02,DRAWNULL);
VAR35:=(LOW+HIGH+CLOSE*2)/4;
VAR36:=EMA(VAR35,14);
VAR37:=(VAR36-REF(VAR36,1))/REF(VAR36,1)*100;
VAR38:=IF(VAR37>=0,VAR36,DRAWNULL);
VAR39:=IF(CROSS(VAR34,0),5,0);
VAR40:=IF(CROSS(VAR38,0),10,0);
VAR41:=VAR39 AND VAR40;
DRAWICON(VAR41,LOW*0.99,1),COLORGREEN;
DRAWICON(VAR41,LOW*0.98,1),COLORGREEN;
VAR42:=REF(CLOSE,1);
VAR43:=SMA(MAX(CLOSE-VAR42,0),5,1)/SMA(ABS(CLOSE-VAR42),5,1)*100;
VAR44:=CROSS(80,VAR43);
DRAWICON(VAR44,HIGH*1.01,2),COLORGREEN;
DRAWICON(VAR44,HIGH*1.02,2),COLORGREEN;
VAR45:=SMA(MAX(CLOSE-VAR26,0),3,1)/SMA(ABS(CLOSE-VAR26),3,1)*100;
VAR46:=EMA(CLOSE,3);
VAR47:=EMA(CLOSE,21);
DRAWTEXT(CROSS(VAR46,VAR47),LOW*0.97,'底'),COLORRED;
DRAWTEXT(CROSS(88,VAR45),HIGH*1.03,'顶'),COLORYELLOW;
VAR48:=CLOSE-REF(CLOSE,1);
VAR49:=IF(CLOSE-REF(CLOSE,1)>=0,VAR48,0);
VAR50:=REF(CLOSE,1)-CLOSE;
VAR51:=IF(CLOSE-REF(CLOSE,1)<=0,VAR50,0);
VAR52:=SUM(VAR49,90)/SUM(VAR51,90);
VAR53:=100-100/(1+VAR52);
VAR54:=EMA(VAR53,21);
VAR55:=EMA(VAR54,5);
VAR56:=EMA(VAR54,3);
VAR57:=(CLOSE*2+HIGH+LOW)/4;
VAR58:=EMA(VAR57,13)-EMA(VAR57,21);
VAR59:=EMA(VAR58,3);
VAR60:=EMA(VAR58,10);
VAR61:=IF(VAR59>=VAR60,VAR59,VAR60);
VAR62:=IF(VAR60-VAR59,VAR60,VAR59);
VAR63:=EMA(CLOSE,7)-EMA(CLOSE,21);
VAR64:=EMA(0.668*REF(VAR63,1)+0.333*VAR63,1);
VAR65:=IF(VAR63>=VAR64,VAR63,VAR64);
VAR66:=IF(VAR64-VAR63,VAR64,VAR63);
VAR67:=VAR61>VAR62;
VAR68:=VAR61=VAR62;
VAR69:=VAR65>VAR66;
VAR70:=VAR65=VAR66;
VAR71:=VAR70 AND VAR68;
VAR72:=VAR69 AND VAR67;
STICKLINE(VAR69,HIGH,LOW,0,0),COLORRED;
STICKLINE(VAR70,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(VAR67,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(VAR68,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(VAR72,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(VAR71,OPEN,CLOSE,2,0),COLORBLUE;
VAR73:=EMA(CLOSE,5);
VAR74:=EMA(VAR73,0);
VAR75:=HHV(MA(HIGH,3),2);
VAR76:=LLV(MA(HIGH,3),1);
DRAWICON(VAR76=VAR75 AND REF(VAR75,1)>REF(VAR76,1) AND VAR69,LOW,1);
DRAWICON(VAR76<VAR75 AND REF(VAR76=VAR75,1) AND VAR70,HIGH*1.01,2);
VAR77:=FILTER(VAR74>REF(VAR74,1) AND VAR75<REF(VAR75,1) AND CLOSE>REF(CLOSE,1),11);
DRAWTEXT(VAR77>=1,LOW*0.99,'牛'),COLORMAGENTA;
VAR78:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
VAR79:=100*(1-WINNER(CLOSE));
VAR80:=100-VAR79;
VAR81:=CROSS(VAR80,VAR79);
DRAWICON(VAR81,LOW,25);
VAR82:=MA(CLOSE,5);
VAR83:=MA(CLOSE,13);
VAR84:=MA(CLOSE,34);
VAR85:=VAR82>REF(VAR82,1) AND VAR83>REF(VAR83,1) AND VAR84>REF(VAR84,1);
VAR86:=EMA(CLOSE,3);
VAR87:=EMA(SLOPE(CLOSE,34)*5+CLOSE,21);
VAR88:=CROSS(VAR86,VAR87);
VAR89:=CROSS(VAR86,VAR87) AND VAR85;
VAR90:=VAR88>0;
VAR91:=VAR89>0;
VAR92:=MA(CLOSE,34);
VAR93:=VAR90 OR VAR91;
VAR94:=CLOSE>VAR92 AND REF(CLOSE,1)<VAR92;
DRAWTEXT(VAR93 AND VAR94,LOW*0.99,'买'),COLORYELLOW;
DRAWTEXT(VAR93 AND VAR72,LOW*0.99,'买'),COLORRED;
VAR95:=CROSS(CLOSE,MA(CLOSE,250)) AND VOL>=REF(VOL,1)*2;
VAR96:=(CLOSE/REF(CLOSE,1)-1)*100>9.97 AND CROSS(CLOSE,MA(CLOSE,250));
VAR97:=VAR95 OR VAR96 OR VAR94;
VAR98:=VAR93 AND VAR81 AND VAR97 AND VAR78;
STICKLINE(VAR98,CLOSE,OPEN,3.05,0),COLOR000099;
STICKLINE(VAR98,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(VAR98,CLOSE,OPEN,1.5,0),COLORRED;
STICKLINE(VAR98,CLOSE,OPEN,0.5,0),COLORYELLOW;
DRAWTEXT(VAR98,LOW,'擒龙'),COLORYELLOW;

举报

扔鸡蛋(0) 回复

杜珂高
Lv.3
发表于 2020-11-5 08:13 复制 查看全部楼层
VAR78:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
VAR79:=100*(1-WINNER(CLOSE));
VAR80:=100-VAR79;
VAR81:=CROSS(VAR80,VAR79);
VAR82:=MA(CLOSE,5);
VAR83:=MA(CLOSE,13);
VAR84:=MA(CLOSE,34);
VAR85:=VAR82>REF(VAR82,1) AND VAR83>REF(VAR83,1) AND VAR84>REF(VAR84,1);
VAR86:=EMA(CLOSE,3);
VAR87:=EMA(SLOPE(CLOSE,34)*5+CLOSE,21);
VAR88:=CROSS(VAR86,VAR87);
VAR89:=CROSS(VAR86,VAR87) AND VAR85;
VAR90:=VAR88>0;
VAR91:=VAR89>0;
VAR92:=MA(CLOSE,34);
VAR93:=VAR90 OR VAR91;
VAR94:=CLOSE>VAR92 AND REF(CLOSE,1)<VAR92;
VAR95:=CROSS(CLOSE,MA(CLOSE,250)) AND VOL>=REF(VOL,1)*2;
VAR96:=(CLOSE/REF(CLOSE,1)-1)*100>9.97 AND CROSS(CLOSE,MA(CLOSE,250));
VAR97:=VAR95 OR VAR96 OR VAR94;
VAR98:=VAR93 AND VAR81 AND VAR97 AND VAR78;
XG:VAR98;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表