请老师帮助将下面指标两个三角向右画出楔形三角

[通达信]
设置
1437 5 宽仁律己 Lv.4 发表于 · 2020-11-5 07:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
SJ1:=(REF(HIGH,3) = HHV(HIGH,((2 * 3) + 1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3 + 1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3) = LLV(LOW,((2 * 3) + 1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3 + 1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2 * 3)),1) + REF(HHV(HIGH,(2 * 3)),1)) / 2);
SJ10:=((HIGH + LOW) / 2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1) + 1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14) > 0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15 > REF(SJ15,1));
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17 > REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20) > 0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21 > REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23 > REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18) + 1));
SJ26:=(SJ25 > REF(SJ25,1));
SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24) + 1));
SJ28:=(SJ27 > REF(SJ27,1));
底:REF(LOW,BARSLAST(SJ26)),NODRAW;
顶:REF(HIGH,BARSLAST(SJ28)),NODRAW;
STICKLINE(SJ26,顶,底,0,0),COLORBLUE;
DRAWLINE(SJ28,HIGH,SJ26,LOW,0),COLORBLUE;
DRAWLINE(SJ28,HIGH,SJ26,顶,0),COLORBLUE;
STICKLINE(SJ28,顶,底,0,0),COLORLIMAGENTA;
DRAWLINE(SJ26,LOW,SJ28,HIGH,0),COLORLIMAGENTA;
DRAWLINE(SJ26,LOW,SJ28,底,0),COLORLIMAGENTA;

DRAWNUMBER(SJ28,HIGH,顶),COLORLIMAGENTA;
DRAWNUMBER(SJ26,LOW,底),COLORLIMAGENTA;
DRAWLINE(BARSLAST(SJ26)=0,L,REF(SJ26=0,1),REF(底,1),1),COLORWHITE;
DRAWLINE(BARSLAST(SJ28)=0,H,REF(SJ28=0,1),REF(顶,1),1),COLORWHITE;

举报

扔鸡蛋(0) 回复

宽仁律己
Lv.4
发表于 2020-11-6 07:26 复制 查看全部楼层
北沙老师您好,非常感谢您的回复,可惜我不会上图

举报

点亮(0) 扔鸡蛋(0) 回复

宽仁律己
Lv.4
发表于 2020-11-6 07:25 复制 查看全部楼层
[img][/img]

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-5 22:29 复制 查看全部楼层
给个图片,往哪画,画到哪?

举报

扔鸡蛋(0) 回复

牛牛1888
Lv.3
发表于 2020-11-5 16:04 复制 查看全部楼层
华仔2888 发表于 2020-11-5 10:11
修改这个指标可能有一定的难度...........真的不行楼主可以去威客区试试...........祝好运

冷妞妞老师最擅长图形类的

举报

扔鸡蛋(0) 回复

华仔2888
Lv.5
发表于 2020-11-5 10:11 复制 查看全部楼层
修改这个指标可能有一定的难度...........真的不行楼主可以去威客区试试...........祝好运

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表