请老师指导一下:如何把此公式改为上个交易日(而不是最近交易日)符合条件?

[通达信]
设置
1313 4 中兔子zn Lv.2 发表于 · 2020-11-5 08:20 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
下面的公式原来选出的是最近收盘符合条件的,如果改为上个交易日符合条件,该怎么改
MA3:=EMA(C,3);
MA5:=EMA(C,5);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA5,MA3))+1),LLV(L,BARSLAST(CROSS(MA5,MA3))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA3))+1),HHV(H,BARSLAST(CROSS(MA5,MA3))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA3))+1),HHV(H,BARSLAST(CROSS(MA5,MA3))+1),L=LLV(L,BARSLAST(CROSS(MA5,MA3))+1),LLV(L,BARSLAST(CROSS(MA5,MA3))+1),0);
A8:=100*EMA(EMA((C-REF(C,1)),6),6)/EMA(EMA(ABS((C-REF(C,1))),6),6);
XG: ((LLV(A8,2)=LLV(A8,7) && COUNT(A8<0,2) && CROSS(A8,MA(A8,2))) && REF(DOWN,1)<REF(DOWN,2) && UP>REF(DOWN,1))=0;
以上是原公式,如何改为上个交易日符合条件

举报

扔鸡蛋(0) 回复

中兔子zn
Lv.2
发表于 2020-11-17 08:00 复制 查看全部楼层
一天行情 发表于 2020-11-5 09:57
MA3:=EMA(C,3);
MA5:=EMA(C,5);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA5,MA3))+1),LLV(L,BARSLAST(CROS ...

谢谢,已打赏!还有一个公式(如下),好象简单,但是因为加上了最后一句:AND BETWEEN..........。测试后显示:AND BETWEEN(C,MA(C,5),MA(C,5)*1.055)
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 176 ; 长度: 7
怎么回事?

C>O AND C>REF(C,1)  AND  C/O<1.098 AND (ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.14115926)>44 AND  (ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.14115926)<75 ;
AND BETWEEN(C,MA(C,5),MA(C,5)*1.055);

举报

点亮(0) 扔鸡蛋(0) 回复

中兔子zn
Lv.2
发表于 2020-11-6 03:03 复制 查看全部楼层
一天行情 发表于 2020-11-5 09:57
MA3:=EMA(C,3);
MA5:=EMA(C,5);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA5,MA3))+1),LLV(L,BARSLAST(CROS ...

谢谢,已打赏

举报

扔鸡蛋(0) 回复

一天行情
Lv.4
发表于 2020-11-5 09:57 复制 查看全部楼层
MA3:=EMA(C,3);
MA5:=EMA(C,5);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA5,MA3))+1),LLV(L,BARSLAST(CROSS(MA5,MA3))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA3))+1),HHV(H,BARSLAST(CROSS(MA5,MA3))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA3))+1),HHV(H,BARSLAST(CROSS(MA5,MA3))+1),L=LLV(L,BARSLAST(CROSS(MA5,MA3))+1),LLV(L,BARSLAST(CROSS(MA5,MA3))+1),0);
A8:=100*EMA(EMA((C-REF(C,1)),6),6)/EMA(EMA(ABS((C-REF(C,1))),6),6);
XG:= ((LLV(A8,2)=LLV(A8,7) && COUNT(A8<0,2) && CROSS(A8,MA(A8,2))) && REF(DOWN,1)<REF(DOWN,2) && UP>REF(DOWN,1))=0;;
JJ:REFX(XG,1);
查看全部打赏
  • 中兔子zn+10理想币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(2) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-5 09:50 复制 查看全部楼层
你指的符合条件是指哪个具体条件?

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表