请老师帮忙编写个公式

[通达信]
设置
1353 4 理想ad3683 Lv.3 发表于 · 2020-11-6 09:39 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
在最近20天内最大成交量的那一天对应的K线的最高价和最低价分别画一条向后延伸的水平线

只在最后20天内画一次线,20天前的不要画

谢谢老师

附件

11.png

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-6 21:13 复制 查看全部楼层
牛牛1888 发表于 2020-11-6 11:07
老师看看,这样行不。

T:=CONST(HHVBARS(V,20)),COLOR0000FF,LINETHICK1;

感谢老师指导,谢谢!

举报

扔鸡蛋(0) 回复

理想ad3683
Lv.3
发表于 2020-11-6 14:13 复制 查看全部楼层
谢谢两位老师的帮忙

举报

扔鸡蛋(0) 回复

牛牛1888
Lv.3
发表于 2020-11-6 11:07 复制 查看全部楼层
本帖最后由 牛牛1888 于 2020-11-6 11:28 编辑
休闲者68 发表于 2020-11-6 10:54
{试试,行不行。不行的话,就请白沙老师帮你写一下,他是这方面的专家。}
T:=BARSLAST(V=HHV(V,20));
TJ1 ...


老师看看,这样行不。

T:=CONST(HHVBARS(V,20)),COLOR0000FF,LINETHICK1;
低画线:IF(CURRBARSCOUNT<=T+1,CONST(IF(T=0,L,REF(L,T))),DRAWNULL),COLORYELLOW,LINETHICK1;
高画线:IF(CURRBARSCOUNT<=T+1,CONST(IF(T=0,H,REF(H,T))),DRAWNULL),COLORYELLOW,LINETHICK1;

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-6 10:54 复制 查看全部楼层
{试试,行不行。不行的话,就请白沙老师帮你写一下,他是这方面的专家。}
T:=BARSLAST(V=HHV(V,20));
TJ1:=REF(H,T);
TJ2:=REF(L,T);
DRAWLINE((IF(CURRBARSCOUNT<=20,V=HHV(V,20),DRAWNULL)),TJ1,REF((IF(CURRBARSCOUNT<=20,V=HHV(V,20),DRAWNULL)),1),REF(TJ1,1),1),COLORRED;
DRAWLINE((IF(CURRBARSCOUNT<=20,V=HHV(V,20),DRAWNULL)),TJ2,REF((IF(CURRBARSCOUNT<=20,V=HHV(V,20),DRAWNULL)),1),REF(TJ2,1),1),COLORGREEN;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表