手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

波段背离大全(指标 副图 通达信 贴图)加密,无未来

[通达信] 26个推荐26
设置
5378 5 晴空万米 Lv.3 发表于 · 2020-11-6 10:42 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
指标由红绿波段+MACD顶底背离+KDJ顶底背离+RSI顶底背离+DMI顶底背离+金叉死叉组成。
操作选择1种背离辅助就行,不要都看。
1.jpg

附件

波段背离大全.tn6 在线检测未来函数

9.55 KB, 下载次数: 48, 下载积分: 共享币 -20 个

举报

扔鸡蛋(0) 回复

农民淘金
Lv.4
发表于 2020-11-7 22:21 复制 查看全部楼层
不要争吵了。下面是去掉密码和时间限制及QQ联系方式的源码。


上:80,COLORRED;
下卖:20,COLOR00FF00;


MACD顶背:0,COLOR00FF00;
MACD底背:0,COLORRED;
KDJ顶背:0,COLORFFCC66;
KDJ底背:0,COLORFF00FF;
RSI顶背:0,COLORFFFFFF;
RSI底背:0,COLORYELLOW;
DMI顶背:0,COLORBLUE;
DMI底背:0,COLOR0099FF;

TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TRR;
MDI:= MDM*100/TRR;
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(REF(CROSS(MDI,PDI),1));
D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);
A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);

DRAWTEXT(B4>0,5,'DMI底背'),COLOR0099FF;
DRAWTEXT(D4>0,95,'DMI顶背'),COLORBLUE;
DRAWTEXT(B1>0,15,'MACD底背'),COLORRED;
DRAWTEXT(B2>0,10,'KDJ底背'),COLORFF00FF;
DRAWTEXT(B3>0,18,'RSI底背'),COLORYELLOW;
DRAWTEXT(D1>0,85,'MACD顶背'),COLOR00FF00;
DRAWTEXT(D2>0,90,'KDJ顶背'),COLORFFCC66;
DRAWTEXT(D3>0,96,'RSI顶背'),COLORFFFFFF;
STICKLINE(B1>0,20,0,0,0),COLORRED;
STICKLINE(B2>0,20,0,0,0),COLORFF00FF;
STICKLINE(B3>0,20,0,0,0),COLORYELLOW;
STICKLINE(D1>0,80,100,0,0),COLOR00FF00;
STICKLINE(D2>0,100,80,0,0),COLORFFCC66;
STICKLINE(D3>0,100,80,0,0),COLORWHITE;
STICKLINE(B4>0,20,0,0,0),COLOR0099FF;
STICKLINE(D4>0,100,80,0,0),COLORBLUE;

VAR188:=((CLOSE - LLV(LOW,34))/(HHV(HIGH,34) - LLV(LOW,34)))*(100);
VAR288:=REVERSE(VAR188);
VAR388:=SMA(VAR188,9,1);
K88:=SMA(VAR388,3,1);
D88:=SMA(K88,3,1);
STICKLINE((K88 >= D88),K88,D88,1,0),COLOR0000FF;
STICKLINE((K88 <= D88),K88,D88,1,0),COLOR00FF00;



DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MMACD:=(DIFF-DEA)*2;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:=SMA(RSV,9,3);
D:=SMA(K,9,3);
J:=3*K-2*D;
A:=CROSS(DIFF,DEA) AND CROSS(K,D) AND CROSS(J,D) AND DIFF<0;
SA:=CROSS(DEA,DIFF) AND CROSS(D,K) AND CROSS(D,J) AND DIFF>0;
DRAWTEXT(FILTER(A,10)=1,12,' 金叉'),COLORYELLOW;
STICKLINE(FILTER(A,10)=1,0,20,2,0),COLORRED ;
DRAWTEXT(FILTER(SA,10)=1,97,'死叉'),COLORYELLOW;

举报

扔鸡蛋(0) 回复

小小vey
Lv.4
发表于 2020-11-6 15:00 复制 查看全部楼层
这指标也加密?

举报

扔鸡蛋(0) 回复

田山三
Lv.4
发表于 2020-11-6 10:44 复制 查看全部楼层
这指标也加密?

举报

扔鸡蛋(0) 回复

刘总统
Lv.5
发表于 2020-11-6 10:43 复制 查看全部楼层
嘛破玩意也加密

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表