请老师帮助做个选股公式

[通达信]
设置
1481 5 灌肠儿 Lv.5 发表于 · 2020-11-6 11:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮我做一个选股公式~谢谢!要求:当日线上出现D周金叉条件~

源码如下:

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
DRAWTEXT_FIX(1,0.88,5,0,'~☆~七色光~☆~'),COLORBLUE;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,P1,1),COLORYELLOW;
D:SMA(K,P2,1),COLOR00DD00;
J:3*K-2*D,COLORRED;
{KDJ日周金叉死叉}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
周J:="KDJ.J#WEEK"(9,3,3);
周金叉:=CROSS(周K,周D);
日金叉:=FILTER(CROSS(K,D) AND K<20,4);
DRAWTEXT(周金叉,D,'★'),COLORYELLOW;
DRAWTEXT(周金叉,D*0.93,' KD周金叉'),COLORYELLOW;
DRAWTEXT(CROSS(周D,周K),D*0.95,'KD周死叉'),COLOR00DDBB;

DRAWICON(日金叉,K,1);
DRAWTEXT(日金叉,D,'低位金叉'),COLOR00CCCC;
KDB:=BARSLAST(REF(CROSS(K,D),1));
KDDB:=REF(CLOSE,KDB+1)>CLOSE AND REF(K,KDB+1)<K AND CROSS(K,D);
K底背:=IF(FILTER(KDDB>0,5),1,0);
DRAWTEXT(K底背=1,D*0.98,'底背离'),COLORRED;
KDD:=BARSLAST(REF(CROSS(D,K),1));
K顶背:=REF(CLOSE,KDD+1)<CLOSE AND REF(K,KDD+1)>K AND CROSS(D,K);
DRAWTEXT(FILTER(K顶背>0,5),D+8,'顶背离'),COLORFFAA22;

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-6 15:16 复制 查看全部楼层
灌肠儿 发表于 2020-11-6 13:13
你做的选股指标是周线选股,我要的是在日线上,这样可以提前~谢谢啦~

这样的经典公式,在条件选股上都有,只要在周期上选择想要的周期就可。

举报

点亮(0) 扔鸡蛋(0) 回复

牛牛1888
Lv.3
发表于 2020-11-6 14:52 复制 查看全部楼层
灌肠儿 发表于 2020-11-6 13:13
你做的选股指标是周线选股,我要的是在日线上,这样可以提前~谢谢啦~

注册老师,这样表达没问题的啊

举报

扔鸡蛋(0) 回复

灌肠儿
Lv.5
发表于 2020-11-6 13:13 复制 查看全部楼层
注册111 发表于 2020-11-6 12:01
{KDJ日周金叉死叉}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);

你做的选股指标是周线选股,我要的是在日线上,这样可以提前~谢谢啦~

举报

点亮(0) 扔鸡蛋(0) 回复

灌肠儿
Lv.5
发表于 2020-11-6 13:12 复制 查看全部楼层
我要求的是像这只股票在11月3日  日线上显示周金叉~

附件

1.png

举报

点亮(0) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-6 12:01 复制 查看全部楼层

{KDJ日周金叉死叉}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
CROSS(周K,周D);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表