手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师指导一下:有几个公式,要求同时满足

[通达信]
设置
1638 7 宁波战斗机 Lv.1 发表于 · 2020-11-6 15:10 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦高手编写一个可以同时满足以下6个条件的选股公式
一,7天内出现有庄指标的选股公式
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

无庄控盘:=控盘<0;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR2:=100*WINNER(CLOSE*0.95);
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
高度控盘:=VAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
A10:=CROSS(控盘,0);
控盘B:=FILTER(IF(A10,1,0),5);
JJ:=DYNAINFO(11);
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}

P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ32:=CROSS(财,神) AND  财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
XG:EXIST(BTJ82,7);


二,短牛选股公式
N1:=5;N2:=10;
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*10;
RSI10:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*10;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0) ;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0) ;
短牛:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);


三大牛选股公式

N1:=5;N2:=10;
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*10;
RSI10:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*10;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0) ;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0) ;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
大牛:REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;

四,20天内涨幅小于20%
五,当天涨幅大小1%小于3%
六,不能是带ST的个股


麻烦高手编写一个可以同时满足以上6个条件的选股公式

举报

扔鸡蛋(0) 回复

天蝎666
Lv.2
发表于 2020-12-20 16:54 复制 查看全部楼层
加薪哥 发表于 2020-12-13 23:58
老师,你好。大牛选股公式有错误,通不过呢?
错误句 :
BNUP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13 ...

MA5:=EMA(C,5);
MA13:=EMA(C,13);
没明白你讲的,加上这个试试。

举报

点亮(0) 扔鸡蛋(0) 回复

加薪哥
Lv.2
发表于 2020-12-13 23:58 复制 查看全部楼层
天蝎666 发表于 2020-11-6 16:28
周游大哥有些小粗心,公式不能通过。我又改了几个小错误,第一段的三行有重复赋值,小牛和短牛等。现在我把 ...

老师,你好。大牛选股公式有错误,通不过呢?
错误句 :
BNUP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0)  
详细信息 : 未知字符串 MA13
错误起始位置 : 295 ; 长度: 4
安装时这样提示的。

举报

点亮(0) 扔鸡蛋(0) 回复

宁波战斗机
Lv.1
发表于 2020-11-6 16:33 复制 查看全部楼层
天蝎666 发表于 2020-11-6 16:28
周游大哥有些小粗心,公式不能通过。我又改了几个小错误,第一段的三行有重复赋值,小牛和短牛等。现在我把 ...

实测可用,感谢

举报

扔鸡蛋(0) 回复

天蝎666
Lv.2
发表于 2020-11-6 16:28 复制 查看全部楼层
周游大哥有些小粗心,公式不能通过。我又改了几个小错误,第一段的三行有重复赋值,小牛和短牛等。现在我把能通过编译的贴下面了。大神再审阅下,有没有问题。。。


ZJVAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(ZJVAR1-REF(ZJVAR1,1))/REF(ZJVAR1,1)*1000;
无庄控盘:=控盘<0;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
ZJVAR2:=100*WINNER(CLOSE*0.95);
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
高度控盘:=ZJVAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
ZJA10:=CROSS(控盘,0);
控盘B:=FILTER(IF(ZJA10,1,0),5);
JJ:=DYNAINFO(11);
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
ZJP:=55;ZJS:=8;ZJM1:=3;
财:=(EMA(CLOSE,ZJS)-EMA(CLOSE,ZJP))*10,COLORRED,LINETHICK2;
神:=EMA(财,ZJM1),COLORGREEN,LINETHICK1;
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ32:=CROSS(财,神) AND  财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
财神波段:=EXIST(BTJ82,7);

{2小牛选股公式}
DNN1:=5;DNN2:=10;
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),DNN1,1)/SMA(ABS(CLOSE-LC),DNN1,1)*10;
RSI10:=SMA(MAX(CLOSE-LC,0),DNN2,1)/SMA(ABS(CLOSE-LC),DNN2,1)*10;
DNVAR1:=C-REF(C,1);
DNVAR2:=100*EMA(EMA(DNVAR1,6),6)/EMA(EMA(ABS(DNVAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
DNUP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0) ;
DNDOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0) ;
小牛:=(LLV(DNVAR2,2)=LLV(DNVAR2,7) AND COUNT(DNVAR2<0,2) AND CROSS(DNVAR2,MA(DNVAR2,2))) AND
REF(DNDOWN,1)<REF(DNDOWN,2) AND DNUP>REF(DNDOWN,1);

{3大牛选股公式}
BNN1:=5;BNN2:=10;
{LC:=REF(CLOSE,1);
BNRSI5:=SMA(MAX(CLOSE-LC,0),BNN1,1)/SMA(ABS(CLOSE-LC),BNN1,1)*10;
BNRSI10:=SMA(MAX(CLOSE-LC,0),BNN2,1)/SMA(ABS(CLOSE-LC),BNN2,1)*10;}
BNVAR1:=C-REF(C,1);
BNVAR2:=100*EMA(EMA(BNVAR1,6),6)/EMA(EMA(ABS(BNVAR1),6),6);
BNUP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0) ;
BNDOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0) ;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
大牛:=REF(BNDOWN,1)<REF(BNDOWN,2) AND BNUP>REF(BNDOWN,1) AND C<HRY33;

{20天内涨幅小于20%}
N20涨幅:=C/REF(C,20)<1.2 AND C>REF(C,20);

{当天涨幅大小1%小于3%}
当天涨幅:=C/REF(C,1)>1.01 AND C/REF(C,1)<1.03;

{不能是带ST的个股}
ST股:=INBLOCK('ST板块');

大小都牛:财神波段 AND 小牛 AND 大牛 AND N20涨幅 AND 当天涨幅 AND NOT(ST股);
查看全部打赏
  • 福阿德+8理想币 +7共享币 : 理想精神:分享,互助,友善,传递正能量!
  • 宁波战斗机+10理想币 +2共享币 : 点赞,知识的价值在于分享,谢谢!

举报

扔鸡蛋(0) 回复

宁波战斗机
Lv.1
发表于 2020-11-6 16:22 复制 查看全部楼层
周游25 发表于 2020-11-6 16:02
6个条件估计选不出来的!
下面的试试吧
ZJVAR1:=EMA(EMA(CLOSE,13),13);

你这个指标测试通不过,不能用啊

举报

扔鸡蛋(0) 回复

天蝎666
Lv.2
发表于 2020-11-6 16:21 复制 查看全部楼层
周游25 发表于 2020-11-6 16:02
6个条件估计选不出来的!
下面的试试吧
ZJVAR1:=EMA(EMA(CLOSE,13),13);

大哥大意了吧,应该。。。

{20天内涨幅小于20%}
N20涨幅:=C/REF(C,20)<0.2 AND C>REF(C,20);

{当天涨幅大小1%小于3%}
当天涨幅:=C/REF(C,1)>0.01 AND C/REF(C,1)<0.03;



我认为应该是:

{20天内涨幅小于20%}
N20涨幅:=C/REF(C,20)<1.2 AND C>REF(C,20);

{当天涨幅大小1%小于3%}
当天涨幅:=C/REF(C,1)>1.01 AND C/REF(C,1)<1.03;


我个人认为应该是这样的,我刚刚学,也不知道对不对。

举报

点亮(1) 扔鸡蛋(0) 回复

周游25
Lv.2
发表于 2020-11-6 16:02 复制 查看全部楼层
6个条件估计选不出来的!
下面的试试吧
ZJVAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(ZJVAR1-REF(ZJVAR1,1))/REF(ZJVAR1,1)*1000;
无庄控盘:=控盘<0;
ZJVAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(ZJVAR1-REF(ZJVAR1,1))/REF(ZJVAR1,1)*1000;
无庄控盘:=控盘<0;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
ZJVAR2:=100*WINNER(CLOSE*0.95);
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
高度控盘:=ZJVAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
ZJA10:=CROSS(控盘,0);
控盘B:=FILTER(IF(ZJA10,1,0),5);
JJ:=DYNAINFO(11);
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
ZJP:=55;ZJS:=8;ZJM1:=3;
财:=(EMA(CLOSE,ZJS)-EMA(CLOSE,ZJP))*10,COLORRED,LINETHICK2;
神:=EMA(财,ZJM1),COLORGREEN,LINETHICK1;
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ32:=CROSS(财,神) AND  财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
财神波段:=EXIST(BTJ82,7);

{2短牛选股公式}
DNN1:=5;DNN2:=10;
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),DNN1,1)/SMA(ABS(CLOSE-LC),DNN1,1)*10;
RSI10:=SMA(MAX(CLOSE-LC,0),DNN2,1)/SMA(ABS(CLOSE-LC),DNN2,1)*10;
DNVAR1:=C-REF(C,1);
DNVAR2:=100*EMA(EMA(DNVAR1,6),6)/EMA(EMA(ABS(DNVAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
DNUP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0) ;
DNDOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0) ;
短牛:=(LLV(DNVAR2,2)=LLV(DNVAR2,7) AND COUNT(DNVAR2<0,2) AND CROSS(DNVAR2,MA(DNVAR2,2))) AND
REF(DNDOWN,1)<REF(DNDOWN,2) AND DNUP>REF(DNDOWN,1);

{3大牛选股公式}
BNN1:=5;BNN2:=10;
{LC:=REF(CLOSE,1);
BNRSI5:=SMA(MAX(CLOSE-LC,0),BNN1,1)/SMA(ABS(CLOSE-LC),BNN1,1)*10;
BNRSI10:=SMA(MAX(CLOSE-LC,0),BNN2,1)/SMA(ABS(CLOSE-LC),BNN2,1)*10;}
BNVAR1:=C-REF(C,1);
BNVAR2:=100*EMA(EMA(BNVAR1,6),6)/EMA(EMA(ABS(BNVAR1),6),6);
BNUP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0) ;
BNDOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0) ;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
大牛:REF(BNDOWN,1)<REF(BNDOWN,2) AND BNUP>REF(BNDOWN,1) AND C<HRY33;

{20天内涨幅小于20%}
N20涨幅:=C/REF(C,20)<0.2 AND C>REF(C,20);

{当天涨幅大小1%小于3%}
当天涨幅:=C/REF(C,1)>0.01 AND C/REF(C,1)<0.03;

{不能是带ST的个股}
ST股:=INBLOCK('ST板块');

大小都牛:财神波段 AND 小牛 AND 大牛 AND N20涨幅 AND 当天涨幅 AND NOT(ST股);

查看全部打赏
  • 宁波战斗机+10理想币 +2共享币 : 点赞,知识的价值在于分享,谢谢!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表