手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个预警公式

[通达信]
设置
1204 1 江苏一丝阳光 Lv.2 发表于 · 2020-11-6 16:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

M5:MA(C,5);
M10:MA(C,10);

M60:MA(C,60),LINETHICK2;
金叉:=CROSS(M5>M10,0.5);
金叉天数:=BARSLAST(金叉);
死叉:=CROSS(M10>M5,0.5);
顶:=CROSS(BACKSET(死叉,REF(BARSLAST(HHV(H,金叉天数+1)=H),1)+2),0.5);
DRAWLINE(顶,H,REF(顶,1),REF(H,1),1);
突破:=COUNT(C>M60,BARSLAST(死叉)+1)=BARSLAST(死叉)+1 AND CROSS(C>REF(H,BARSLAST(顶)),0.5);
STICKLINE(突破,C,REF(H,BARSLAST(顶)),1,0),COLORRED;


当股价触碰最后一根绿线时(或者限制在是10日内出现的绿线)预警,触碰以前的绿线不要预警,谢谢老师

附件

QQ图片20201106161755.png

举报

扔鸡蛋(0) 回复

好好听哦
Lv.4
发表于 2020-11-6 17:31 复制 查看全部楼层
M5:=MA(C,5);
M10:=MA(C,10);
金叉:=CROSS(M5>M10,0.5);
金叉天数:=BARSLAST(金叉);
死叉:=CROSS(M10>M5,0.5);
顶:=CROSS(BACKSET(死叉,REF(BARSLAST(HHV(H,金叉天数+1)=H),1)+2),0.5);
X1:=DRAWLINE(顶,H,REF(顶,1),REF(H,1),1);
XG:H>=REF(H,BARSLAST(顶)) AND BARSLAST(顶)<10;

不知是否适合你的意思

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表