手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助根据邱一平老师的四个指标改成通达信版的四量图

[通达信]
设置
1984 3 响湾头 Lv.2 发表于 · 2020-11-6 21:49 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
EMV源码(通达信):

N:2  90  14
M:2  60  9
VOLUME:=MA(VOL,N)/VOL;
MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);
EMV:MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,N),N);
MAEMV:MA(EMV,M);


WVAD 源码(通达信):
N:2  120  24
M:2  60   6
WVAD:SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,N)/10000;
MAWVAD:MA(WVAD,M);


邱氏曲腰量源码(钱龙版源码,需改成通达信版):

N1   0        1000        30
N2   0        1000        30
M     0        1000        6

RES1:=MA(CLOSE,N1);
RES2:=MA(AMOUNT,N2);
SOURCE1:=(AMOUNT/RES2-1)*100.0-(CLOSE/RES1-1)*100.0;
SOURCE2:=MA(SOURCE1,N2);
REF1:=REF(SOURCE2,1);
REF2:=REF(SOURCE1,N2);
IF(BARSCOUNT(CLOSE)>=(N1+N2-1)) THEN
SV:REF1*N2-REF2+SOURCE1)/N2,COLORSTICK;
MA:MA(SV,M);  
邱氏量法源码:

{N1:1,999,30}

{N2:1,999,6}

CHIU1:=(AMOUNT/MA(AMOUNT,N1)-1);

CHIU:SUM(CHIU1,0),COLORSTICK;

CHIUMA:MA(CHIU,N2);

举报

扔鸡蛋(0) 回复

响湾头
Lv.2
发表于 2020-11-8 06:01 复制 查看全部楼层
买你的也可呀

举报

扔鸡蛋(0) 回复

响湾头
Lv.2
发表于 2020-11-8 06:00 复制 查看全部楼层
请问老师,你有吗

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-7 08:59 复制 查看全部楼层
N:=(2,  90,  14);
M:=(2,  60,  9);
VOLUME:=MA(VOL,N)/VOL;
MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);
EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,N),N);
MAEMV:=MA(EMV,M);
STICKLINE(EMV>MAEMV,0,8,5,0),COLORRED;
STICKLINE(EMV<MAEMV,0,8,5,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,4,'EMV'),COLORBLACK;
{WVAD 源码(通达信):}
N1:=(2,  120,  24);
M1:=(2,  60,   6);
WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,N1)/10000;
MAWVAD:=MA(WVAD,M1);
STICKLINE(WVAD>MAWVAD,10,18,5,0),COLORRED;
STICKLINE(WVAD<MAWVAD,10,18,5,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,14,'WVAD'),COLORBLACK;

{邱氏曲腰量源码(钱龙版源码,需改成通达信版):}

N2:=(   0,        1000,        30);
M2:=(     0,        1000,        6);
RES1:=MA(CLOSE,N2);
RES2:=MA(AMOUNT,N2);
SOURCE1:=(AMOUNT/RES2-1)*100.0-(CLOSE/RES1-1)*100.0;
SOURCE2:=MA(SOURCE1,N2);
REF1:=REF(SOURCE2,1);
REF2:=REF(SOURCE1,N2);
SV:=IF(BARSCOUNT(CLOSE)>=(N1+N2-1),REF1*N2-REF2+SOURCE1/N2,0),COLORSTICK;
MA1:=MA(SV,M2);  
STICKLINE(SV>MA1,20,28,5,0),COLORRED;
STICKLINE(SV<MA1,20,28,5,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,24,'邱氏曲腰量'),COLORBLACK;


{邱氏量法源码:}

CHIU1:=(AMOUNT/MA(AMOUNT,N2)-1);

CHIU:=SUM(CHIU1,0),COLORSTICK;

CHIUMA:=MA(CHIU,M2);

STICKLINE(CHIU>CHIUMA,30,38,5,0),COLORRED;
STICKLINE(CHIU<CHIUMA,30,38,5,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,34,'邱氏量法'),COLORBLACK;

附件

捕获.JPG

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表