请老师帮助修改一下选股公式指标,就是当白线在数值10~20左右时可以全部选出来,...

[通达信]
设置
1772 13 楚留香1971 Lv.2 发表于 · 2020-11-7 12:26 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI2:SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
RSI3:SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;

附件

123.png
321.png

举报

扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-16 14:25 复制 查看全部楼层
已经复制粘贴到附图里了,主图不会压缩,附图会,压缩成一条线了。

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 14:12 复制 查看全部楼层
主图可以。你把指标复制粘贴到附图里不就行了。

举报

点亮(0) 扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-16 09:43 复制 查看全部楼层
许昌舍得 发表于 2020-11-16 08:35
MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;

许昌老师,还是不行啊,我需要的是在分时副图里面用的,你的这 个指标还只是能在分时图里用,副图根本不起作用,什么都 显示不了。请再修改一下册,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-16 08:35 复制 查看全部楼层
楚留香1971 发表于 2020-11-8 09:52
谢谢老师,可以用了,非常感谢!

MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;
STICKLINE((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLORRED,LINETHICK3;
支撑:L1+P1*0.5/8,COLORWHITE,LINETHICK3;
现价:CLOSE,COLORWHITE;

STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'买★B'),COLORYELLOW;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价*0.997,'卖★'),COLOR00FF00;

DRAWTEXT_FIX(1,0.5,0.009,0,'指令:    开盘在红色线之上禁止用SKDJ做 T+0')COLORYELLOW;

附件

tdxjietu1.JPG

举报

点亮(0) 扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-8 09:52 复制 查看全部楼层
休闲者68 发表于 2020-11-8 08:08
7楼是两个公式,不能一起安装,要分别安装才行。

谢谢老师,可以用了,非常感谢!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-8 08:08 复制 查看全部楼层

7楼是两个公式,不能一起安装,要分别安装才行。

举报

点亮(0) 扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-7 22:43 复制 查看全部楼层
休闲者68 发表于 2020-11-7 22:04
{公式1}
WR1:=100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));
BETWEEN(WR1,90,100);

还是不行哦



当前公式 : 顶部90左右 (条件选股公式)  
错误句 :  
详细信息 : 对不起,条件选股公式顶部90左右输出不能超过1个!
错误起始位置 : 137 ; 长度: 7

附件

123.png

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-7 22:04 复制 查看全部楼层
本帖最后由 休闲者68 于 2020-11-8 08:07 编辑
楚留香1971 发表于 2020-11-7 20:43
有错,运行不了!请麻烦再修改一下,谢谢老师!

当前公式 : 顶部90左右 (条件选股公式)  


{公式1}
WR1:=100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));
BETWEEN(WR1,90,100);






{公式2}
WR2:=100*(HHV(HIGH,N1)-CLOSE)/(HHV(HIGH,N1)-LLV(LOW,N1));
BETWEEN(WR2,90,100);

举报

点亮(0) 扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-7 20:43 复制 查看全部楼层
休闲者68 发表于 2020-11-7 15:54
WR1:100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));
BETWEEN(WR1,90,100);

有错,运行不了!请麻烦再修改一下,谢谢老师!

当前公式 : 顶部90左右 (条件选股公式)  
错误句 :  
详细信息 : 对不起,条件选股公式顶部90左右输出不能超过1个!
错误起始位置 : 137 ; 长度: 7

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-7 15:54 复制 查看全部楼层
楚留香1971 发表于 2020-11-7 13:47
休闲者68老师,可以再帮我修改一个公式吗?谢谢!选择90-100数值时可以选出来。

WR1:100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));
BETWEEN(WR1,90,100);







WR2:100*(HHV(HIGH,N1)-CLOSE)/(HHV(HIGH,N1)-LLV(LOW,N1));
BETWEEN(WR2,90,100);

举报

点亮(0) 扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-7 13:47 复制 查看全部楼层

休闲者68老师,可以再帮我修改一个公式吗?谢谢!选择90-100数值时可以选出来。



WR1:100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));
WR2:100*(HHV(HIGH,N1)-CLOSE)/(HHV(HIGH,N1)-LLV(LOW,N1));

附件

123.png

举报

点亮(0) 扔鸡蛋(0) 回复

楚留香1971
Lv.2
发表于 2020-11-7 13:21 复制 查看全部楼层
休闲者68 发表于 2020-11-7 12:38
{N1 2 120 9}
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;

谢谢老师!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-7 12:38 复制 查看全部楼层
{N1 2 120 9}
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
BETWEEN(RSI1,10,20);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表