手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙看看这个公式怎么选不出股?

[通达信]
设置
1278 4 起来炒股 Lv.3 发表于 · 2020-11-7 16:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DIFF:=EMA(CLOSE,5)-EMA(CLOSE,13);
DEA:=EMA(DIFF,8);
MACD:=2*(DIFF-DEA);
A:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背:=REF(CLOSE,A+1)>CLOSE AND DIFF>REF(DIFF,A+1) AND CROSS(DIFF,DEA);
RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A1:=BARSLAST(REF(CROSS(J,K),1));
底背:=REF(CLOSE,A1+1)>CLOSE AND J>REF(J,A1+1) AND CROSS(J,K);
金叉:=IF(SUM(CROSS(K,D)AND D<25,15)>=2 AND CROSS(K,D)AND C>O,1.1,0);
TJ1:=EVERY(MA(C,24)>REF(MA(C,24),1),4);
TJ2:=EXIST(CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA>0,4);
TJ3:=EVERY(MACD.DIF>REF(MACD.DIF,1),4);
XG:TJ1 AND TJ2 AND TJ3  AND 背 AND 底背  AND   金叉 ;

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-11-7 17:11 复制 查看全部楼层
起来炒股 发表于 2020-11-7 17:01
老师帮改一下吧!  谢谢

你这个条件是矛盾的又要均线向上又要背离又要金叉 你把选股条件逐一删除 看看想要那个就保留那个就行了 本身kdj就是快线均线都向上了还要金叉那首先就得打下来 打下来你还要均线不动 那是不可能的

举报

点亮(0) 扔鸡蛋(0) 回复

起来炒股
Lv.3
发表于 2020-11-7 17:01 复制 查看全部楼层
老师帮改一下吧!  谢谢

举报

扔鸡蛋(0) 回复

竹隐风雷
Lv.4
发表于 2020-11-7 16:31 复制 查看全部楼层
金叉的条件过于苛刻了

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表