手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改个选股公式

[通达信]
设置
1283 2 糟糕没缘 Lv.3 发表于 · 2020-11-9 14:48 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_3:=IF(NAMELIKE(12) OR NAMELIKE(13) OR NAMELIKE(14),0,1);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_9:=(2*CLOSE+HIGH+LOW+OPEN)/5;
宇亮1:=EMA(HHV(HIGH,500),21);
宇亮2:=EMA(HHV(HIGH,250),21);
宇亮3:=EMA(HHV(HIGH,90),21);
宇亮5:=EMA(LLV(LOW,500),21);
宇亮6:=EMA(LLV(LOW,250),21);
宇亮8:=EMA(LLV(LOW,90),21);
宇亮9:=EMA((宇亮5*0.96+宇亮6*0.96+宇亮8*0.96+宇亮1*0.558+宇亮2*0.558+宇亮3*0.558)/6,21);
宇亮A1:=EMA((宇亮5*1.25+宇亮6*1.23+宇亮8*1.2+宇亮1*0.55+宇亮2*0.55+宇亮3*0.65)/6,21);
宇亮A2:=EMA((宇亮5*1.3+宇亮6*1.3+宇亮8*1.3+宇亮1*0.68+宇亮2*0.68+宇亮3*0.68)/6,21);
宇亮A3:=EMA((宇亮9*3+宇亮A1*2+宇亮A2)/6*1.738,21);
宇亮A5:=REF(LOW,1);
宇亮A6:=SMA(ABS(LOW-宇亮A5),3,1)/SMA(MAX(LOW-宇亮A5,0),3,1)*100;
宇亮A8:=EMA(IF(CLOSE*1.35<=宇亮A3,宇亮A6*10,宇亮A6/10),3);
宇亮A9:=LLV(LOW,30);
宇亮S1:=HHV(宇亮A8,30);
宇亮10:=IF(MA(CLOSE,58),1,0);
宇亮主力介入: EMA(IF(LOW<=宇亮A9,(宇亮A8+宇亮S1*2)/2,0),3)/618*宇亮10;
有宇亮主力介入:IF(宇亮主力介入>0,宇亮主力介入,0),STICK,LINETHICK2, COLOR0000FF;

宇亮介入度: 宇亮主力介入;
宇亮N1:IF(宇亮主力介入>0,宇亮介入度*1.2,0),STICK,LINETHICK5, COLOR0000FF;
宇亮N2:IF(宇亮主力介入>0,宇亮介入度*0.8,0),STICK,LINETHICK5, COLOR0000FF;
宇亮N3:IF(宇亮主力介入>0,宇亮介入度*0.6,0),STICK,LINETHICK5, COLOR0000FF;
宇亮N5:IF(宇亮主力介入>0,宇亮介入度*0.4,0) ,STICK,LINETHICK5,COLOR0000FF;
宇亮N6:IF(宇亮主力介入>0,宇亮介入度*0.2,0) ,STICK,LINETHICK5,COLOR0000FF;

举报

扔鸡蛋(0) 回复

糟糕没缘
Lv.3
发表于 2020-11-9 16:19 复制 查看全部楼层
注册111 发表于 2020-11-9 15:27
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE

非常谢谢注册111老师

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-9 15:27 复制 查看全部楼层
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_3:=IF(NAMELIKE(12) OR NAMELIKE(13) OR NAMELIKE(14),0,1);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_9:=(2*CLOSE+HIGH+LOW+OPEN)/5;
宇亮1:=EMA(HHV(HIGH,500),21);
宇亮2:=EMA(HHV(HIGH,250),21);
宇亮3:=EMA(HHV(HIGH,90),21);
宇亮5:=EMA(LLV(LOW,500),21);
宇亮6:=EMA(LLV(LOW,250),21);
宇亮8:=EMA(LLV(LOW,90),21);
宇亮9:=EMA((宇亮5*0.96+宇亮6*0.96+宇亮8*0.96+宇亮1*0.558+宇亮2*0.558+宇亮3*0.558)/6,21);
宇亮A1:=EMA((宇亮5*1.25+宇亮6*1.23+宇亮8*1.2+宇亮1*0.55+宇亮2*0.55+宇亮3*0.65)/6,21);
宇亮A2:=EMA((宇亮5*1.3+宇亮6*1.3+宇亮8*1.3+宇亮1*0.68+宇亮2*0.68+宇亮3*0.68)/6,21);
宇亮A3:=EMA((宇亮9*3+宇亮A1*2+宇亮A2)/6*1.738,21);
宇亮A5:=REF(LOW,1);
宇亮A6:=SMA(ABS(LOW-宇亮A5),3,1)/SMA(MAX(LOW-宇亮A5,0),3,1)*100;
宇亮A8:=EMA(IF(CLOSE*1.35<=宇亮A3,宇亮A6*10,宇亮A6/10),3);
宇亮A9:=LLV(LOW,30);
宇亮S1:=HHV(宇亮A8,30);
宇亮10:=IF(MA(CLOSE,58),1,0);
宇亮主力介入:=EMA(IF(LOW<=宇亮A9,(宇亮A8+宇亮S1*2)/2,0),3)/618*宇亮10;
宇亮介入度:=宇亮主力介入;
CROSS(宇亮介入度<REF(宇亮介入度,1),0.5);

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表