手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

麻烦各位懂指标的老师进来看一下,感谢

设置
2457 5 咸鱼666 Lv.2 发表于 · 2020-11-9 15:37 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
别人发给我的一个选股公式,但是测试的时候显示缺少一个输出条件,麻烦各位老师帮我修改一下。


MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA5)/MA5*100;
BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
三拾日乖离率:=(C-MA30)/MA30*100;
VAR1:=(MA20-MA30)>REF((MA20-MA30),1)AND MA20>REF(MA20,1)AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1)AND MA20<REF(MA20,1)AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1)AND 速度5>REF(速度5,1),10);
清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1)AND 三拾日乖离率<REF(三拾日乖离率,1)AND MA10<REF(MA10,1),10);
JC:=CROSS(0,五日乖离率)AND 三拾日乖离率<REF(三拾日乖离率,1)AND MA10>REF(MA10,1);
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
支撑:=MA(REF(LLV(C,30),1),2);

举报

扔鸡蛋(0) 回复

缝骨刀
Lv.5
发表于 2020-11-9 23:14 复制 查看全部楼层
弃了吧!
无效语句太多,
条件逻辑陈旧,
还不够伤累电脑的~~~

举报

点亮(1) 扔鸡蛋(0) 回复

期权量夫
Lv.2
发表于 2020-11-9 21:27 复制 查看全部楼层
选股公式:
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA5)/MA5*100;
BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1)*5;
加速度5:=EMA((速度5-REF(速度5,1)),3)*5;
三拾日乖离率:=(C-MA30)/MA30*100;
强势狙击:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1)AND 速度5>REF(速度5,1),10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,7);
买点:=CROSS(三拾日乖离率,五日乖离率) AND 三拾日乖离率>REF(三拾日乖离率,1);
共振买点:强势狙击 AND 买入;

举报

扔鸡蛋(0) 回复

期权量夫
Lv.2
发表于 2020-11-9 21:20 复制 查看全部楼层
副图公式:
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:(C-MA5)/MA5*100,COLORYELLOW;
BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
速度5:SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1)*5,COLORLIGRAY,DOTLINE;
加速度5:EMA((速度5-REF(速度5,1)),3)*5,COLORLIRED,DOTLINE;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
三拾日乖离率:(C-MA30)/MA30*100,COLORRED;
VAR1:=(MA20-MA30)>REF((MA20-MA30),1)AND MA20>REF(MA20,1)AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1)AND MA20<REF(MA20,1)AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1)AND 速度5>REF(速度5,1),10);
DRAWICON(强势狙击,三拾日乖离率,9);
清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1)AND 三拾日乖离率<REF(三拾日乖离率,1)AND MA10<REF(MA10,1),3);
DRAWICON(清仓,三拾日乖离率,15);
JC:=CROSS(0,五日乖离率)AND 三拾日乖离率<REF(三拾日乖离率,1)AND MA10>REF(MA10,1);
减仓:=FILTER(JC,3);
DRAWICON(减仓 AND 三拾日乖离率<REF(三拾日乖离率,1),三拾日乖离率,8);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,7);
DRAWICON(FILTER(MR,10),10,7);
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
支撑:=MA(REF(LLV(C,30),1),2);
买点:CROSS(三拾日乖离率,五日乖离率) AND 三拾日乖离率>REF(三拾日乖离率,1),COLORMAGENTA,NODRAW;
DRAWICON(CROSS(三拾日乖离率,五日乖离率) AND 三拾日乖离率>REF(三拾日乖离率,1),五日乖离率,34);
共振买点:强势狙击 AND 买入,COLORRED,NODRAW;
DRAWICON(共振买点,速度5,25);

举报

扔鸡蛋(0) 回复

青稞酒一壶
Lv.4
发表于 2020-11-9 15:45 复制 查看全部楼层
MA5:=MA(C,5);
MA30:=MA(C,30);
五日乖离率:=(C-MA5)/MA5*100;
三拾日乖离率:=(C-MA30)/MA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:FILTER(MR,10);

举报

点亮(0) 扔鸡蛋(0) 回复

王人二
Lv.7
发表于 2020-11-9 15:40 复制 查看全部楼层
随便一个等号去掉就不会报错

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表