手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编辑个指标幅图

[通达信]
设置
1335 3 一位道友 Lv.3 发表于 · 2020-11-9 19:05 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师帮忙把以下的5日线10日线填色主图公式改成指标幅图,感谢!!!
DRAWBAND(MA(CLOSE,5),RGB(190,16,0),MA(CLOSE,10),RGB(0,0,130));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);

举报

扔鸡蛋(0) 回复

一位道友
Lv.3
发表于 2020-11-10 16:44 复制 查看全部楼层
一天行情 发表于 2020-11-10 09:09
JJ1:=DRAWBAND(MA(CLOSE,5),RGB(190,16,0),MA(CLOSE,10),RGB(0,0,130));
JJ2:=DRAWKLINE(HIGH,OPEN,LOW,CL ...

老师你好可以帮我改一下吗?改成用红绿灯指标来,只要5日线和10线出现金叉就显示一条红色,死叉就显示绿色可以吗,我把红绿灯指标的源码发给你,帮忙修改一下,红绿灯显示的是4个周期,我只要在指标上面显示一条就可以了,样子像红绿灯。万分感谢!!!



F15A:=MAX(MA(C,5),MA(C,10));
F15B:=MIN(MA(C,5),MA(C,10));
绿行F15:C>F15A,COLORGREEN;
红停F15:C<F15B,COLORRED;
黄望F15:C>=F15B AND C<=F15A,COLORYELLOW;
STICKLINE(C>F15A,3.3,4,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<F15B,3.3,4,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=F15B AND C<=F15A,3.3,4,8,0),COLORYELLOW,LINETHICK2;

F30A:=MAX(MA(C,10),MA(C,20));
F30B:=MIN(MA(C,10),MA(C,20));
绿行F30:C>F30A,COLORGREEN;
红停F30:C<F30B,COLORRED;
黄望F30:C>=F30B AND C<=F30A,COLORYELLOW;
STICKLINE(C>F30A,2.3,3,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<F30B,2.3,3,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=F30B AND C<=F30A,2.3,3,8,0),COLORYELLOW,LINETHICK2;

F60A:=MAX(MA(C,20),MA(C,28));
F60B:=MIN(MA(C,20),MA(C,28));
绿行F60:C>F60A,COLORGREEN;
红停F60:C<F60B,COLORRED;
黄望F60:C>=F60B AND C<=F60A,COLORYELLOW;
STICKLINE(C>F60A,1.3,2,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<F60B,1.3,2,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=F60B AND C<=F60A,1.3,2,8,0),COLORYELLOW,LINETHICK2;

FRA:=MAX(MA(C,60),MA(C,120));
FRB:=MIN(MA(C,60),MA(C,120));
绿行FR:C>FRA,COLORGREEN;
红停FR:C<FRB,COLORRED;
黄望FR:C>=F30B AND C<=F30A,COLORYELLOW;
STICKLINE(C>FRA,0,1,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<FRB,0,1,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=FRB AND C<=FRA,0,1,8,0),COLORYELLOW,LINETHICK2;

DPA:=MAX(MA(INDEXC,60),MA(INDEXC,120));
DPB:=MIN(MA(INDEXC,60),MA(INDEXC,120));
绿行DP:INDEXC>DPA,COLORGREEN;
红停DP:INDEXC<DPB,COLORRED;
黄望DP:INDEXC>=DPB AND INDEXC<=DPA,COLORYELLOW;
STICKLINE(INDEXC>DPA,4.3,5,8,0),COLORGREEN,LINETHICK2;
STICKLINE(INDEXC<DPB,4.3,5,8,0),COLORRED,LINETHICK2;
STICKLINE(INDEXC>=DPB AND INDEXC<=DPA,4.3,5,8,0),COLORYELLOW,LINETHICK2;

附件

QQ图片20201110164330.png

举报

点亮(0) 扔鸡蛋(0) 回复

红茶2014
Lv.4
发表于 2020-11-10 10:18 复制 查看全部楼层
DRAWBAND(MA(CLOSE,5),RGB(190,16,0),MA(CLOSE,10),RGB(0,0,130));
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);

举报

扔鸡蛋(0) 回复

一天行情
Lv.4
发表于 2020-11-10 09:09 复制 查看全部楼层
JJ1:=DRAWBAND(MA(CLOSE,5),RGB(190,16,0),MA(CLOSE,10),RGB(0,0,130));
JJ2:=DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
IF(MA5>MA10,MA5,DRAWNULL),COLORRED,LINETHICK4;

IF(MA5<MA10,MA5,DRAWNULL),COLORGREEN,LINETHICK4;
2020-11-10_090922.png

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表