手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这两个选股公式合二为一

[通达信]
设置
1298 6 折纸登月 Lv.3 发表于 · 2020-11-9 21:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
公式1;BR:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);

买好股:=IF(MA(CLOSE,17)<BR,BR,MA(CLOSE,17));

YR:=买好股-(EMA(C,3)-买好股);

M5:=MA(C,5);

XG:CROSS(M5,YR);
公式2;C1:=C/REF(C,1);
MX:=EMA(SLOPE(C,N2)*20+C,N1);
MXR:=MX/REF(MX,1);
MR:=SLOPE(MX,2);
MRD:=CROSS(0,MR);
TMR:=BARSLAST(MRD);
MRR:=REF(MX,TMR);
MN3:=HHV(MRR,N3);
大肉:CROSS(C,MN3)&&C1>1.035;

举报

扔鸡蛋(0) 回复

天子蓝1
Lv.2
发表于 2020-11-9 23:06 复制 查看全部楼层
N1:=6;
N2:=6;
N3:=6;
BR:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);

买好股:=IF(MA(CLOSE,17)<BR,BR,MA(CLOSE,17));
YR:=买好股-(EMA(C,3)-买好股);
M5:=MA(C,5);
XG:=CROSS(M5,YR);
C1:=C/REF(C,1);
MX:=EMA(SLOPE(C,N2)*20+C,N1);
MXR:=MX/REF(MX,1);
MR:=SLOPE(MX,2);
MRD:=CROSS(0,MR);
TMR:=BARSLAST(MRD);
MRR:=REF(MX,TMR);
MN3:=HHV(MRR,N3);
大肉:=CROSS(C,MN3) AND C1>1.035;

GZ:大肉 AND XG;

举报

扔鸡蛋(0) 回复

折纸登月
Lv.3
发表于 2020-11-9 23:04 复制 查看全部楼层
天子蓝1,老师,加在YR:=买好股-(EMA(C,3)-买好股);后面,还是不行,麻烦老师把整个选股公式贴上来吧,麻烦了

举报

点亮(0) 扔鸡蛋(0) 回复

天子蓝1
Lv.2
发表于 2020-11-9 22:33 复制 查看全部楼层
BR:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
加上这个

举报

点亮(0) 扔鸡蛋(0) 回复

折纸登月
Lv.3
发表于 2020-11-9 21:47 复制 查看全部楼层
许昌舍得老师,当前公式 : 有肉买好股 (条件选股公式)  
错误句 :
买好股:=IF(MA(CLOSE,17)<BR,BR,MA(CLOSE,17))
详细信息 : 未知字符串 BR
错误起始位置 : 48 ; 长度: 2,麻烦老师再看看

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-9 21:42 复制 查看全部楼层
N1:=6;
N2:=6;
N3:=6;
买好股:=IF(MA(CLOSE,17)<BR,BR,MA(CLOSE,17));
YR:=买好股-(EMA(C,3)-买好股);
M5:=MA(C,5);
XG:=CROSS(M5,YR);
C1:=C/REF(C,1);
MX:=EMA(SLOPE(C,N2)*20+C,N1);
MXR:=MX/REF(MX,1);
MR:=SLOPE(MX,2);
MRD:=CROSS(0,MR);
TMR:=BARSLAST(MRD);
MRR:=REF(MX,TMR);
MN3:=HHV(MRR,N3);
大肉:=CROSS(C,MN3) AND C1>1.035;

GZ:大肉 AND XG;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表