手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股公式

[通达信]
设置
1351 3 邵冠豪 Lv.2 发表于 · 2020-11-10 17:09 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),21,1)/SMA(ABS(CLOSE-AA),21,1)*1000;
HHH:=BBB-LLV(BBB,27);
CCC:=LLV(BBB,27)-BBB;
QQ:=(MA(HHH,2)*3+HHH*13)/16,COLORFF00FF,LINETHICK1;
SS:=(MA(CCC,2)*3+CCC*13)/16,COLORFF00FF,LINETHICK1;
GG:=MA(HHH,5),LINETHICK1,COLORGREEN;
MM:=MA(CCC,5),LINETHICK1,COLORGREEN;
WW:=IF(QQ<GG,SS,MM),LINETHICK1,COLOR0000FF;
EE:=IF(SS<MM,GG,QQ),COLORFFFFCC,LINETHICK1;
★买:=IF(EE-WW<5.6,200,0);
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
买AA:=黄金 AND RSVV<VARB2-2;
特准:(买AA>0)*3,LINETHICK2;
CM1:=EMA(C,2);
CM2:=EMA(C,18);
TJ1:=IF(CROSS(CM2,CM1),1,0);
A1:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
TJ2:=(A1/2+22)*1;
Q:=EMA(VOL,13);
Y:=EMA(AMOUNT,13);
S:=(Y/Q)/100;
X:=((CLOSE-S)/S)*100;
F:=X<0 AND ZXNH;
XQ:=F AND A1<TJ2-2;
阴线买入:(TJ1 AND XQ)*2;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
阶段卖出: 3.2,COLORC6C600;
3.5,COLOR0088FF;
清仓卖出: 3.5,COLORFF75FF;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLOR00FF00;
底部:0.2,COLOR70DB93;
关注:0.5,COLORYELLOW;
DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(清仓卖出,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,底部),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(阶段卖出,动力线),20),动力线+0.02,2);
强弱分界线:1.75,POINTDOT,LINETHICK2,COLOR70DB93;
数值:=动力线,COLORA8A8A8;
MA1:=MA(C,5);MA2:=MA(C,10);
MA3:=MA(C,20);MA4:=MA(C,40);
MA5:=MA(C,60);MA6:=MA(C,30);
MA7:=MA(C,120);
P3:=ABS(MA1-MA2)+ABS(MA2-MA3)+ABS(MA1-MA3);
良知之花:=IF(P3/C<6/100,2,0)COLORFF00FF,LINETHICK3;
K1:=1;M1:=5;M2:=10;M3:=20;M4:=60;P:=VOL;
牛波波:=IF(MA(P,M1)>MA(P,M4)*0.9,2,0)COLORFF33CC,LINETHICK3;
VOLUME:=VOL;
LB:=VOL/REF(MA(VOL,5),1)COLORGREEN;
LONG:=26;SHORT:=12;M:=9;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
顽强绽放:=IF(CROSS(DIFF,DEA) AND MACD>REF(MACD,1),1,0)COLORRED,LINETHICK2;
香飘世界:=IF(CROSS(DIFF,DEA) AND DIFF<0 AND DEA<0 AND MACD>REF(MACD,1),1,0)COLORRED,LINETHICK2;
空依子:=IF(DIFF>0 AND DEA>0 AND CROSS(DIFF,DEA) AND MACD>REF(MACD,1),1,0)COLORRED,LINETHICK2;
地量180:IF(VOL<REF(LLV(VOL,180),1),1.8,0)COLOR9999FF,LINETHICK3;
地量150:IF(VOL<REF(LLV(VOL,150),1),1.5,0)COLORFFFF00,LINETHICK3;
地量120:IF(VOL<REF(LLV(VOL,120),1),1.2,0)COLOR0066FF,LINETHICK3;
地量90:IF(VOL<REF(LLV(VOL,90),1),0.9,0)COLORYELLOW,LINETHICK3;
地量60:IF(VOL<REF(LLV(VOL,60),1),0.6,0)COLORFF00FF,LINETHICK3;
地量40:=IF(VOL<REF(LLV(VOL,40),1),0.4,0)COLORGREEN,LINETHICK3;
春天里:=IF(香飘世界=1 AND REF(EXIST(香飘世界=1,40),12) AND (DEA>REF(DEA,12) OR DEA>REF(DEA,13) OR DEA>REF(DEA,14)
OR DEA>REF(DEA,15) OR DEA>REF(DEA,16) OR DEA>REF(DEA,17) OR DEA>REF(DEA,18) OR DEA>REF(DEA,19) OR DEA>REF(DEA,20)
OR DEA>REF(DEA,21) OR DEA>REF(DEA,22) OR DEA>REF(DEA,23) OR DEA>REF(DEA,24) OR DEA>REF(DEA,25) OR DEA>REF(DEA,26)),1,0)COLORFF00FF,LINETHICK2;
希望1:=IF((EXIST(地量150=1.5,12) OR EXIST(地量120=1.2,12) OR EXIST(地量90=0.9,12)) AND 顽强绽放,1,0)COLORWHITE,LINETHICK8;
希望2:=IF((EXIST(地量150=1.5,12) OR EXIST(地量120=1.2,12) OR EXIST(地量90=0.9,12)) AND 顽强绽放,1,0)COLORYELLOW,LINETHICK8;
希望3:=IF((EXIST(地量120=1.2,10) OR EXIST(地量90=0.9,10) OR EXIST(地量60=0.6,10) OR EXIST(地量40=0.4,10)) AND 顽强绽放,1,0)COLORYELLOW,LINETHICK8;
安全奖:IF(希望1 AND 香飘世界 AND (春天里 OR REF(春天里,1)) AND LB>1,1.8,0)COLORGREEN,LINETHICK8;
平和奖:IF(希望2 AND C<MA5*1.2 AND LB>2.2,1.2,0)COLORRED,LINETHICK8;
WJ:=(MA5>REF(MA5,1) AND REF(MA5,1)>REF(MA5,2)) AND (MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1));
勇气奖:IF(希望3 AND 空依子 AND (良知之花 OR REF(良知之花,1)) AND WJ AND C>MA1 AND MA1>MA5 AND MA3>MA5 AND EXIST(MA1<MA3,5) AND LB>2,1,0)COLORYELLOW,LINETHICK8;
本主题由 任务系统 于 2020-11-10 17:13 审核通过

举报

扔鸡蛋(0) 回复

邵冠豪
Lv.2
发表于 2020-11-10 20:24 复制 查看全部楼层
谢谢两位老师,明天看看效果

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-10 18:42 复制 查看全部楼层
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
买AA:=黄金 AND RSVV<VARB2-2;
特准:(买AA>0)*3;
查看全部打赏
  • 邵冠豪+5理想币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(3) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-10 17:41 复制 查看全部楼层

AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),21,1)/SMA(ABS(CLOSE-AA),21,1)*1000;
HHH:=BBB-LLV(BBB,27);
CCC:=LLV(BBB,27)-BBB;
QQ:=(MA(HHH,2)*3+HHH*13)/16,COLORFF00FF,LINETHICK1;
SS:=(MA(CCC,2)*3+CCC*13)/16,COLORFF00FF,LINETHICK1;
GG:=MA(HHH,5),LINETHICK1,COLORGREEN;
MM:=MA(CCC,5),LINETHICK1,COLORGREEN;
WW:=IF(QQ<GG,SS,MM),LINETHICK1,COLOR0000FF;
EE:=IF(SS<MM,GG,QQ),COLORFFFFCC,LINETHICK1;
★买:=IF(EE-WW<5.6,200,0);
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
买AA:=黄金 AND RSVV<VARB2-2;
特准:(买AA>0)*3,LINETHICK2;
查看全部打赏
  • 邵冠豪+5理想币 : 理想精神:分享,互助,友善,传递正能量!

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表