手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙把副图改成选股预警

[通达信]
设置
1499 3 狼要吃肉 Lv.3 发表于 · 2020-11-10 20:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师把幅图中出现 箭步如飞 信号改成选股预警
DIF:=EMA(CLOSE,12) - EMA(CLOSE,27);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
CCI线:=CCI(84);
分割线:=100.00;
妖股启动:=CROSS(CCI线,分割线) AND MACD>0 AND MACD>=REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND C>=REF(C,1)*1.05;
妖股启动选股:STICKLINE(妖股启动,1,4,2,0),COLORYELLOW;
DRAWTEXT(妖股启动,3.5,'妖股启动'),COLORMAGENTA;


月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH";
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK";
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
日金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);
金叉共振:=IF(CROSS(周DIF,周DEA),MACD,0) AND C>REF(C,1)*1.078;
共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉)
OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACD+0.2,0) AND C>REF(C,1)*1.078;  
起爆抓妖选股:STICKLINE(共振,1,3,2,0),COLORRED;
妖股初现选股:STICKLINE(金叉共振,0,2,3,0),COLORCC3299;
起爆选股:DRAWTEXT(共振,2.5,'起爆'),COLORYELLOW ;
青云直上选股:DRAWTEXT(金叉共振,1.8,'青云直上'),COLORLIRED;
{时间}
N1:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y1:=STRCAT(CON2STR(MONTH,0),' 月 ');
R:=STRCAT(CON2STR(DAY,0),' 日 ');
SJ:=STRCAT(STRCAT(N1,Y1), R);
DRAWTEXT_FIX(C>0,0.88,0,0,SJ),COLORYELLOW;

{七号}
EE:=MACD-REF(MACD,1)>0.05 AND COUNT(C/REF(C,1)>1.09,16)<2 AND C=HHV(H,60) AND
C/REF(C,1)>1.07 AND NOT(H=L) AND COUNT(C>O,6)<=4 AND C/REF(C,9)<1.2;
STICKLINE(EE AND C/REF(C,1)>1.05,0,1.5,4,0),COLORDB7093;
打板启动选股:DRAWTEXT(EE AND C/REF(C,1)>1.05,1.2,'打板启动'),COLORRED;
VOLUME:=VOL;
MA1:=MA(VOLUME,5);
启动:= (MA1+MA1)>VOLUME;
买入:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND CLOSE>=HHV(HIGH,10)
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85) AND C>O;
选股:=(C>REF(HHV(H,3),1) AND (C-REF(C,1))/REF(C,1)>0.07) AND 启动 AND 买入;
抓妖股启动选股:STICKLINE(选股 AND C/REF(C,1)>1.05,0,1,5,0),COLORYELLOW;
箭步如飞选股:DRAWTEXT(选股,0.5,'箭步如飞'),COLORMAGENTA;

抓妖股:=金叉共振 AND 共振 AND 选股 ;
抓妖股选股:DRAWICON(抓妖股,3.3,26)COLORYELLOW;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-11 09:01 复制 查看全部楼层
雨竹168 发表于 2020-11-11 08:18
老师请再写一个"起爆”和“青云直上”同时出现时选股,谢谢

月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH";
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK";
日DIF:="MACD.DIF";
日DEA:="MACD.DEA";
日金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);
金叉共振:=IF(CROSS(周DIF,周DEA),MACD,0) AND C>REF(C,1)*1.078;
共振:=IF((日DIF>日DEA AND 周DIF>周DEA AND 月金叉) OR ( 周DIF>周DEA AND 月DIF>月DEA AND 日金叉)
OR (月DIF>月DEA AND 日DIF>日DEA AND 周金叉) OR (日金叉 AND 周金叉 AND 月金叉),MACD+0.2,0) AND C>REF(C,1)*1.078;  

起爆选股:=共振;
青云直上选股:=金叉共振;

XG:起爆选股 AND 青云直上选股;

举报

点亮(1) 扔鸡蛋(0) 回复

雨竹168
Lv.3
发表于 2020-11-11 08:18 复制 查看全部楼层
许昌舍得 发表于 2020-11-10 20:15
VOLUME:=VOL;
MA1:=MA(VOLUME,5);
启动:= (MA1+MA1)>VOLUME;


老师请再写一个"起爆”和“青云直上”同时出现时选股,谢谢

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-10 20:15 复制 查看全部楼层
VOLUME:=VOL;
MA1:=MA(VOLUME,5);
启动:= (MA1+MA1)>VOLUME;
买入:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND CLOSE>=HHV(HIGH,10)
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85) AND C>O;
选股:=(C>REF(HHV(H,3),1) AND (C-REF(C,1))/REF(C,1)>0.07) AND 启动 AND 买入;

箭步如飞选股:选股;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表