手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助根据主图公式改成选股公式

[通达信]
设置
1500 1 龚文祥 Lv.3 发表于 · 2020-11-10 20:33 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
N1:=MA(C,5);
N2:=MA(C,10);
N3:=MA(C,20);
N4:=MA(C,30);
N5:=MA(C,45);
N6:=MA(C,75);
N7:=MA(C,90);
N8:=MA(C,120);
N9:=MA(C,150);
N10:=MA(C,180);

SNM:=N1/C+N2/C+N3/C+N4/C+N5/C+N6/C+N7/C+N8/C+N9/C+N10/C;
AGV:=SNM/(TOTALBARSCOUNT-CURRBARSCOUNT);
X:=(N1-AGV)*(N1-AGV)+(N2-AGV)*(N2-AGV)+(N3-AGV)*(N3-AGV)+(N4-AGV)*(N4-AGV)+(N5-AGV)*(N5-AGV)+(N6-AGV)*(N6-AGV)+(N7-AGV)*(N7-AGV)+(N8-AGV)*(N8-AGV)+(N9-AGV)*(N9-AGV)+(N10-AGV)*(N10-AGV);
牛熊:SQRT(X/9),COLORFFCC33;

原码如上:

麻烦老师帮忙改成选股公式,把牛熊线走平或者向上的选出来。

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-10 20:45 复制 查看全部楼层


N1:=MA(C,5);
N2:=MA(C,10);
N3:=MA(C,20);
N4:=MA(C,30);
N5:=MA(C,45);
N6:=MA(C,75);
N7:=MA(C,90);
N8:=MA(C,120);
N9:=MA(C,150);
N10:=MA(C,180);

SNM:=N1/C+N2/C+N3/C+N4/C+N5/C+N6/C+N7/C+N8/C+N9/C+N10/C;
AGV:=SNM/(TOTALBARSCOUNT-CURRBARSCOUNT);
X:=(N1-AGV)*(N1-AGV)+(N2-AGV)*(N2-AGV)+(N3-AGV)*(N3-AGV)+(N4-AGV)*(N4-AGV)+(N5-AGV)*(N5-AGV)+(N6-AGV)*(N6-AGV)+(N7-AGV)*(N7-AGV)+(N8-AGV)*(N8-AGV)+(N9-AGV)*(N9-AGV)+(N10-AGV)*(N10-AGV);
牛熊:=SQRT(X/9),COLORFFCC33;

条件:牛熊>=REF(牛熊,1);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表