手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把以下V形反转指标修改为条件公式

[通达信]
设置
1050 1 朱坏123 Lv.4 发表于 · 2020-11-11 08:09 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师把以下V形反转指标修改为条件公式:

HT:=HHVBARS(H,15);
LT:=LLVBARS(L,15);
DF1:=(REF(C,LT)-REF(C,HT+1))/REF(C,HT+1)*100;
DF2:=(C-REF(C,LT+1))/REF(C,LT+1)*100;
TJ:=C>=REF(C,HT);
XG:=HT>LT AND DF1<-5 AND COUNT(TJ,HT+1)=1 AND TJ;
XGT:=BARSLAST(XG);
HQF:=BACKSET(XG,HT+1);
LQF:=BACKSET(XG,LT+1);
HQFT:=BARSLAST(CROSS(HQF=1,0.5));
LQFT:=BARSLAST(CROSS(LQF=1,0.5));
DRAWLINE(HQFT=0,H,LQFT=0,L,0),COLORRED,LINETHICK2;
DRAWLINE(LQFT=0,L,XG,L,0),COLORRED,LINETHICK2;
DRAWTEXT(LQFT=0,L*0.95,VARCAT(VARCAT('跌幅:',VAR2STR(REFX(DF1,BARSNEXT(XGT=0)),2)),'﹪'))COLORYELLOW;
DRAWTEXT(XGT=0,H*1.02,VARCAT(VARCAT('涨幅:',VAR2STR(REF(DF2,XGT),2)),'﹪'))COLORYELLOW;
STICKLINE(XG,C,O,2,0),COLORMAGENTA;
STICKLINE(XG,H,L,0,0),COLORMAGENTA;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.CXH99.COM '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

谢谢!

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-11 12:11 复制 查看全部楼层
有未来。
HT:=HHVBARS(H,15);
LT:=LLVBARS(L,15);
DF1:=(REF(C,LT)-REF(C,HT+1))/REF(C,HT+1)*100;
DF2:=(C-REF(C,LT+1))/REF(C,LT+1)*100;
TJ:=C>=REF(C,HT);
XG:=HT>LT AND DF1<-5 AND COUNT(TJ,HT+1)=1 AND TJ;
XGT:=BARSLAST(XG);
HQF:=BACKSET(XG,HT+1);
LQF:=BACKSET(XG,LT+1);
HQFT:=BARSLAST(CROSS(HQF=1,0.5));
LQFT:=BARSLAST(CROSS(LQF=1,0.5));
X1:=DRAWLINE(HQFT=0,H,LQFT=0,L,0);
X2:=DRAWLINE(LQFT=0,L,XG,L,0);
CROSS(X2>REF(X2,1),0.5)||REF(X2=X1&&NOT(X1=DRAWNULL),1);

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表