手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股公式

[通达信]
设置
1050 2 安迪116 Lv.2 发表于 · 2020-11-11 15:55 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师编写个近三天出现“关注”的选股公式



VAR2:=REF(LOW,1);

VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;

VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);

VAR5:=LLV(LOW,34);

VAR6:=HHV(VAR4,34);

VAR7:=IF(LLV(LOW,56),1,0);

VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;

AA:=VAR8>REF(VAR8,1);

DR:=100;

ZRQ:=3;

DJ:=REF(LLV(L,100),3);

ZD:=REFDATE(DJ,DATE);

XG:=L=ZD;

XGA:AA AND XG,COLORRED,LINETHICK2;

XG1:=XGA>REF(XGA,1);

牛股起爆点:=XG1>REF(XG1,1)COLORRED,LINETHICK2;

STICKLINE(FILTER(牛股起爆点>=1,5),45,0,4,0),COLORRED;

DRAWTEXT(FILTER(牛股起爆点=1,5),36,'---牛股起爆点A'),COLORRED;

STICKLINE(牛股起爆点,40,25,1,0),COLORYELLOW;

STICKLINE(牛股起爆点,25,10,2,0),COLOR00FF00;

STICKLINE(牛股起爆点,10,0,2,0),COLORBLUE;

STICKLINE(牛股起爆点,25,15,0.5,0),COLORRED;

STICKLINE(牛股起爆点,15,6,1,0),COLOR00FF00;

STICKLINE(牛股起爆点,6,0,2,0),COLORBLUE;

VARA3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

趋势:=EMA(VARA3,3)-10; VARB7:=LLV(LOW,30);

VARA11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*20;

VARA12:=HHV(VARA11,30)*20;

火焰山:=EMA(IF(LOW<=VARB7 AND 趋势<40,(VARA11+VARA12),0),3)/618,COLORRED,LINETHICK2;

火焰:=STICKLINE(火焰山>0,0,火焰山,3,1);

今量:=火焰山; STICKLINE(火焰山>0,0,今量*1.2,2,0),COLORLIRED;

VAR13:=EMA(EMA(CLOSE,13),13);

控盘:= (VAR13-REF(VAR13,1))/REF(VAR13,1)*1000;

STICKLINE(控盘<0,控盘,0,2,0),COLORWHITE;

无庄控盘:控盘<0,COLORWHITE;

STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,2,1),COLORRED;

有庄控盘: 控盘>REF(控盘,1) AND 控盘>0,COLORRED;

VAR23:=100*WINNER(CLOSE*0.95);

STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,2,0),COLOR00FF00;

主力出货: 控盘<REF(控盘,1) AND 控盘>0,COLOR00FF00;

STICKLINE(VAR23>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,2,0),COLORFF00FF;

高度控盘: VAR23>50 AND COST(85)<CLOSE AND 控盘>0,COLORFF00FF;

A10:=CROSS(控盘,0);

开始控盘:IF(A10,6,0),COLORYELLOW;

VARF:=TROUGHBARS(3,15,1)<4;

多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;

0,COLORRED;

STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,3,0),COLORRED;

STICKLINE(FILTER(VARF=1,5),50,0,1,0),COLORRED;

DRAWICON(FILTER(VARF=1,3),50,1);

DRAWTEXT(FILTER(VARF=1,3),25,'关注'),COLORYELLOW;

附件

关注.png

举报

扔鸡蛋(0) 回复

安迪116
Lv.2
发表于 2020-11-12 14:59 复制 查看全部楼层
谢谢,老师提醒

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-11 16:05 复制 查看全部楼层
未来信号  谨慎使用


VARF:=TROUGHBARS(3,15,1)<4;

XG:FILTER(VARF=1,3);

举报

点亮(2) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表