手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个预警公式

[通达信]
设置
1009 3 王一八上 Lv.2 发表于 · 2020-11-11 17:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师写个同时::K1,k2,k3上强(80),空下弱的预警公式,谢谢

DRAWGBK(CURRBARSCOUNT=1 , RGB(0,0,0),RGB(0,0,0),0,'1',0);

BIAS6 :(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*200,NODRAW  ;
STICKLINE((BIAS6>=REF(BIAS6,1) AND BIAS6>10),0,ABS(BIAS6),3.0,0),COLORYELLOW ;

A62:=((CLOSE - (LLV(LOW,36))) / ((HHV(HIGH,36)) - (LLV(LOW,36)))) * 100;
A63:=SMA(A62,3,1);
A64:=SMA(A63,3,1);
A65:=SMA(A64,3,1);
A66:=(CROSS(A64,A65)) AND (A64 < 12);
STICKLINE(((FILTER(A66,10)) = 1),0,80,2,1),COLORMAGENTA ;

AIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
AEA:=EMA(AIFF,9),COLORWHITE;
AACD:=(AIFF-AEA)*2;
A:STICKLINE(AACD>=0 AND AACD>=REF(AACD,1) AND REF(AACD,1)<0
AND AACD>=0.01,90,AACD,1,1) ,COLORYELLOW;
DRAWTEXT(A,85,' 一飞冲天'),COLORYELLOW ;

{RV1:=(C-MA(C,4))/MA(C,4)*100;
CDMA:EMA(EMA(RV1,7),7)*4,NODRAW,COLORWHITE;
STICKLINE(CDMA>=0 AND CDMA>=REF(CDMA,1),50,50+CDMA,1.0,0),COLORRED  ;}

启动线:=10*SUM(EMA((C+L)/2,2),5)/10.158,NODRAW;
平衡线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,4),NODRAW;
平台线:=10*LLV(SUM( EMA((C+L)/2,2),5)/10.158,10),NODRAW;
强弱线:=EMA(启动线,21);
VVAR1:=2*MA(LLV((C+L)/2,8)*1.1,13)-EMA((C+L)/2,3)-((C+L)/2)*0.1;
VVAR2:=IF((EMA((C+L)/2,3)-VVAR1)*5>0,POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10,-1*POW((EMA((C+L)/2,3)-VVAR1)*5,2)/10);
VVAR3:=IF(VVAR2>0,VVAR2-0,0);
STICKLINE(VVAR3>0 AND REF(VVAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),0,25,0,0),COLORMAGENTA;
DRAWTEXT(VVAR3>0 AND REF(VVAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),30,'动'),COLORMAGENTA;

顶:90,COLORYELLOW,LINETHICK1;
强:80,COLORRED,LINETHICK2;
红柱过线成妖:25,COLORYELLOW ,LINETHICK1;
弱:10,COLORGREEN,LINETHICK3;

DRAWTEXT(ISLASTBAR,  顶,'  顶'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,  强,'  强'),COLORRED;
DRAWTEXT(ISLASTBAR,  红柱过线成妖,'红柱过线成妖   '),COLORYELLOW ;
DRAWTEXT(ISLASTBAR,  弱,'  弱'),COLORGREEN;

VAR13:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:SMA(VAR13,3,1),COLORCYAN,LINETHICK1;
VAR21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K2:SMA(VAR21,3,1),COLORMAGENTA,LINETHICK1;
VAR34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K3:SMA(VAR34,3,1),COLORRED,LINETHICK1;
VAR55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K4:SMA(VAR55,3,1),COLOR00FF00,NODRAW;
买点:K1<20  AND K1>REF(K1,1)  AND K2<20
AND K3<20  ,COLORRED,NODRAW;
STICKLINE(买点 ,105,100,2,0),COLORGREEN ;
TOBU:= K3>80 AND K2>80 ;
STICKLINE(TOBU=1,105,100,1,0)  ,COLORRED;
DD:=-10;
DRAWTEXT(ISLASTBAR,K1,'  '),COLORCYAN  ;
DRAWTEXT(ISLASTBAR,K2,'   ←拉升线'),COLORYELLOW  ;
DRAWTEXT(ISLASTBAR,K3,'   ←主力线'),COLORRED ;
空方:100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55)),COLORGREEN,  ;
DRAWTEXT(ISLASTBAR,空方,'  ←空方'),COLORGREEN;

附件

e44391e10f1fda49c04808c1932678e.png

举报

扔鸡蛋(0) 回复

雨竹168
Lv.3
发表于 2020-11-12 08:57 复制 查看全部楼层
许昌舍得 发表于 2020-11-11 18:01
VAR13:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:=SMA(VAR13,3,1),COLORCYAN,LINETHICK ...

许老师请帮忙在写“动”和“一飞冲天”两个选股公式 ,谢谢许老师

举报

点亮(0) 扔鸡蛋(0) 回复

王一八上
Lv.2
发表于 2020-11-11 19:15 复制 查看全部楼层
谢谢许昌舍得 老师
请老师帮我合并一下指标,要谢谢
N:=5;M:=3;
VAR0:=((EMA(C,5)) * 7 + (EMA(C,10)) * 3) / 10;
VAR1:=IF((YEAR) >= (2025),0,1);
VAR2:=EMA(EMA(L,21) + (6.8) * (STD(L,2)),55);
VAR3:=EMA(((C / (VAR2)) * ((1.88) * C + L + O)) / (2.75),3);
VAR4:=(((VAR3) - (VAR2)) / (VAR2)) / 2;
VAR5:=(EMA((VAR3) - ((VAR4) * (VAR3)),5)) * (VAR1);
黄金轨道:=(IF((VAR0) > (VAR5),VAR0,VAR5)) * (VAR1);
上轨:=IF(((VAR5) < (VAR0)) AND ((VAR5) < (C * (0.15))),(EMA(C,300)) - (3 * (STD(C,300))),VAR5);
VAR10:=(((SMA(MAX(C - (REF(C,1)),0),24,1)) / (SMA(ABS(C - (REF(C,1))),24,1))) * (100)) * (VAR1);
VAR13:=((SMA(MAX(C - (REF(C,1)),0),14,1)) / (SMA(ABS(C - (REF(C,1))),14,1))) * (100);
VAR14:=(EMA(C,60) + EMA(C,120) + EMA(C,240) + EMA(C,480)) / 4;
VAR15:=VAR14 + (1.91) * (STD(VAR14,3));
VAR16:=(EMA(VAR15,12)) * (1.23);
XG: 黄金轨道!=上轨 &&
    ((VAR10>=64.5 AND VAR13>=65 AND MA(C,1)>VAR16) OR
     (VAR10>65 AND VAR13>=65 AND MA(C,1)>VAR16) OR
     (VAR10>=65 AND C=O AND MA(C,1)>VAR16) OR
     (VAR10>=64.5 AND VAR13>=65 AND VAR13>VAR10 AND C<上轨) OR
     (VAR10>=64.5 AND VAR13>=65 AND VAR13>VAR10 AND C<上轨));

VAR13:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:=SMA(VAR13,3,1),COLORCYAN,LINETHICK1;
VAR21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K2:=SMA(VAR21,3,1),COLORMAGENTA,LINETHICK1;
VAR34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K3:=SMA(VAR34,3,1),COLORRED,LINETHICK1;
VAR55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K4:=SMA(VAR55,3,1),COLOR00FF00;

空方:=100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));



TJ:K1>80 AND K2>80 AND K3>80
AND 空方<10;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-11 18:01 复制 查看全部楼层
VAR13:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:=SMA(VAR13,3,1),COLORCYAN,LINETHICK1;
VAR21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K2:=SMA(VAR21,3,1),COLORMAGENTA,LINETHICK1;
VAR34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K3:=SMA(VAR34,3,1),COLORRED,LINETHICK1;
VAR55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K4:=SMA(VAR55,3,1),COLOR00FF00;

空方:=100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));



TJ:K1>80 AND K2>80 AND K3>80
AND 空方<10;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表