手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个通达信指标

[通达信]
设置
1325 5 自然醒2008 Lv.4 发表于 · 2020-11-11 18:13 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MACD\KDJ\RSi 顶底背离指标,还可以选股。




A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) and cross("macd.diff"(12,26,9),"macd.dea"(12,26,9));
MACD底背离:=FILTER(B1>0,5);
STICKLINE(MACD底背离,0,0.75,3,0),COLORGREEN;
DRAWTEXT(MACD底背离,0.57,'MACD底背离'),COLORGREEN;
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
KDJ底背离:=FILTER(B2>0,5);
STICKLINE(KDJ底背离,0,1,3,0),COLORYELLOW;
DRAWTEXT(KDJ底背离,0.80,'KDJ底背离'),COLORYELLOW;
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背离:=FILTER(B3>0,5);
STICKLINE(RSI底背离,0,0.5,3,0),COLORFFCC66;
DRAWTEXT(RSI底背离,0.25,'RSI底背离'),COLORFFCC66;
2,COLORRED;
C1:=BARSLAST(ref(cross("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=ref(c,C1+1)<c and ref("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) and cross("macd.dea"(12,26,9),"macd.diff"(12,26,9));
MACD顶背离:=FILTER(D1>0,5);
STICKLINE(MACD顶背离,2,1.25,3,0),COLOR0066FF;
DRAWTEXT(MACD顶背离,1.47,'MACD顶背离'),COLOR0066FF;
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)<c and ref("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
KDJ顶背离:=FILTER(D2>0,5);
STICKLINE(KDJ顶背离,2,1,3,0),COLORRED;
DRAWTEXT(KDJ顶背离,1.2,'KDJ顶背离'),COLORRED;
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI顶背离:=FILTER(D3>0,5);
STICKLINE(RSI顶背离,2,1.5,3,0),COLORFF00FF;
DRAWTEXT(RSI顶背离,1.75,'RSI顶背离'),COLORFF00FF;

底背离:MACD底背离 or KDJ底背离 or RSI底背离;
顶背离:MACD顶背离 or KDJ顶背离 or RSI顶背离;

举报

扔鸡蛋(0) 回复

雨竹168
Lv.3
发表于 2020-11-12 08:58 复制 查看全部楼层
谢谢许老师 ,太快了

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-12 08:51 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-11-12 08:53 编辑
雨竹168 发表于 2020-11-12 08:30
许老师您好;
请帮忙写出每个底背离选股,谢谢


A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
MACD底背离:FILTER(B1>0,5);










A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
KDJ底背离:FILTER(B2>0,5);












A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背离:FILTER(B3>0,5);

举报

点亮(0) 扔鸡蛋(0) 回复

雨竹168
Lv.3
发表于 2020-11-12 08:30 复制 查看全部楼层
许昌舍得 发表于 2020-11-11 18:37
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MA ...

许老师您好;
请帮忙写出每个底背离选股,谢谢

举报

点亮(0) 扔鸡蛋(0) 回复

自然醒2008
Lv.4
发表于 2020-11-11 22:38 复制 查看全部楼层
许昌舍得老师谢谢您

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-11 18:37 复制 查看全部楼层
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
MACD底背离:=FILTER(B1>0,5);
STICKLINE(MACD底背离,0,0.75,3,0),COLORGREEN;
DRAWTEXT(MACD底背离,0.57,'MACD底背离'),COLORGREEN;
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
KDJ底背离:=FILTER(B2>0,5);
STICKLINE(KDJ底背离,0,1,3,0),COLORYELLOW;
DRAWTEXT(KDJ底背离,0.80,'KDJ底背离'),COLORYELLOW;
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背离:=FILTER(B3>0,5);
STICKLINE(RSI底背离,0,0.5,3,0),COLORFFCC66;
DRAWTEXT(RSI底背离,0.25,'RSI底背离'),COLORFFCC66;
2,COLORRED;
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
MACD顶背离:=FILTER(D1>0,5);
STICKLINE(MACD顶背离,2,1.25,3,0),COLOR0066FF;
DRAWTEXT(MACD顶背离,1.47,'MACD顶背离'),COLOR0066FF;
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
KDJ顶背离:=FILTER(D2>0,5);
STICKLINE(KDJ顶背离,2,1,3,0),COLORRED;
DRAWTEXT(KDJ顶背离,1.2,'KDJ顶背离'),COLORRED;
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI顶背离:=FILTER(D3>0,5);
STICKLINE(RSI顶背离,2,1.5,3,0),COLORFF00FF;
DRAWTEXT(RSI顶背离,1.75,'RSI顶背离'),COLORFF00FF;

底背离:MACD底背离 OR KDJ底背离 OR RSI底背离;
顶背离:MACD顶背离 OR KDJ顶背离 OR RSI顶背离;

附件

tdxjietu11.JPG
查看全部打赏
  • 自然醒2008+20理想币 : 理想精神:分享,互助,友善,传递正能量!

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表