手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改写指标使特定时间段资金流入为正

[大智慧]
设置
1442 3 雪山飞歌 Lv.3 发表于 · 2020-11-11 18:25 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
ZL10A:=REF(特净额+大净额,BARSLAST(TIME>93000 and TIME<=93100));


请教要使9:30-9:31分流入的资金为正(统计这1分钟内的资金流入,使之>0),应该怎么写?

举报

扔鸡蛋(0) 回复

雪山飞歌
Lv.3
发表于 2020-11-12 07:53 复制 查看全部楼层
谢谢指点。两种写法好像都没有解决问题,第一种没有选出股票,第二种资金流入有为负的。我要算出9:30-9:31分与9:15-9:30分流入资金的比例,而且要使这两个时间段流入的资金都为正。这么写不知错在哪,请再指点(股票池里是不是选分时)。
{分时资金}
TODAY:="ddx.ddx"<>0;{判断是否有正版数据}
TODAY1:="xyk.ddx"<>0;{判断是否有新游客数据}
TDLR:=SUM((AMOUNT*"wd.特单买#day"/10000),0);
TDLC:=SUM((AMOUNT*"wd.特单卖#day"/10000),0);
特净额:=TDLR-TDLC;
DDLR:=SUM((AMOUNT*"wd.大单买#day"/10000),0);
DDLC:=SUM((AMOUNT*"wd.大单卖#day"/10000),0);
大净额:=DDLR-DDLC;
ZL10A:=REF(特净额+大净额,BARSLAST(TIME>91500 and TIME<=93000));
ZL10B:=REF(特净额+大净额,BARSLAST(TIME>93000 and TIME<=93100));
ZL10A>0;
ZL10B>0;
XG:ZL10B/ZL10A>=4;

举报

点亮(1) 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-11 18:42 复制 查看全部楼层
试试
ZL10A:=REF(特净额+大净额,BARSLAST( TIME<=093100));
ZL10A>0;

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-11 18:40 复制 查看全部楼层
ZL10A:=REF(特净额+大净额,BARSLAST(TIME>93000 AND TIME<=93100));

TJ:ZL10A>0;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表