手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股公式

[通达信]
设置
765 1 雨竹168 Lv.3 发表于 · 2020-11-12 09:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
老师写一个红箭头选股,谢谢
源码:
{获利副图}
DF:=3;
N1:=12;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
K:=SMA(RSV,DF,1);
D:=SMA(K,DF,1);
KK:=SMA(RSV,DF,1);
DD:=SMA(K,DF,1);
N:=KK+DD;
关注区:STICKLINE(N<50,N,50,2,0),COLORRED;
风险区:STICKLINE(N>160,N,160,2,0),COLORFFFF00;
成本区:50,COLORYELLOW,LINETHICK2;
GWGD:=N<REF(N,1) AND REF(N,1)>=160 AND REF(N,1)>=REF(N,2);
获利区:160,COLORFFFF00,LINETHICK2;
操盘线:N,COLORFF00FF,LINETHICK2;
买入↑:DRAWICON(CROSS(N,50),50,1),COLORRED;
卖出↓:DRAWICON(CROSS(160,N),160,2),COLORGREEN;
AA:=(C+O+L+H)/4;
BB:=REF(CLOSE,AA);
获利盘:=SMA(MAX(CLOSE-BB,0),2,1)/SMA(ABS(CLOSE-BB),2,1)*100;
DZ1:=获利盘>REF(获利盘,1) AND 获利盘>89;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
CCI1:=EMA(EMA(EMA(CCI,2),2),2);
CCI2:=EMA(EMA(EMA(CCI,3),2),2);
DZ2:=CCI1>100;
T:=CLOSE*1.0+LOW*0.0+HIGH*0.0;
SL:=(T/REF(T,1)-1)*1000;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-12 09:33 复制 查看全部楼层
DF:=3;
N1:=12;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
K:=SMA(RSV,DF,1);
KK:=SMA(RSV,DF,1);
DD:=SMA(K,DF,1);
N:=KK+DD;
买入↑:CROSS(N,50);

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表