手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个预警公式

[通达信]
设置
1016 2 美丽小阳光 Lv.3 发表于 · 2020-11-12 10:04 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
预警要求:当出显黄色柱主力介入时预警,谢谢


主力筹码:=IF(C<0,0,EMA(WINNER(CLOSE)*70,3));

散户筹码:=IF(C<0,0,EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3));

散户持仓:IF(C<0,0,散户筹码/(主力筹码+散户筹码)*100),COLORGREEN,NODRAW;

主力持仓:IF(C<0,0,主力筹码/(主力筹码+散户筹码)*100),COLORRED,NODRAW;

散户资金:=IF(C<0,0,EMA(散户持仓,89));

主力资金:=IF(C<0,0,EMA(主力持仓,89));

资金流入强度:IF(C<0,0,INTPART(主力持仓-主力资金)),NODRAW,COLOR0000FF;SH8:=IF(C<0,0,EMA(散户持仓,8));

STICKLINE(CLOSE>0,散户持仓,主力持仓,1,0),COLORGRAY;

STICKLINE(散户资金>REF(散户资金,1),散户持仓,散户资金,1,0),COLORWHITE;

STICKLINE(CLOSE>0,主力持仓,0,1,0),COLORBROWN;

STICKLINE(主力持仓>75,主力持仓,0,1,0),COLORRED;

STICKLINE(主力资金>REF(主力资金,1),主力持仓,主力资金,1,0),COLORLIMAGENTA;

STICKLINE(散户持仓>=90,主力持仓,0,1,0),COLORGREEN;

STICKLINE(REF(散户持仓,1)>90 AND 散户持仓<90,0,散户持仓,1,0),COLORYELLOW;

主力介入:REF(散户持仓,1)>90 AND 散户持仓<90,NODRAW;筹码总量:IF(C<0,0,MA(主力筹码+散户筹码,13)),NODRAW;

筹码绿:IF(CLOSE>0,筹码总量,DRAWNULL),COLORGREEN,LINETHICK2;

筹码红:IF(筹码总量>REF(筹码总量,1),筹码总量,DRAWNULL),COLORRED,LINETHICK2;

资金流入:IF(主力资金>REF(主力资金,1),主力持仓,DRAWNULL),COLORMAGENTA,NODRAW;

DRAWTEXT(筹码总量>REF(筹码总量,1) AND SH8<REF(SH8,1) AND ISLASTBAR,筹码总量,'←增量资金');

选股:COUNT(主力介入=1,3) AND 筹码红 AND 资金流入,NODRAW,COLORYELLOW;

举报

扔鸡蛋(0) 回复

美丽小阳光
Lv.3
发表于 2020-11-13 09:06 复制 查看全部楼层

多谢帮助。。。。。。。。。。

举报

扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2020-11-12 11:56 复制 查看全部楼层
主力筹码:=IF(C<0,0,EMA(WINNER(CLOSE)*70,3));

散户筹码:=IF(C<0,0,EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3));

散户持仓:=IF(C<0,0,散户筹码/(主力筹码+散户筹码)*100);

REF(散户持仓,1)>90 AND 散户持仓<90;

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表