手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并一个选股公式

[通达信]
设置
788 1 狼要吃肉 Lv.3 发表于 · 2020-11-12 14:53 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_11:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
X_A:=CROSS(X_7,X_11);
X_B:=CROSS(X_11,X_7);
X_12:=REF(X_8,1);
X_13:=REF(X_8,2);
X_14:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,2))/MA(CLOSE,32)*100)/3;
X_15:=X_8<-100 OR X_12<-100;
X_16:=X_8>100 OR X_12>100;
X_17:=20*MAX(X_8,X_16)*DMA(EMA(CLOSE,6),SUM(VOL,60)/VOL)/EXP(2*HIGH-LOW/3);
X_C:=CROSS(X_14,X_17);
X_D:=CROSS(X_17,X_14);
关键点:=X_A AND X_B AND X_C AND X_D;
X_E:=关键点;
X_18:=X_8>X_12 AND X_12<X_13 OR X_E;
慢进:X_15 AND X_18;



RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A:=((REF(C,3)-REF(C,1))/C)*100>6;
A1:= CLOSE>REF(CLOSE,1)*1.03 ;
A2:=CROSS(J,MA(J,2)) AND C>O;
A3:= REF(((H-O)/C)*100<2,1);
A4:=REF(C<O,2) AND REF(C<O,1);
A5:=((H-C)/C)*100<2 AND H>REF(H,1);
A6:=((REF(O,1)-REF(C,1))/C)*100>1;
A7:=((REF(O,2)-REF(C,2))/C)*100<9;
BB:A AND A1 AND A2 AND A3 AND A4 AND A5 AND A7;

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-12 15:04 复制 查看全部楼层

X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_11:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
X_A:=CROSS(X_7,X_11);
X_B:=CROSS(X_11,X_7);
X_12:=REF(X_8,1);
X_13:=REF(X_8,2);
X_14:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,2))/MA(CLOSE,32)*100)/3;
X_15:=X_8<-100 OR X_12<-100;
X_16:=X_8>100 OR X_12>100;
X_17:=20*MAX(X_8,X_16)*DMA(EMA(CLOSE,6),SUM(VOL,60)/VOL)/EXP(2*HIGH-LOW/3);
X_C:=CROSS(X_14,X_17);
X_D:=CROSS(X_17,X_14);
关键点:=X_A AND X_B AND X_C AND X_D;
X_E:=关键点;
X_18:=X_8>X_12 AND X_12<X_13 OR X_E;
慢进:=X_15 AND X_18;



RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
A:=((REF(C,3)-REF(C,1))/C)*100>6;
A1:= CLOSE>REF(CLOSE,1)*1.03 ;
A2:=CROSS(J,MA(J,2)) AND C>O;
A3:= REF(((H-O)/C)*100<2,1);
A4:=REF(C<O,2) AND REF(C<O,1);
A5:=((H-C)/C)*100<2 AND H>REF(H,1);
A6:=((REF(O,1)-REF(C,1))/C)*100>1;
A7:=((REF(O,2)-REF(C,2))/C)*100<9;
BB:A AND A1 AND A2 AND A3 AND A4 AND A5 AND A7 AND 慢进;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表