手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把第一次红色或粉色内出现黄柱做个选股公式或预警公式

[通达信]
设置
1821 8 鑫股民 Lv.2 发表于 · 2020-11-12 18:43 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DRAWGBK(CLOSE>0,RGB(0,0,0),RGB(0,50,50),0,1,0);

X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;

X_3:=EMA(X_2,12)-EMA(X_2,26);

X_4:=EMA(X_3,9);

X_5:=(X_3-X_4)*2;

主力资金:X_5,NODRAW,COLORYELLOW;

流入:CROSS(X_5,0),NODRAW,COLORRED;

DRAWICON(CROSS(X_5,0),REF(X_5,1),38);

流出:CROSS(0,X_5),NODRAW,COLORGREEN;

DRAWICON(CROSS(0,X_5),REF(X_5,1),39);

X_6:=1;

X_7:=CLOSE*VOL;

X_8:=EMA((EMA(X_7,3)/EMA(VOL,3)+EMA(X_7,6)/EMA(VOL,6)+EMA(X_7,12)/EMA(VOL,12)+EMA(X_7,24)/EMA(VOL,24))/4,13);

X_9:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;

X_10:=X_9;

X_11:=X_7;

X_12:=X_8;

X_13:=1.06*X_12;

X_14:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6;

X_15:=EMA(HIGH,10)*(1+6/100);

X_16:=X_6 AND X_14>0 AND CROSS(CLOSE,X_15) AND CROSS(CLOSE,X_13);

X_17:=FILTER(CROSS(X_10,EMA(HIGH,55)*(1+10/100)),5);

黑马启动:IF(X_6 AND X_16,1,0),NODRAW,COLORRED;

非妖即顶:IF(X_6 AND X_17,1,0),NODRAW,COLORMAGENTA;

STICKLINE(X_5>0 AND X_5>=REF(X_5,1),X_5,0,3,1),COLORRED;

STICKLINE(X_5>0 AND X_5<REF(X_5,1),X_5,0,3,1),COLORGREEN;

STICKLINE(X_5<0,X_5,0,3,1),COLORCYAN;

STICKLINE(黑马启动>0,X_5,0,4,0),COLORRED;

STICKLINE(非妖即顶>0,X_5,0,4,0),COLORMAGENTA;

X_18:=X_6;

X_19:=IF(X_6<=0,0,HHVBARS(X_5,BARSLAST(X_5<0)+1));

X_20:=IF(X_18>0,CROSS(BACKSET(CROSS(0,X_5),REF(X_19,1)+2),0.5),0);

X_21:=CROSS(BACKSET(CROSS(0,X_5) OR (ISLASTBAR AND X_5>0),REF(X_19,1)+2),0.5);

X_22:=DRAWLINE(X_20,X_5,REF(X_20,1),REF(X_5,1),1);

NOTEXT前高:X_22,COLORGRAY;

X_23:=LLVBARS(X_5,BARSLAST(X_5>0)+1);

X_24:=CROSS(BACKSET(CROSS(X_5,0),REF(X_23,1)+2),0.5);

X_25:=BARSLAST(FILTERX(CROSS(0,X_5),BARSCOUNT(CLOSE)));

X_26:=DRAWLINE(X_24,X_5,REF(X_24,1),REF(X_5,1),1);

NOTEXT前低:X_26,COLORGRAY;

X_27:=IF(X_5<0,FILTERX(X_5=LLV(X_5,BARSLAST(X_5>0)),BARSCOUNT(CLOSE)),DRAWNULL);

X_28:=BARSLAST(X_27);

X_29:=FILTERX(X_5<CONST(LLV(X_5,X_25+1)),BARSCOUNT(CLOSE));

X_30:=BARSLAST(X_29);

X_31:=IF(X_25+1>=1,CONST(LLV(X_5,X_25+1)),DRAWNULL);

NOTEXT本低:X_31,COLORWHITE;

X_32:=CROSS(COUNT(CROSS(X_5>X_31/2 AND X_5<0,0.5),X_28)=1,0.5) AND X_28>=0;

X_33:=IF(ISLASTBAR AND X_5>0 AND X_5=HHV(X_5,BARSLAST(X_5<0)),1,IF(FILTERX(X_21,BARSCOUNT(CLOSE)),2,DRAWNULL));

X_34:=X_33=1 OR X_33=2 AND X_5>0;

X_35:=FILTERX(X_34,BARSCOUNT(CLOSE));

X_36:=DRAWLINE(X_35,X_5,REF(X_35,1),REF(X_5,1),1);

NOTEXT本高:X_36,COLORWHITE;

X_37:=CONST(REF(X_5,BARSLAST(X_35)));

X_38:=X_5>X_37;

X_39:=FILTERX(REFX(BARSLAST(X_38),1)=1,BARSCOUNT(CLOSE));

NOTEXT天数:BARSLAST(X_39),NODRAW,COLORYELLOW;

NOTEXT上横线:DRAWLINE(X_39,X_37,X_35,X_37,0),DOTLINE,COLORGREEN;

NOTEXT下横线:DRAWLINE(X_29,CONST(LLV(X_5,X_25+1)),X_27=1,X_5,0),DOTLINE,COLORYELLOW;

X_40:=IF(X_39,BARSNEXT(X_35),DRAWNULL);

X_41:=IF(NOTEXT天数>0 AND NOTEXT天数<=REF(X_40,NOTEXT天数),SUM(X_5>0,NOTEXT天数),DRAWNULL);

X_42:=REF(CLOSE,NOTEXT天数);

X_43:=(X_42-CLOSE)/CLOSE*100;

X_44:=BARSLAST(X_35);


X_45:=CROSS(COUNT(CROSS(X_5<X_36/2 AND X_5>0,0.5),X_35)=1,0.5) AND X_35>=0;

STICKLINE(X_5>X_22 AND X_36>X_22 AND BARSLAST(CROSS(X_5<X_36/2,0.5))>0 AND X_5>(X_22+X_36)/2,X_5,X_22,1,0),COLORYELLOW;

X_46:=IF(X_5>0 AND X_36!=X_22,DRAWLINE(X_45,(X_22+X_36)/2,REF(X_45,1),REF((X_22+X_36)/2,1),1),DRAWNULL);

STICKLINE(X_5>X_22,X_5,X_22,1,0),COLORYELLOW;

STICKLINE(X_45,X_5,0,1,0),COLORGREEN;

STICKLINE(X_5<0 AND X_5<X_26 AND X_26<0,X_5,X_26,1,0),COLORBLUE;

X_47:=IF(CROSS(X_5<0,0.5),BARSNEXT(X_27),DRAWNULL);

X_48:=BARSLAST(X_5>0)-1;

举报

扔鸡蛋(0) 回复

鑫股民
Lv.2
发表于 2020-11-15 11:11 复制 查看全部楼层
非常感谢!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-15 10:48 复制 查看全部楼层
鑫股民 发表于 2020-11-15 09:49
老师,能把红框内首次出现黄柱也加进预警公式吗?谢谢!

X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;
X_3:=EMA(X_2,12)-EMA(X_2,26);
X_4:=EMA(X_3,9);
X_5:=(X_3-X_4)*2;
X_6:=1;
X_18:=X_6;
X_19:=IF(X_6<=0,0,HHVBARS(X_5,BARSLAST(X_5<0)+1));
X_20:=IF(X_18>0,CROSS(BACKSET(CROSS(0,X_5),REF(X_19,1)+2),0.5),0);
X_22:=DRAWLINE(X_20,X_5,REF(X_20,1),REF(X_5,1),1);
黄柱:=X_5>X_22;
X_9:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
X_10:=X_9;
X_17:=FILTER(CROSS(X_10,EMA(HIGH,55)*(1+10/100)),5);
非妖即顶:=IF(X_6 AND X_17,1,0);
X_7:=CLOSE*VOL;
X_8:=EMA((EMA(X_7,3)/EMA(VOL,3)+EMA(X_7,6)/EMA(VOL,6)+EMA(X_7,12)/EMA(VOL,12)+EMA(X_7,24)/EMA(VOL,24))/4,13);
X_12:=X_8;
X_13:=1.06*X_12;
X_14:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6;
X_15:=EMA(HIGH,10)*(1+6/100);
X_16:=X_6 AND X_14>0 AND CROSS(CLOSE,X_15) AND CROSS(CLOSE,X_13);
黑马启动:=IF(X_6 AND X_16,1,0);
红框:=X_5>0 AND X_5>=REF(X_5,1);

XG:(黄柱 AND 非妖即顶) OR (黄柱 AND 黑马启动) OR (黄柱 AND 红框);

举报

点亮(0) 扔鸡蛋(0) 回复

鑫股民
Lv.2
发表于 2020-11-15 09:49 复制 查看全部楼层
休闲者68 发表于 2020-11-12 19:20
{指标含有未来函数}BACKSET!,慎用!}
X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;

老师,能把红框内首次出现黄柱也加进预警公式吗?谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

鑫股民
Lv.2
发表于 2020-11-13 07:33 复制 查看全部楼层
600596新安股份启动点在11月5日,截至昨日已累计涨幅达20%,注意控制风险;002646青青稞酒启动点在周四,目前已两连板未来看板块是否持续走强,否则会调整。

举报

点亮(0) 扔鸡蛋(0) 回复

王一八上
Lv.2
发表于 2020-11-12 21:48 复制 查看全部楼层
600596新安股份.002646青青稞酒.这两只你看看

举报

点亮(0) 扔鸡蛋(0) 回复

鑫股民
Lv.2
发表于 2020-11-12 19:50 复制 查看全部楼层
有未来函数的指标不能单独使用,和其他指标配合用也许会有意想不到的结果,根据老师给修改的这个指标再结合其他几个指标,今天选出了下面几个,未来几天观察看咋样。300019硅宝科技,002527新时代,000929兰州黄河。

举报

点亮(1) 扔鸡蛋(0) 回复

鑫股民
Lv.2
发表于 2020-11-12 19:42 复制 查看全部楼层
谢谢!非常感谢!

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-12 19:20 复制 查看全部楼层
{指标含有未来函数}BACKSET!,慎用!}
X_1:=VOL;
X_2:=SMA((CLOSE-REF(CLOSE,1))*X_1,3,1)/10000;
X_3:=EMA(X_2,12)-EMA(X_2,26);
X_4:=EMA(X_3,9);
X_5:=(X_3-X_4)*2;
X_6:=1;
X_18:=X_6;
X_19:=IF(X_6<=0,0,HHVBARS(X_5,BARSLAST(X_5<0)+1));
X_20:=IF(X_18>0,CROSS(BACKSET(CROSS(0,X_5),REF(X_19,1)+2),0.5),0);
X_22:=DRAWLINE(X_20,X_5,REF(X_20,1),REF(X_5,1),1);
黄柱:=X_5>X_22;
X_9:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
X_10:=X_9;
X_17:=FILTER(CROSS(X_10,EMA(HIGH,55)*(1+10/100)),5);
非妖即顶:=IF(X_6 AND X_17,1,0);
X_7:=CLOSE*VOL;
X_8:=EMA((EMA(X_7,3)/EMA(VOL,3)+EMA(X_7,6)/EMA(VOL,6)+EMA(X_7,12)/EMA(VOL,12)+EMA(X_7,24)/EMA(VOL,24))/4,13);
X_12:=X_8;
X_13:=1.06*X_12;
X_14:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>6;
X_15:=EMA(HIGH,10)*(1+6/100);
X_16:=X_6 AND X_14>0 AND CROSS(CLOSE,X_15) AND CROSS(CLOSE,X_13);
黑马启动:=IF(X_6 AND X_16,1,0);
XG:(黄柱 AND 非妖即顶) OR (黄柱 AND 黑马启动);

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表