手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师指导一下:关于通达信分时图指标的问题

[通达信]
设置
1634 12 凤舞九天5 Lv.2 发表于 · 2020-11-12 23:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层


在分时图上,满足A条件时,一直出信号,直到满足B条件后,前面的A条件的所有信号消失,应该用哪个函数?未来函数也可以,
先感谢老师们的帮助!

举报

扔鸡蛋(0) 回复

凤舞九天5
Lv.2
发表于 2020-11-14 01:10 复制 查看全部楼层
北沙 发表于 2020-11-13 22:35
A:=TIME>931  AND COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)=DYNAINFO(3)*1.04,FROMOPEN)>1;
AB:=IF( ...

谢谢老师,你的指标虽然还没达要求,我看了下,只要把你的 :IF(条件=DRAWNULL AND A,A,B);  最后的B变为0,即可达成满足B条件时,前面A信号全部消失。就改这个了,所以这指标改后就已经完成了,再次感谢老师的帮助!

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-13 22:35 复制 查看全部楼层
凤舞九天5 发表于 2020-11-13 16:00
老师,您好,我看了下,似乎还是不行,
我是想要:

A:=TIME>931  AND COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)<2;
B:=COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)>1;
AB:=IF(CONST(BARSLAST(CROSS(B,0.5)))>0 AND A,0,B);
条件:=CONST(BARSLAST(CROSS(B,0.5)));
IF(条件=DRAWNULL AND A,A,B);

举报

点亮(0) 扔鸡蛋(0) 回复

凤舞九天5
Lv.2
发表于 2020-11-13 16:00 复制 查看全部楼层
北沙 发表于 2020-11-13 14:16
A:=TIME>931  AND COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)=DYNAINFO(3)*1.04,FROMOPEN)>1;
AB:IF(C ...

老师,您好,我看了下,似乎还是不行,

我是想要:
满足A条件时出信号,当满足B条件时,A条件后所有的信号都消失。不满足B条件时,一直是A信号。


你改的这个,是满足B条件出信号哦,不满足B条件时,你改的这个A信号也消失…………

麻烦老师了!!

举报

点亮(0) 扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-13 14:16 复制 查看全部楼层
凤舞九天5 发表于 2020-11-13 12:40
老师,你好,这是通达信分时图的指标,当出现B条件时,前面的信号也没消失哦!!!你复制去分时图看看/:y ...

A:=TIME>931  AND COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)<2;
B:=COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)>1;
AB:IF(CONST(BARSLAST(CROSS(B,0.5)))>0 AND A,0,B);
查看全部打赏
  • 凤舞九天5+10理想币 +2共享币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(1) 扔鸡蛋(0) 回复

凤舞九天5
Lv.2
发表于 2020-11-13 12:40 复制 查看全部楼层
北沙 发表于 2020-11-13 11:16
sum(b,barslast(a))=0;

老师,你好,这是通达信分时图的指标,当出现B条件时,前面的信号也没消失哦!!!你复制去分时图看看

DRAWTEXT_FIX(TIME>=0,0,0.0001,0,'_'),COLORFF00FF;



A:=TIME>931  AND COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)<2;
B:=COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)>1;
AB:=sum(B,barslast(A))=0;
DRAWTEXT(AB,C,'★未拉升'),COLORCYAN;

举报

点亮(1) 扔鸡蛋(0) 回复

凤舞九天5
Lv.2
发表于 2020-11-13 12:36 复制 查看全部楼层
江哥323323 发表于 2020-11-13 09:14
用BACKSET,但你这么做,不就是在掩盖即成事实吗?

老师,你好,这是通达信分时图的指标,当出现B条件时,用BACKSET也没办法把前面的信号消失呢!!!

DRAWTEXT_FIX(TIME>=0,0,0.0001,0,'_'),COLORFF00FF;



A:=TIME>931  AND COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)<2;
B:=COUNT(REF(C,1)>=DYNAINFO(3)*1.04,FROMOPEN)>1;
AB:=BACKSET(A,B);
DRAWTEXT(AB,C,'★未拉升'),COLORCYAN;

举报

点亮(1) 扔鸡蛋(0) 回复

凤舞九天5
Lv.2
发表于 2020-11-13 12:34 复制 查看全部楼层
北沙 发表于 2020-11-13 11:16
sum(b,barslast(a))=0;

放进去后,也不行呢!!!!!!

举报

扔鸡蛋(0) 回复

北沙
Lv.7
发表于 2020-11-13 11:16 复制 查看全部楼层
sum(b,barslast(a))=0;

举报

扔鸡蛋(0) 回复

江哥323323
Lv.5
发表于 2020-11-13 09:14 复制 查看全部楼层
凤舞九天5 发表于 2020-11-13 09:10
我想的是:当满足条件A后一直有信号,到满足条件B时,前面A的每一次信号全部消失,谢谢老师

用BACKSET,但你这么做,不就是在掩盖即成事实吗?

举报

点亮(1) 扔鸡蛋(0) 回复

凤舞九天5
Lv.2
发表于 2020-11-13 09:10 复制 查看全部楼层
许昌舍得 发表于 2020-11-13 08:37
试试



我想的是:当满足条件A后一直有信号,到满足条件B时,前面A的每一次信号全部消失,谢谢老师

举报

点亮(1) 扔鸡蛋(0) 回复

凤舞九天5
Lv.2
发表于 2020-11-13 09:08 复制 查看全部楼层
许昌舍得 发表于 2020-11-13 08:37
试试



这不行的,后面B出信号后,A的信号不消失

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-13 08:37 复制 查看全部楼层
试试



TJ:A AND NOT(B);

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表