手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并一个选股

[通达信]
设置
975 4 狼要吃肉 Lv.3 发表于 · 2020-11-13 08:21 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_11:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
X_A:=CROSS(X_7,X_11);
X_B:=CROSS(X_11,X_7);
X_12:=REF(X_8,1);
X_13:=REF(X_8,2);
X_14:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,2))/MA(CLOSE,32)*100)/3;
X_15:=X_8<-100 OR X_12<-100;
X_16:=X_8>100 OR X_12>100;
X_17:=20*MAX(X_8,X_16)*DMA(EMA(CLOSE,6),SUM(VOL,60)/VOL)/EXP(2*HIGH-LOW/3);
X_C:=CROSS(X_14,X_17);
X_D:=CROSS(X_17,X_14);
关键点:=X_A AND X_B AND X_C AND X_D;
X_E:=关键点;
X_18:=X_8>X_12 AND X_12<X_13 OR X_E;
慢进:=X_15 AND X_18;


A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),LINETHICK1,COLORMAGENTA;
操作线:=分水岭-(EMA(C,3)-分水岭),LINETHICK1,COLORYELLOW;
PM:=MA(C,5),COLORWHITE;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);

VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,30);
VAR4:=MA(CLOSE,60);
VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC:=INTPART(VARB*100)/100;
VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE:=EMA(VARD,9);
VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13:=REF(VARE,1);
VAR14:=VARE;
VAR15:=VAR14-VAR13;
VAR16:=REF(VARD,1);
VAR17:=VARD;
VAR18:=VAR17-VAR16;
VAR19:=OPEN;
VAR1A:=CLOSE;
白马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
黑马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
白马黑马共振:=白马剑 AND 黑马剑;
MA1:=EMA(CLOSE,5);
MA2:=EMA(CLOSE,10);
MA3:=EMA(CLOSE,20);
MA4:=EMA(CLOSE,30);
三线粘合剑:=CROSS(分水岭,操作线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;

HBXG:慢进 AND 三线粘合剑;



选股二
操盘线:=MA(CLOSE,18);
角度:=ATAN((操盘线/REF(操盘线,1)-1)*100)*180/3.1416;
多头线:=EMA(C,1.5);
空头线:=EMA(C,5);
均衡线:=EMA(空头线,5);
CROSS(多头线,均衡线) AND CROSS(空头线,均衡线) AND CROSS(多头线,操盘线) AND C>=REF(C,1)*1.015 AND 角度>=0 AND CROSS(C,MA(C,18)) AND MA(C,18)>MA(C,50);

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-14 07:43 复制 查看全部楼层
风含笑204 发表于 2020-11-13 21:45
MA3:MA(C,3);
MA5:MA(C,5);
MA10:MA(C,10);

MA3:MA(C,3);
MA5:MA(C,5);
MA10:MA(C,10);

A0:=((L+H+C*2)/4);
上:=EMA(A0,14)*1.1382,COLORYELLOW,LINETHICK2;
{上B:REFDATE(上,DATE),COLORYELLOW,DOTLINE;}
{DRAWNUMBER(ISLASTBAR,上,上),COLORWHITE;
中:=EMA(A0,14)*1.0618,COLORWHITE,LINETHICK2;
DRAWNUMBER(ISLASTBAR,中,中),COLORWHITE;
下:=EMA(A0,14),COLORRED,LINETHICK2;
DRAWNUMBER(ISLASTBAR,下,下),COLORWHITE;}
{A2:=EMA(A0,25)COLORLIBLUE,LINETHICK3;
A1X:=(下-REF(下,1))/REF(下,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:IF(A1X>=0,下,DRAWNULL),COLORRED,LINETHICK3;
卖:IF(A1X<0 AND A2X<0,下,DRAWNULL)COLORGREEN3;}
多空:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW,LINETHICK3;
做空:=REF(多空,1),COLORGREEN,NODRAW;
A2:=EMA(多空,25)COLORLIBLUE,LINETHICK3;
A1X:=(多空-REF(多空,1))/REF(多空,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:=IF(A1X>=0,多空,DRAWNULL),COLORMAGENTA,LINETHICK3;
卖:=IF(A1X<0 AND A2X<0,多空,DRAWNULL),COLORGREEN,LINETHICK3;
{STICKLINE(做多>做空,做多,做空,3,0),COLORRED;
STICKLINE(做多<=做空,做多,做空,3,1),COLORGREEN;}

{水平支撑压力}
HIGHN:=10;
HIGHN8:=20;
LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDDD,REF(H,DDDD),H);
DINGBUTS:=IF(DDDD,REF(GDTS,DDDD),GDTS);
DINGBU1:=REF(DINGBU,DDDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
CC8:=FILTER(QY,HIGHN8) AND H=HHV(H,HIGHN8+1);
DDDD8:=BARSLAST(CC8);
GDTS8:=IF(CC8,CURRBARSCOUNT,0);
DINGBUTS8:=IF(DDDD8,REF(GDTS8,DDDD8),GDTS8);
GDCS8:=CONST(DINGBUTS8);
DINGBUTS9:=REF(DINGBUTS8,DDDD8+1);
GDCS9:=CONST(DINGBUTS9);
高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK1;
压A:DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,LINETHICK2;
压B:DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORLIGREEN,LINETHICK2;
压A2:=DRAWLINE(CURRBARSCOUNT=GDCS9,H,ISLASTBAR,REF(H,GDCS9-1),1),COLOR0055FF,LINETHICK2;
压B2:=DRAWLINE(CURRBARSCOUNT=GDCS8,H,ISLASTBAR,REF(H,GDCS8-1),1),COLORLIGREEN,LINETHICK2;

AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:=DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;
支A:=DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA;
支B:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN;
{高低连线支撑压力}
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
A2B:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2B,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
压1:=DRAWLINE(D1,H,S11,H,1),COLORGREEN;
压2:=DRAWLINE(D12,H,S112,H,1),COLORLIBLUE;
支1:=DRAWLINE(D2,L,U11,L,1),COLORRED;
支2:=DRAWLINE(D22,L,U112,L,1),COLORLIRED;
{变动支撑压力}
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ);
支C:=IF(BARSLAST(TJ1),REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压C:=IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;

{涨停表示}
LA:=BARSLAST(C>REF(C,1)*1.098);
LC:=REF(CLOSE,LA);
LO:=REF(OPEN,LA);
LAL:=REF(L,LA);
LAH:=REF(H,LA);

一涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,1);
双涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,2);
三涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,3) AND H>L;
策略1A:=EXIST((C/REF(C,2)-1)*100>20,2) AND COUNT(LC>LO,3)>=1 AND O<REF(C,1)  AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
策略1B:=EXIST(双涨停,3) AND COUNT(LC>LO,4)>=1 AND O<REF(C,1)  AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
DRAWTEXT(策略1A,LOW,'↖①'),COLORYELLOW;
DRAWTEXT(策略1B,LOW,'↖①'),COLORYELLOW;
{策略2:=EXIST(三涨停,5)  AND C>中  AND L<中*1.01618 AND C/REF(C,1)<1.05 AND HHV(H,5)/C>1.14;
DRAWTEXT(策略2,LOW,'↖②'),COLORYELLOW;}
角度:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
持有:=EXIST(一涨停,5) AND 角度>75 AND C>上 AND C>REF(C,1) AND C>上 ;
突破:=角度>75 AND C>上 AND C>REF(C,1) AND C>上 {AND (H/C)<1.038};
DRAWTEXT(持有,LOW,'↖龙'),COLORYELLOW;
STICKLINE(突破,O,C,1,0),COLORMAGENTA;

{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
{STICKLINE(涨停,O,C,1,0),COLORYELLOW;}
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;

举报

点亮(0) 扔鸡蛋(0) 回复

风含笑204
Lv.2
发表于 2020-11-13 21:45 复制 查看全部楼层
休闲者68 发表于 2020-11-13 08:30
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSEX_12 AND X_120,0.8,0 ...

休闲老师   辛苦了

附件

111.png
222.png

举报

扔鸡蛋(0) 回复

风含笑204
Lv.2
发表于 2020-11-13 21:45 复制 查看全部楼层
休闲者68 发表于 2020-11-13 08:30
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSEX_12 AND X_120,0.8,0 ...

MA3:MA(C,3);
MA5:MA(C,5);
MA10:MA(C,10);

A0:=((L+H+C*2)/4);
上:=EMA(A0,14)*1.1382,COLORYELLOW,LINETHICK2;
{上B:REFDATE(上,DATE),COLORYELLOW,DOTLINE;}
DRAWNUMBER(ISLASTBAR,上,上),COLORWHITE;
中:=EMA(A0,14)*1.0618,COLORWHITE,LINETHICK2;
DRAWNUMBER(ISLASTBAR,中,中),COLORWHITE;
下:=EMA(A0,14),COLORRED,LINETHICK2;
DRAWNUMBER(ISLASTBAR,下,下),COLORWHITE;
{A2:=EMA(A0,25)COLORLIBLUE,LINETHICK3;
A1X:=(下-REF(下,1))/REF(下,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:IF(A1X>=0,下,DRAWNULL),COLORRED,LINETHICK3;
卖:IF(A1X<0 AND A2X<0,下,DRAWNULL)COLORGREEN3;}
多空:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW,LINETHICK3;
做空:=REF(多空,1),COLORGREEN,NODRAW;
A2:=EMA(多空,25)COLORLIBLUE,LINETHICK3;
A1X:=(多空-REF(多空,1))/REF(多空,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买:=IF(A1X>=0,多空,DRAWNULL),COLORMAGENTA,LINETHICK3;
卖:=IF(A1X<0 AND A2X<0,多空,DRAWNULL),COLORGREEN,LINETHICK3;
{STICKLINE(做多>做空,做多,做空,3,0),COLORRED;
STICKLINE(做多<=做空,做多,做空,3,1),COLORGREEN;}

{水平支撑压力}
HIGHN:=10;
HIGHN8:=20;
LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDDD,REF(H,DDDD),H);
DINGBUTS:=IF(DDDD,REF(GDTS,DDDD),GDTS);
DINGBU1:=REF(DINGBU,DDDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
CC8:=FILTER(QY,HIGHN8) AND H=HHV(H,HIGHN8+1);
DDDD8:=BARSLAST(CC8);
GDTS8:=IF(CC8,CURRBARSCOUNT,0);
DINGBUTS8:=IF(DDDD8,REF(GDTS8,DDDD8),GDTS8);
GDCS8:=CONST(DINGBUTS8);
DINGBUTS9:=REF(DINGBUTS8,DDDD8+1);
GDCS9:=CONST(DINGBUTS9);
高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK1;
压A:DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,LINETHICK2;
压B:DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORLIGREEN,LINETHICK2;
压A2:=DRAWLINE(CURRBARSCOUNT=GDCS9,H,ISLASTBAR,REF(H,GDCS9-1),1),COLOR0055FF,LINETHICK2;
压B2:=DRAWLINE(CURRBARSCOUNT=GDCS8,H,ISLASTBAR,REF(H,GDCS8-1),1),COLORLIGREEN,LINETHICK2;

AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:=DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;
支A:=DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA;
支B:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN;
{高低连线支撑压力}
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
A2B:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2B,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
压1:=DRAWLINE(D1,H,S11,H,1),COLORGREEN;
压2:=DRAWLINE(D12,H,S112,H,1),COLORLIBLUE;
支1:=DRAWLINE(D2,L,U11,L,1),COLORRED;
支2:=DRAWLINE(D22,L,U112,L,1),COLORLIRED;
{变动支撑压力}
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ);
支C:=IF(BARSLAST(TJ1),REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压C:=IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;

{涨停表示}
LA:=BARSLAST(C>REF(C,1)*1.098);
LC:=REF(CLOSE,LA);
LO:=REF(OPEN,LA);
LAL:=REF(L,LA);
LAH:=REF(H,LA);

一涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,1);
双涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,2);
三涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,3) AND H>L;
策略1A:=EXIST((C/REF(C,2)-1)*100>20,2) AND COUNT(LC>LO,3)>=1 AND O<REF(C,1)  AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
策略1B:=EXIST(双涨停,3) AND COUNT(LC>LO,4)>=1 AND O<REF(C,1)  AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
DRAWTEXT(策略1A,LOW,'↖①'),COLORYELLOW;
DRAWTEXT(策略1B,LOW,'↖①'),COLORYELLOW;
{策略2:=EXIST(三涨停,5)  AND C>中  AND L<中*1.01618 AND C/REF(C,1)<1.05 AND HHV(H,5)/C>1.14;
DRAWTEXT(策略2,LOW,'↖②'),COLORYELLOW;}
角度:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
持有:=EXIST(一涨停,5) AND 角度>75 AND C>上 AND C>REF(C,1) AND C>上 ;
突破:=角度>75 AND C>上 AND C>REF(C,1) AND C>上 {AND (H/C)<1.038};
DRAWTEXT(持有,LOW,'↖龙'),COLORYELLOW;
STICKLINE(突破,O,C,1,0),COLORMAGENTA;

{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;


休闲老师  辛苦下   帮忙把主图里面 带有黄色的K线  变成普通的正常K线颜色   不影响带有龙字的提示         另外 主图带有价格数字的去掉     拿掉后   影响带有龙字的提示吗 ???

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2020-11-13 08:30 复制 查看全部楼层
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_11:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
X_A:=CROSS(X_7,X_11);
X_B:=CROSS(X_11,X_7);
X_12:=REF(X_8,1);
X_13:=REF(X_8,2);
X_14:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,2))/MA(CLOSE,32)*100)/3;
X_15:=X_8<-100 OR X_12<-100;
X_16:=X_8>100 OR X_12>100;
X_17:=20*MAX(X_8,X_16)*DMA(EMA(CLOSE,6),SUM(VOL,60)/VOL)/EXP(2*HIGH-LOW/3);
X_C:=CROSS(X_14,X_17);
X_D:=CROSS(X_17,X_14);
关键点:=X_A AND X_B AND X_C AND X_D;
X_E:=关键点;
X_18:=X_8>X_12 AND X_12<X_13 OR X_E;
慢进:=X_15 AND X_18;


A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),LINETHICK1,COLORMAGENTA;
操作线:=分水岭-(EMA(C,3)-分水岭),LINETHICK1,COLORYELLOW;
PM:=MA(C,5),COLORWHITE;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);

VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,30);
VAR4:=MA(CLOSE,60);
VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC:=INTPART(VARB*100)/100;
VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE:=EMA(VARD,9);
VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13:=REF(VARE,1);
VAR14:=VARE;
VAR15:=VAR14-VAR13;
VAR16:=REF(VARD,1);
VAR17:=VARD;
VAR18:=VAR17-VAR16;
VAR19:=OPEN;
VAR1A:=CLOSE;
白马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
黑马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
白马黑马共振:=白马剑 AND 黑马剑;
MA1:=EMA(CLOSE,5);
MA2:=EMA(CLOSE,10);
MA3:=EMA(CLOSE,20);
MA4:=EMA(CLOSE,30);
三线粘合剑:=CROSS(分水岭,操作线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;

HBXG:=慢进 AND 三线粘合剑;

操盘线:=MA(CLOSE,18);
角度:=ATAN((操盘线/REF(操盘线,1)-1)*100)*180/3.1416;
多头线:=EMA(C,1.5);
空头线:=EMA(C,5);
均衡线:=EMA(空头线,5);
XG2:=CROSS(多头线,均衡线) AND CROSS(空头线,均衡线) AND CROSS(多头线,操盘线) AND C>=REF(C,1)*1.015 AND 角度>=0 AND CROSS(C,MA(C,18)) AND MA(C,18)>MA(C,50);

XG:HBXG AND XG2;

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表