手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙合并一个选股

[通达信]
设置
997 2 狼要吃肉 Lv.3 发表于 · 2020-11-13 08:42 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股一
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_11:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
X_A:=CROSS(X_7,X_11);
X_B:=CROSS(X_11,X_7);
X_12:=REF(X_8,1);
X_13:=REF(X_8,2);
X_14:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,2))/MA(CLOSE,32)*100)/3;
X_15:=X_8<-100 OR X_12<-100;
X_16:=X_8>100 OR X_12>100;
X_17:=20*MAX(X_8,X_16)*DMA(EMA(CLOSE,6),SUM(VOL,60)/VOL)/EXP(2*HIGH-LOW/3);
X_C:=CROSS(X_14,X_17);
X_D:=CROSS(X_17,X_14);
关键点:=X_A AND X_B AND X_C AND X_D;
X_E:=关键点;
X_18:=X_8>X_12 AND X_12<X_13 OR X_E;
慢进:=X_15 AND X_18;


A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),LINETHICK1,COLORMAGENTA;
操作线:=分水岭-(EMA(C,3)-分水岭),LINETHICK1,COLORYELLOW;
PM:=MA(C,5),COLORWHITE;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);

VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,30);
VAR4:=MA(CLOSE,60);
VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC:=INTPART(VARB*100)/100;
VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE:=EMA(VARD,9);
VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13:=REF(VARE,1);
VAR14:=VARE;
VAR15:=VAR14-VAR13;
VAR16:=REF(VARD,1);
VAR17:=VARD;
VAR18:=VAR17-VAR16;
VAR19:=OPEN;
VAR1A:=CLOSE;
白马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
黑马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
白马黑马共振:=白马剑 AND 黑马剑;
MA1:=EMA(CLOSE,5);
MA2:=EMA(CLOSE,10);
MA3:=EMA(CLOSE,20);
MA4:=EMA(CLOSE,30);
三线粘合剑:=CROSS(分水岭,操作线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;

HBXG:慢进 AND 三线粘合剑;


选股二
VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
选股:CROSS(主力资金,0) AND CROSS(拉升资金,0.01)AND VOL/MA(REF(VOL,1),5)>2;

举报

扔鸡蛋(0) 回复

狼要吃肉
Lv.3
发表于 2020-11-13 09:23 复制 查看全部楼层
许昌舍得 发表于 2020-11-13 08:54
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSEX_12 AND X_120,0.8,0 ...

怎么一个都选不出来,麻烦再研究一下

附件

微信图片_20201113091949.png

举报

点亮(1) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-13 08:54 复制 查看全部楼层
X_1:=IF(CLOSE>REF(CLOSE,1),1,0);
X_2:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND X_1=1,1,0);
X_4:= (HIGH + LOW + CLOSE*2)/4;
X_5:=X_4*3+X_1*2-(X_2+X_1)*2+X_2-X_4;
X_6:=X_5+X_2-X_4;
X_7:=4*SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,X_6)-3*SMA(SMA((CLOSE-LLV(LOW,X_5))/(HHV(HIGH,X_5)-LLV(LOW,X_5))*100,5,1),3.2,1);
X_8:=(X_6-MA(X_6,14))/(0.015*AVEDEV(X_6,14));
X_11:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
X_A:=CROSS(X_7,X_11);
X_B:=CROSS(X_11,X_7);
X_12:=REF(X_8,1);
X_13:=REF(X_8,2);
X_14:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,2))/MA(CLOSE,32)*100)/3;
X_15:=X_8<-100 OR X_12<-100;
X_16:=X_8>100 OR X_12>100;
X_17:=20*MAX(X_8,X_16)*DMA(EMA(CLOSE,6),SUM(VOL,60)/VOL)/EXP(2*HIGH-LOW/3);
X_C:=CROSS(X_14,X_17);
X_D:=CROSS(X_17,X_14);
关键点:=X_A AND X_B AND X_C AND X_D;
X_E:=关键点;
X_18:=X_8>X_12 AND X_12<X_13 OR X_E;
慢进:=X_15 AND X_18;


A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),LINETHICK1,COLORMAGENTA;
操作线:=分水岭-(EMA(C,3)-分水岭),LINETHICK1,COLORYELLOW;
PM:=MA(C,5),COLORWHITE;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);

VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,30);
VAR4:=MA(CLOSE,60);
VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC:=INTPART(VARB*100)/100;
VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE:=EMA(VARD,9);
VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
VAR13:=REF(VARE,1);
VAR14:=VARE;
VAR15:=VAR14-VAR13;
VAR16:=REF(VARD,1);
VAR17:=VARD;
VAR18:=VAR17-VAR16;
VAR19:=OPEN;
VAR1A:=CLOSE;
白马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
黑马剑:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.8,0);
白马黑马共振:=白马剑 AND 黑马剑;
MA1:=EMA(CLOSE,5);
MA2:=EMA(CLOSE,10);
MA3:=EMA(CLOSE,20);
MA4:=EMA(CLOSE,30);
三线粘合剑:=CROSS(分水岭,操作线) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;

HBXG:=慢进 AND 三线粘合剑;



VAR1Q:=(HIGH+LOW+CLOSE*2)/4;
VAR21:=EMA(VAR1Q,21);
VAR31:=STD(VAR1Q,21);
VAR41:=((VAR11-VAR21)/VAR31*100+200)/4;
VAR51:=(EMA(VAR41,89)-25)*1.56;
VAR61:=EMA(VAR51,5)*1.22;
VAR71:=EMA(VAR61,3);
VAR81:=3*VAR61-2*VAR71;
VAR1A1:=IF(CROSS(VAR61,VAR81) AND CROSS(VAR71,VAR81) AND CROSS(VAR71,VAR61),1,0);
VAR1B1:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C1:=EMA(VAR1B1,21);
VAR1D1:=(VAR1B1-VAR1C1)*10;
VAR1F1:=POW(VAR1D1,3)*0.1+POW(VAR1D1,2);
拉升资金:=IF(VAR1D1>0.015,VAR1F1,0)/45;
VAR91:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR101:=EMA(VAR91,13);
VAR111:=2*(VAR91-VAR101);
主力资金:=POW(VAR11,3)*0.1+POW(VAR111,1);
选股:=CROSS(主力资金,0) AND CROSS(拉升资金,0.01)AND VOL/MA(REF(VOL,1),5)>2;


TJ:HBXG AND 选股;

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表