手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师指导一下:预警公式需要先后满足两个选股公式如何写?

[大智慧]
设置
1684 16 村里种树 Lv.2 发表于 · 2020-11-13 09:43 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
比如预警公式选股需要在满足条件A以后,再满足条件B,则选股成立。请问用哪个函数?是用IF函数吗?具体参数怎么设置?请老师指点。

举报

扔鸡蛋(0) 回复

村里种树
Lv.2
发表于 2020-11-14 18:59 复制 查看全部楼层
衷心感谢!尤其是许昌舍得老师仰慕已久。

举报

点亮(0) 扔鸡蛋(0) 回复

森GG777
Lv.4
发表于 2020-11-13 14:53 复制 查看全部楼层
{面积背离}
JC:=0-CCI;
绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);
红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF(CCI<0,BARSLAST(CROSS(CCI,0)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);
RS1:=CCI<0 AND REF(CCI,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
YY:=DYNAINFO(14)<0.09 AND DYNAINFO(14)>-0.09;
底背驰:=IF (CROSS(CCI,0),REF(Y1,1),0) AND YY;
条件成立:=COUNT(底背驰,2)>0;
AAA:=ABS(REF(C,1)-REF(C,2))/REF(C,2)>0.04 AND REF(V,1)<REF(V,2) AND REF(C,1)<REF(C,2);
BBB:=C>REF(O,1) AND ABS(C-REF(C,1))/REF(C,1)*100>4 AND C>REF(C,1);

A成立:=(条件成立 AND AAA);
T:=BARSLAST(A成立);
XG:COUNT(BBB,T)=1;

参考许昌舍得的老师思路,试一下



查看全部打赏
  • 村里种树+5理想币 : 很给力,投资愉快,理想因你而精彩;

举报

点亮(0) 扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2020-11-13 14:40 复制 查看全部楼层

供参考

A成立后的第一次B 成立



T:=BARSLAST(A);

XG:COUNT(B,T)=1;
查看全部打赏
  • 村里种树+5理想币 : 点赞,知识的价值在于分享,谢谢!

举报

点亮(0) 扔鸡蛋(0) 回复

森GG777
Lv.4
发表于 2020-11-13 14:09 复制 查看全部楼层
AAA:=ABS(REF(C,1)-REF(C,2))/REF(C,2)>0.04 AND REF(V,1)<REF(V,2) AND REF(C,1)<REF(C,2);
BBB:=C>REF(O,1) AND ABS(C-REF(C,1))/REF(C,1)*100>4 AND C>REF(C,1);
预警:AAA AND BBB;   再用这个做预警指标

举报

扔鸡蛋(0) 回复

森GG777
Lv.4
发表于 2020-11-13 14:08 复制 查看全部楼层
JC:=0-CCI;
绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);
红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF(CCI<0,BARSLAST(CROSS(CCI,0)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);
RS1:=CCI<0 AND REF(CCI,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
YY:=DYNAINFO(14)<0.09 AND DYNAINFO(14)>-0.09;
底背驰:=IF (CROSS(CCI,0),REF(Y1,1),0) AND YY;
条件成立:COUNT(底背驰,2)>0;  先用这个指标选股票

举报

扔鸡蛋(0) 回复

森GG777
Lv.4
发表于 2020-11-13 14:07 复制 查看全部楼层

{面积背离}
JC:=0-CCI;
绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);
红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF(CCI<0,BARSLAST(CROSS(CCI,0)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);
RS1:=CCI<0 AND REF(CCI,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
YY:=DYNAINFO(14)<0.09 AND DYNAINFO(14)>-0.09;
底背驰:=IF (CROSS(CCI,0),REF(Y1,1),0) AND YY;
条件成立:=COUNT(底背驰,2)>0;

AAA:=ABS(REF(C,1)-REF(C,2))/REF(C,2)>0.04 AND REF(V,1)<REF(V,2) AND REF(C,1)<REF(C,2);
BBB:=C>REF(O,1) AND ABS(C-REF(C,1))/REF(C,1)*100>4 AND C>REF(C,1);
XG:条件成立=1 AND AAA AND BBB;

指标能做,但你这样是选不出股票的,想矛盾了,唯一解决的办法,把面积背离的选出来放入自定义板块,用下面的指标做预警,达到条件就会自己跳出来

举报

点亮(1) 扔鸡蛋(0) 回复

村里种树
Lv.2
发表于 2020-11-13 13:03 复制 查看全部楼层
森GG777 发表于 2020-11-13 12:15
把两个指标发上来

谢谢拉谢谢拉

举报

扔鸡蛋(0) 回复

村里种树
Lv.2
发表于 2020-11-13 13:02 复制 查看全部楼层
这是第二个:

AAA:=ABS(REF(C,1)-REF(C,2))/REF(C,2)>0.04 AND REF(V,1)<REF(V,2) AND REF(C,1)<REF(C,2);
BBB:=C>REF(O,1) AND ABS(C-REF(C,1))/REF(C,1)*100>4 AND C>REF(C,1);
AAA AND BBB;

举报

扔鸡蛋(0) 回复

村里种树
Lv.2
发表于 2020-11-13 13:01 复制 查看全部楼层
这是第一个:


TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
{面积背离}
JC:=0-CCI;
绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);
红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF(CCI<0,BARSLAST(CROSS(CCI,0)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);
RS1:=CCI<0 AND REF(CCI,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
YY:=DYNAINFO(14)<0.09 AND DYNAINFO(14)>-0.09;
底背驰:=IF (CROSS(CCI,0),REF(Y1,1),0) AND YY;
COUNT(底背驰,2)>0;

举报

点亮(1) 扔鸡蛋(0) 回复

森GG777
Lv.4
发表于 2020-11-13 12:15 复制 查看全部楼层
把两个指标发上来

举报

扔鸡蛋(0) 回复

村里种树
Lv.2
发表于 2020-11-13 12:02 复制 查看全部楼层
上面的图一逻辑关系可以用AND函数,图二则不能。

举报

点亮(1) 扔鸡蛋(0) 回复

村里种树
Lv.2
发表于 2020-11-13 12:01 复制 查看全部楼层
这就是二者的不同

附件

这就是二者的不同

这就是二者的不同

举报

扔鸡蛋(0) 回复

追牛服
Lv.3
发表于 2020-11-13 10:32 复制 查看全部楼层
A可以先用(>大于)成立

举报

扔鸡蛋(0) 回复

追牛服
Lv.3
发表于 2020-11-13 10:29 复制 查看全部楼层
村里种树 发表于 2020-11-13 10:20
A AND B句式的两个条件A和B 是同时满足的,我的要求是在A满足后,如果B再满足,则选股被触发。请注意,这 ...

有不同吗有不同吗

举报

扔鸡蛋(0) 回复

村里种树
Lv.2
发表于 2020-11-13 10:20 复制 查看全部楼层

A AND B句式的两个条件A和B 是同时满足的,我的要求是在A满足后,如果B再满足,则选股被触发。请注意,这里是要求有时间先后的。

举报

点亮(0) 扔鸡蛋(0) 回复

追牛服
Lv.3
发表于 2020-11-13 10:08 复制 查看全部楼层
a  and  b




/:M/:M/:M/:M/:M/:M/:M

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表